Installed 2 LiteOn SATA drives - Win7 64bit does not recognize - need help

Discussion in 'Windows 64bit' started by Jim McCants, Mar 3, 2010.

  1. Jim McCants

    Jim McCants Guest

    After my IDE drives were not seen by Win7 64bit, I bought 2 LiteOn Sata
    drives OEM from Newegg. I have SATA cables, and power cable to attach 2
    SATA cables from the drives. Attached both cables to the power cable (which
    is split - one power plug and hookup for the 2 SATA cables.

    Installed and still Windows Explorer will not see them. I've looked in my
    BIOS and have 3 options for the OnChip SATA device:

    IDE
    RAID
    AHCI

    I have it set to IDE, no good. I've tried AHCI and no good. I am not rigged
    for RAID and don't want it. Does anyone have any idea of what's wrong?

    Any help will be appreciated very much!

    Jim
     
    Jim McCants, Mar 3, 2010
    #1
    1. Advertisements

  2. OK, there's no reason at all that an IDE drive shouldn't be seen, and I
    doubt that you have a SATA controller that can't be seen, so let's try to
    get a bit more information. What type of computer are we dealing with here?
    Standard OEM, or a system you built? What brand of motherboard (and model),
    and what are the overall system spec's? When you added the drives, did you
    run Disk Manager to initialize and format them? Or were they already
    formatted drives?
     
    Charlie Russel - MVP, Mar 3, 2010
    #2
    1. Advertisements

  3. Hi,
    in BIOS, you should havee a look at the primary page (where u set up
    drives , date and time etc.) , and see wether the drives are detected or
    not.

    some BIOSes have a routine to start detection.

    jk
     
    Juergen Kluth, Mar 3, 2010
    #3
  4. Jim McCants

    Jim McCants Guest

    Charlie, I've tried to respond to you via the "Reply" option. That did not
    work, so here goes:

    My board is Abit IP35 Pro. System is home built. 4GB memory, 2 hard drives,
    Quad core 6600 processor. MY problem is NOT hard drive related. The problem
    is Win7 (64bit) will not 'see' my LitoOn OPTICAL drives, model IHAS124-04
    which I just received from Newegg. They are OEM. I have SATA cables and a
    split power plug that will accept both cable to power the drives. Upon
    bootup, no optical drives are seen, Win Explorer does not see them, neither
    does Device Manager. My BIOS is version #17, the latest that ABIT offers.

    How do I get these drives to be seen?

    Thanks,
    Jim
     
    Jim McCants, Mar 3, 2010
    #4
  5. Ah, optical drives. First, are they recognized in BIOS? Second, are any of
    the drives you already have running off that SATA controller? In
    devmgmt.msc, are there any ?'s or X's? If they are visible in the BIOS, and
    no sign of them in devmgmt, then I strongly suspect you're missing a mobo
    driver for your SATA controller.
     
    Charlie Russel - MVP, Mar 3, 2010
    #5
  6. Jim McCants

    Jim McCants Guest

    Charlie, in BIOS, I show 1 and 2 are hard drives, 3,4,5,6 show nothing. I
    don't see anything showing the SATA Optical drives. They are not in device
    manager. Where could I look in BIOS for the drives. I have them plugged in
    the same SATA channels that the hard drives are. Do I need them connected
    elsewhere?

    Thanks!
    Jim
     
    Jim McCants, Mar 3, 2010
    #6
  7. Jim McCants

    Jim McCants Guest

    I've tried to reply 3 times now and each time I get an error message when I
    'reply' or 'reply group'. Don't understand how to reply to the thread, no
    option is given for that.

    Bios does not show the optical drives. It show 6 channels and that is the
    number I have on the mobo. Channels 1&2 are for the IDE hard drives. I have
    the 2 optical drives in channels 3 &4. No other SATA options are available
    on my mobo. The drives are not showing in device manager - nor upon bootup.

    Thanks,
    Jim
     
    Jim McCants, Mar 3, 2010
    #7

  8. Don't use Reply (Ctrl-r) or Reply All (Ctrl-Shift-R); those send an
    E-mail to the poster. Use Reply to Group (Ctrl-g) only. Use Alt-A to
    see these Actions listed in a menu.

    There is a References: header in your post, so clearly one of your Ctrl-g
    worked. Charlie may tell you if he received an E-mail from you as a result
    of a Ctrl-r. ; )


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Mar 3, 2010
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.