Incoming Caller ID not working

Discussion in 'UK VOIP' started by Debbie Wilson, Oct 3, 2005.

  1. Hi - I'm a bit of a VoIP newbie so please forgive me if this is a bit
    confusing. I have a problem in that incoming caller ID for landline and
    mobile calls does not work with my newly-setup VoIP service. They just
    show up as 'Out of Area'. (I haven't tried any incoming VoIP calls as I
    don't know anyone else using it!)

    The configuration/equipment is as follows:
    - Thomson Speedtouch 716WL VoIP router
    - PlusTalk Anytime service from my ISP PlusNet
    - Caller ID is enabled on my BT line
    - CLIP is enabled on the router's 'telephony service' menu

    I am using a normal DECT handset with the basestation plugged into the
    Phone 1 port on the router. The router has a DSL connection and a
    separate PSTN connection to an XF-1e ADSL filter which I specifically
    got to allow caller display to work (it has been working fine
    previously). The filter then plugs into the BT wall socket as per
    normal. The call quality is good both incoming and outgoing, it's just
    that incoming caller ID is not working as it should. It's very important
    to me as I'm a freelance illustrator and really want to know who's
    ringing to hassle me about deadlines, before answering ;-)

    Can anyone help at all? Thanks very much -

    Debbie Wilson, Oct 3, 2005
    1. Advertisements

  2. Debbie Wilson

    Brian Guest

    There are people about who are skilled in explaining how caller ID is
    carried across networks but I'm probably not one of them. However, that
    'Out of Area' would appear to be a message used in the USA. Quoting

    'If a caller is in an area that does not have Caller ID technology or
    the call is routed through machinery that is not equipped with Caller ID
    technology, a message reading "Out of Area" will appear on your Caller
    ID display screen.'

    I assume you get 'Out of Area' when contacting your voip phone from your
    own BT line or mobile, so I suggest you contact PlusTalk as they are
    responsible for passing the caller ID.

    Brian, Oct 3, 2005
    1. Advertisements

  3. Debbie Wilson

    LJ Guest

    I've got exactly the same issue with a new ZyXEL 2602HWL-61C. CLI for VoIP
    calls shows up fine on the DECT phone I've got plugged in. CLI is
    definitely on the BT line because it comes up on a standalone CLID I've got
    connected between ADSL filter and router, but doesn't show up on the DECT
    phone. (I've tried it without the standalone CLID just on case that was
    affecting it, but no change). I've emailed ZyXEL support about it this

    Maybe you could plug in a standalone CLID temporarily?

    LJ, Oct 3, 2005
  4. Debbie Wilson

    Sean Guest

    Sadly it is not likely it will ever work. I've used BT VoIP boxes, with
    PSTN connectivity, and they work with a relay. They are on VoIP all the
    time, unless there is a power cut, or the user presses a key which has
    been assigned. When a incoming call comes through on a BT line the CLI
    is sent before the ring voltage, the relay does not switch over until
    the ring is sent. So if your using a cable line (with american CLI) it
    will work, because the phone rings, the relay clicks over, the CLI goes
    thru, the phone rings again. I don't know if what i am blabbering on
    about will help anyone, but BT CLI is not good with VoIP to PSTN
    connectivity. Best to use an additional telephone :)
    Sean, Oct 3, 2005
  5. Same situation here. CLI definitely working, and if I plug the DECT
    phone directly into the filter - BT socket, it works on that. But when
    plugged into the router it shows 'Out of Area'. I've emailed Speedtouch
    support and also Plus Net but neither have come back so far.
    Have just fetched my old CD30 out of the loft and connected that back
    up. Even that was very temperamental, and after a lot of fiddling around
    it is only working when plugged into the same microfilter as the DSL
    line into the router. If the router's DSL and PSTN lines share one
    filter, the CD30 won't work on another one on its own. Bizarre. I now
    have it sitting next to the DECT phone so at least there is some kind of
    ID, though not as good as having the address book display on the DECT.

    Thanks for your help -

    Debbie Wilson, Oct 3, 2005
  6. Thanks Brian, useful info there. Yes, it's 'Out of Area' when I ring the
    VoIP phone from my mobile. It's odd because as this router has an
    incoming PSTN line, incoming landline/mobile calls basically go from BT
    line to router to DECT phone. So I am wondering if it's some fault or
    seting on the router that isn't working properly? I have emailed
    Speedtouch today about this... see if they reply.

    Debbie Wilson, Oct 3, 2005
  7. So the phone misses the CLI as it's whizzed through before it knows it's
    got an incoming call... if the router was on PSTN by default, instead of
    VoIP, it would be OK for CLI, except you'd have to probably press a
    button or whatever to make a VoIP call. I think I sort of understand :)
    If so then it's not going be be solvable, as you say. Guess I'll have to
    stick with the CD30 for now.

    Thanks Sean -

    Debbie Wilson, Oct 3, 2005
  8. Debbie Wilson

    LJ Guest

    That makes sense. Surely it would make more sense to have the relay set to
    the PSTN line until a VoIP call comes in - that way the BT pre-ring CLI
    would get through... I guess the problem is that that would make it more
    complicated when the phone goes off hook to make a call - the router would
    have to quickly disconnect from the PSTN to stop the call going that way.
    Heh, true but the idea was to route it all by a nice DECT phone rather than
    have two handsets! ...and anyway it says here on the router box:
    "Telephony Features: Caller ID" ! ;)

    LJ, Oct 3, 2005
  9. Debbie Wilson

    LJ Guest

    No problem - guess it's better than nothing while we wait for the various
    support departments to come back to us. Doesn't sound promising based on
    what Sean posted though :/

    LJ, Oct 3, 2005
  10. Debbie Wilson

    Sean Guest

    Yeah, i've tried this, but telephone calls are like buses, non for ages,
    then loads at once. So i would miss calls if i used one handset for 2
    lines. Also it's useful to be able to make more than one call at a time :)
    Sean, Oct 3, 2005
  11. My CD30 has now stopped displaying any information too - seems to be
    totally random, whatever combination of plugging-in of equipment,
    whether it works or not! It is going straight into the ADSL filter to
    the BT socket, and shows nothing, and the DECT phone happily telling me
    'Out of Area'.... arghh!!

    Debbie Wilson, Oct 3, 2005
  12. Debbie Wilson

    LJ Guest

    Well I've got voicemail on the VoIP - the PSTN would just get an engaged
    tone (I don't fancy BT's 1571). Anyway, two calls at once sounds far too
    much like being at the office!

    LJ, Oct 3, 2005
  13. Debbie Wilson

    LJ Guest

    Pesky telephones! If you've already tried unplugging everything else,
    whatever's left has to be faulty *g* I've heard of duff filters stopping
    CLI from getting through - have you got more than one?

    LJ, Oct 3, 2005
  14. Ah yes - been through that in the past ;-)
    Got myself three XF-1e filters previously which have been doing an
    excellent job of allowing Caller ID to work.

    Interesting thing though, I unplugged the CD-30 in disgust and plugged
    in an old Philips Onis DECT phone to the BT line instead (with filter).
    It *does* show the caller ID (number only) although the line quality is
    bad. Very odd! Must mean something but have no idea what, or how it
    would help.

    Debbie Wilson, Oct 3, 2005
  15. Debbie Wilson

    LJ Guest

    Running out of things to suggest - have you tried unscrewing the faceplate
    on the main socket and plugging directly into the socket behind?

    LJ, Oct 3, 2005
  16. No... that's actually in a different room to the rest of this setup so
    would be tricky. Thanks for all your suggestions anyway, much
    appreciated! Am now waiting for two different tech support people to get
    back to me.... some day :)

    Debbie Wilson, Oct 3, 2005
  17. Debbie Wilson

    LJ Guest

    I got a reply from ZyXEL saying they were aware of the issue and working on
    a new firmware release. No date for the new release, but they said it was
    in late beta... ;)

    LJ, Oct 8, 2005
  18. Interesting... maybe Speedtouch will be working on the same. We live in
    hope :)

    Debbie Wilson, Oct 8, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.