i repost the message, because i never solved the problem :'(

Discussion in 'Cisco' started by TechMan, Jul 23, 2003.

  1. TechMan

    TechMan Guest

    hi guys, i've a nat prob. with my 837.
    Cisco 837 connects by adsl correctly, but if i try to nat a pc 10.10.10.70
    (in which i have a web server) nothing appears, i cannot see webserver.
    this is the cfg, something wrong?
    thanks to all ;-)


    !
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname 837_KARMA
    !
    enable secret 5 xxxxxxxxxxxxxxxxxxx
    enable password 7 xxxxxxxxxxxxxxx

    ip subnet-zero
    no ip domain lookup
    ip name-server 195.110.128.1
    !
    ip audit notify log
    ip audit po max-events 100
    !
    !
    !
    !
    interface Ethernet0
    ip address 10.10.10.111 255.255.255.0
    ip nat inside
    no cdp enable
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/75
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    dsl power-cutback 0
    !
    interface Async1
    no ip address
    !
    interface Dialer0
    no ip address
    shutdown
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp pap sent-username xxxxx password 7 xxxxxxx
    !
    ip nat inside source list 10 interface Dialer1 overload
    ip nat inside source static tcp 10.10.10.70 80 interface Dialer1 80
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    no ip http server
    !
    !
    access-list 10 permit 10.10.10.0 0.0.0.255
    access-list 100 permit tcp any any eq www
    dialer-list 1 protocol ip list 100
    !
    line con 0
    exec-timeout 120 0
    password 7 0207104E06140E
    login
    no modem enable
    stopbits 1
    line aux 0
    password 7 121811021F190D
    login
    stopbits 1
    line vty 0
    exec-timeout 120 0
    password 7 0207104E06140E
    login
    line vty 1
    exec-timeout 120 0
    password 7 0820585B040B04
    login
    line vty 2
    access-class 23 in
    exec-timeout 120 0
    password 7 050A121A2C5E4F
    login local
    line vty 3 4
    access-class 23 in
    exec-timeout 120 0
    login local
    !
    scheduler max-task-time 5000
    end
     
    TechMan, Jul 23, 2003
    #1
    1. Advertisements

  2. nat config looks good.
    Have you tried an extended ping to verify nat is working? Type ping and
    press enter. Use you ethernet ip out source interface.

    When you say you cannot see webserver what do you mean from the outside
    (www) coming through your 837. You won't be able to because you are nating
    to you dialer IP.

    Can you webserver surf the web if so Nat is working as configured.

    Ronnie
     
    Ronnie Higginbotham, Jul 23, 2003
    #2
    1. Advertisements

  3. TechMan

    TechMan Guest

    Something strange... i cannot ping from my router by dns but only by ip
    address.
    i'm asking to my friend in other place outside my office with separate
    dialup connection to try to reach my web server, only one time has reached
    but
    the surprise is that the config was wrong!!! how could nat and see my web
    server if i called an acl that does not exist?
    do you think my router has bugs?
     
    TechMan, Jul 23, 2003
    #3
  4. TechMan

    TechMan Guest

    i solved the problem, it was the gateway.
    Tnx for your reply however.
    :)
     
    TechMan, Jul 23, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.