I need some help verifying and cleaning up my Cisco PIX 501 Config

Discussion in 'Cisco' started by xvpnx, Jan 25, 2009.

  1. xvpnx

    xvpnx

    Joined:
    Jan 25, 2009
    Messages:
    3
    Likes Received:
    0
    Hi, ive configured a Cisco PIX 501 and I have done my best to get it right. I havent tested it yet, because I have no way of testing this until we migrate the lines and connection. So, therefore im seeking some help and advice wether my configuration is correct or if im missing something.

    Ive configured inside/outside, access-lists, an Internal Exchange server wich should recieve e-mails at port 25, Ive configured vpngroup and vpn users.

    I allso need help removing/cleaning the configuration file, so that its as neat as possible, but I dont know exactly what I can remove... Below is my initial configuration and I would really love that a Cisco tech with great knowledge like alot of you in this forum have, to lay eyes on this and help me get it right.

    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    hostname pix
    domain-name xxxx.com
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 192.168.2.253 Exchange
    name 192.168.2.2 my name
    access-list vpnn2it_splitTunnelAcl permit ip any any
    access-list vpnn2it_splitTunnelAcl permit ip 192.168.2.0 255.255.255.0 any
    access-list inside_outbound_nat0_acl permit ip any 192.168.100.0 255.255.255.240
    access-list inside_outbound_nat0_acl permit ip 192.168.2.0 255.255.255.0 192.168.100.0 255.255.255.240
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.100.0 255.255.255.240
    access-list outside_access_in permit tcp interface outside host Exchange eq smtp
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 80.80.80.154 255.255.255.0
    ip address inside 192.168.2.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool 192.168.100.1-192.168.100.10
    pdm location 192.168.2.2 255.255.255.255 inside
    pdm history enable
    arp timeout 14400
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 0 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface smtp Exchange smtp netmask 255.255.255.255 0 0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    http server enable
    http my name 255.255.255.255 outside
    http 192.168.2.2 255.255.255.255 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map client authentication LOCAL
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup vpngroup address-pool vpnpool
    vpngroup vpngroup dns-server 192.168.2.254
    vpngroup vpngroup default-domain xxxx.com
    vpngroup vpngroup split-tunnel vpnn2it_splitTunnelAcl
    vpngroup vpngroup idle-time 1800
    vpngroup vpngroup password ********
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    username vpnuser1 password xxxxxxxxxxxxxxxx encrypted privilege 15
    username vpnuser2 password xxxxxxxxxxxxxxxx encrypted privilege 5
    terminal width 80
    Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    I hope to hear from you, and many thanks.
     
    xvpnx, Jan 25, 2009
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.