I can get internet but I can't share files.

Discussion in 'Wireless Networking' started by Guest, Jun 10, 2006.

  1. Guest

    Guest Guest

    Well, I recently got a laptop. I have had a wireless router for about a year
    now so when I got the laptop I set up the connection. Everything works fine
    with the internet, but I'm a bit confused on what I have to do to get file
    and printer sharing. It's an inconvience having to put files on my USB drive
    and move over to my desktop just to print.
    So could anyone tell me which network setup option I have to go to, to set
    up file and printer sharing for a wireless network? I have tried a few
    different ones but I don't know if they're meant for wireless and when it
    seems like I find the right one, it never works.

    Any help would be appreciated.
     
    Guest, Jun 10, 2006
    #1
    1. Advertisements

  2. Guest

    Malke Guest

    The fact that you have a wireless connection is irrelevant. You need to
    set up your local area network.

    Run the Network Setup Wizard on both computers, making sure to enable
    File & Printer Sharing, and reboot. The only "gotcha" is that this will
    turn on the XPSP2 Windows Firewall. If you aren't running a third-party
    firewall or have an antivirus with "Internet Worm Protection" (like
    Norton 2005/06) which acts as a firewall, then you're fine. If you have
    third-party firewall software, configure it to allow the Local Area
    Network traffic as trusted. I usually do this with my firewalls with an
    IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you would
    substitute your correct subnet.

    If one or more of the computers is XP Pro:

    a. If you need Pro's ability to set fine-grained permissions, turn off
    Simple File Sharing (Folder Options>View tab) and create identical user
    accounts/passwords on all computers.

    b. If you don't care about using Pro's advanced features, leave the
    Simple File Sharing enabled.

    Simple File Sharing means that Guest (network) is enabled. This means
    that anyone without a user account on the target system can use its
    resources. This is a security hole but only you can decide if it
    matters in your situation.

    Then create shares as desired. XP Home does not permit sharing of users'
    home directories (My Documents) or Program Files, but you can share
    folders inside those directories. A better choice is to simply use the
    Shared Documents folder.

    Malke
     
    Malke, Jun 10, 2006
    #2
    1. Advertisements

  3. Guest

    martin Guest

    If you've already tried several ways of setting up file and print sharing
    then maybe you have the same problem I had. I use zonelabs firewall and it
    doesn't allow file sharing etc in high security mode. Sometimes it doesn't
    even allow it in medium security and then I have to turn the firewall off to
    share files.

    I'm assuming you've checked file and print sharing is installed and ticked
    in the network Network settings setup. But just in case you haven't. Try
    this (I should point out that I'm totally new to networking so this will be
    very basic!)

    ControlPanel->Network Connections
    Right click on your network card->properties
    you should now have a list of services and protocols listed
    in there you should have File and printer sharing installed.
    Make sure there's a tick against the box as well. If it's not installed I
    think you can just click install. It will ask if you want a client or a
    protocol or a service. I'm not sure which one file and printer sharing comes
    under. Service maybe. I can't try it on mine to see as xp doesn't list
    services that are already installed in the install menu. But anyway, if you
    haven't got file sharing installed then thats your problem. If you have then
    maybe try sharing with your firewall disabled. Also have you actually set
    any folders on either of your computers to be shared. If not then nothing
    will show in your Network Places. To set a folder for sharing simply goto my
    computer. Select your hard disk. Pick a folder to share and right click on
    it. Select Sharing and security. Windows may warn you about sharing folders.
    If you select something like "I understand the dangers and want to share
    this folder anyway (I can't recall the exact words) then then dialog will
    open out a bit more and there should be a "share this folder" box. Check the
    box Click apply then you have a shared folder. You should now be able to see
    the folder you've choosen to share in My Network places on both machines.
    Press refresh a few times sometimes helps.

    If you've already tried all this I apologise for waqsting your time. Your
    post didn't give many details. Oh yes one last thing. Make sure both your
    pc's are set for the same workgroup name and both computers have different
    Computer names

    martin (complete newbie)
     
    martin, Jun 10, 2006
    #3
  4. Jack \(MVP-Networking\)., Jun 10, 2006
    #4
  5. Guest

    Guest Guest

    Thank you! I have Zone Alarm installes so I found that that was blocking my
    attempts to share files. Aftre shutting down Zone Alarm, everything works
    fine.

    I found in where I can insert trusted IPs, but I don't know how I find the
    IPs of my computers. So how do I do this? *Sorry, kind of a stupid question
    I'm sure.

    Thanks again.
     
    Guest, Jun 10, 2006
    #5
  6. Guest

    Guest Guest

    I figured it out. Thank you everyone for the help. It's all working now.
     
    Guest, Jun 10, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.