HTML/HTM icons

Discussion in 'Firefox' started by Ranjit, Apr 27, 2005.

  1. Ranjit

    Ranjit Guest

    Hi,

    I have been struggling with this problem for quite some time now.
    I have set FF as my default browser for quite some time now. When I
    first set is as the default all the HTML/HTM files rightly got set to
    the FF icon. But then after some time (I think momentarily IE accidently
    became the default browser - for 5 mins) all the HTML/HTM icons are just
    the windows default application icon (the white with blue bar at top). I
    tried changing them by going to Windows Explorer -> Folder options ->
    File types and explictly change the icons for the HTML files, but still
    no sucess.

    I got really puzzled when same thing happened with my office PC too. Any
    solutions?

    Oh, I have Windows XP pro on both the machines, if that helps.

    TIA
     
    Ranjit, Apr 27, 2005
    #1
    1. Advertisements

  2. Ranjit

    gadge Guest

    Ranjit said the following on 4/27/05 7:19 PM:
    Right-click on the required file whilst pressing <ctrl> at the same
    time. 'Open With ..' should appear in the menu. Select 'open with' and
    navigate to the firefox.exe icon. Should work ...
     
    gadge, Apr 27, 2005
    #2
    1. Advertisements

  3. Ranjit

    Ranjit Guest

    Hi gadge,

    I tried what u mentioned and even clicked on "always use the selected
    program to open selected kind of file", but somehow the html icons are
    still the default windows app. Not sure what's going wrong !!!

    Thanks anyways, do let me know if you have any more suggestions.
     
    Ranjit, Apr 27, 2005
    #3
  4. If you have TweakUI installed, there should be a "Repair Icons" option
    that might fix this.
     
    John Thompson, Apr 28, 2005
    #4
  5. Ranjit

    Doug G Guest

    I tried TweakUI's Repair Icons and all it did was rearrange my desktop
    icons. HTM and HTML files still have a generic icon but open in Firefox.

    I think a recent WinXP update messed things up.
     
    Doug G, Apr 28, 2005
    #5
  6. Ranjit

    Ranjit Guest


    Oh! good atleast shares the same problem.
    I even tried deleting the file types and then "Restoring them".
    Now they have IE icon but since I changed the "open with", they open up
    in mozilla. I think I can stay with the IE icon rather than the generic
    one :).

    Doug, do let me know if u find a better solution.
     
    Ranjit, Apr 29, 2005
    #6
  7. Ranjit

    pip78 Guest

    Have you tried reinstalling FF?
     
    pip78, Apr 29, 2005
    #7
  8. Ranjit

    Ed Mullen Guest

    Since I don't have the problem I can't really test this but it's what
    I'd try in your situation.

    - Make sure IE is set to NOT be the default browser, and is set to NOT
    ask to be set as the default, using Control panel - Internet Options -
    Programs tab. Close out the dialogue.
    - Make sure FF IS set as the default browser using Tools - Options -
    General. Close the browser.
    - Use XP's "Set Program Access and Default" on the Start menu to
    verify/set Firefox as the default browser. Close the dialogue.
    - Reboot
    - Before running FF, check in Windows Explorer to see what the icons now
    are. If necessary, open Tools - Folder Options - File Types tab -
    Advanced - Change Icon, and set the icon for the HTM and HTML (and any
    other related ones).
    - Reboot if you had to change anything in the last step.
    - Recheck the icons in Windows Explorer
    - Run FF
     
    Ed Mullen, May 4, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.