How to turn off "Auto Complete"

Discussion in 'Firefox' started by maradcliff, Dec 8, 2004.

  1. maradcliff

    maradcliff Guest

    I think thats the correct name for it.
    What I am referring to is when I start typing in the url bar, I begin
    typing www.go and I get and etc.

    I hated this feature in IE, and I hate it in firefox. I can type the
    url faster than using that thing. IE has a way to shut it off, I cant
    seem to find a way in Firefox, and want to get rid if it. It's simply
    distracting and annoying.

    maradcliff, Dec 8, 2004
    1. Advertisements

  2. maradcliff

    Moz Champion Guest

    First we have to ascertain which feature that is impacting your choice.
    From the looks of it, it appears to be internet keywords that is
    attempting to 'complete' your incomplete location.

    Domain guessing (adding a www. and .com prefix/suffix [configurable])
    only comes into play if IK doesnt work

    So in your case, turning off Internet Keywords would prevent much of the
    auto typing you now see.

    On Firefox you turn off Internet keywords by
    making (pref("keyword.enabled", false) using the about:config method

    That would leave you with 'domain guessing' turned on, which would
    attempt to add www and .com (configurable) to your typing. If this still
    bothers you, you can turn that off as well by
    browser.fixup.alternate.enabled - false,

    or configure the choices with the next two prefs
    browser.fixup.alternate.prefix - "www."
    browser.fixup.alternate.suffix - ".com"

    these can be changed directly in the prefs by use of the about:config
    method or changed via a user.js method as well.
    Moz Champion, Dec 9, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.