How to reduce the availability delay of a Catalist port

Discussion in 'Cisco' started by Eddie, Nov 20, 2003.

  1. Eddie

    Eddie Guest

    Hello,

    I am looking for the different management tricks that may help to
    reduce the time after which a Catalist port becomes available when you
    plug an host on it.
    I am using either a Catalist 2925 or 6513.

    By default you get a delay of about 50 seconds.
    Setting the port to fast forwarding mode, the delay is reduced to
    about 17 seconds.
    I have looked, without success, in various Cisco documents to
    understand what the Catalist is doing during these 17 seconds (all I
    need, in my case, when I plug a host on this switch is the half/full
    10/100M negotiation and then, an immediately operational port)
    It is possible to reduce even more this delay ?

    Thanks in advance for your help,

    Eddie
     
    Eddie, Nov 20, 2003
    #1
    1. Advertisements

  2. Hello, Eddie!
    You wrote on 20 Nov 2003 13:10:18 -0800:

    E> I am looking for the different management tricks that may help to reduce
    E> the time after which a Catalist port becomes available when you plug an
    E> host on it.
    E> I am using either a Catalist 2925 or 6513.

    E> By default you get a delay of about 50 seconds.
    E> Setting the port to fast forwarding mode, the delay is reduced to about
    E> 17 seconds.

    Looks like PAgP protocol. It takes about 15 second to negotiate Etherchannel.

    For IOS -

    switchport mode access

    PAgP is turning off by default on IOS based switches so if you have ~15 seconds
    delay look for channel-group command under given interface and remove it.

    For CatOS -

    set port channel port range mode off
    set trunk port range off

    There is a macro command for CatOS - "set port host" which turns on portfast and
    turns off PAgP and DTP.

    With best regards,
    Andrey.
     
    Andrey Tarasov, Nov 20, 2003
    #2
    1. Advertisements

  3. :I am looking for the different management tricks that may help to
    :reduce the time after which a Catalist port becomes available when you
    :plug an host on it.
    :I am using either a Catalist 2925 or 6513.

    :By default you get a delay of about 50 seconds.
    :Setting the port to fast forwarding mode, the delay is reduced to
    :about 17 seconds.
    :I have looked, without success, in various Cisco documents to
    :understand what the Catalist is doing during these 17 seconds (all I
    :need, in my case, when I plug a host on this switch is the half/full
    :10/100M negotiation and then, an immediately operational port)

    The port has to do speed and duplex negotiation, and has to
    do fast spanning tree. I do not know if there are other things.

    :It is possible to reduce even more this delay ?

    Locking the speed and duplex should help a bit. Disabling spanning
    tree entirely for the port (or the switch) should help more.
     
    Walter Roberson, Nov 20, 2003
    #3
  4. Hello, Walter!
    You wrote on 20 Nov 2003 21:45:40 GMT:

    WR> Locking the speed and duplex should help a bit. Disabling spanning tree
    WR> entirely for the port (or the switch) should help more.

    According to Cisco speed/duplex negotiation takes less that 1 second. It takes
    about 1 second for port to come up when portfast is enabled. Switching spanning
    tree off is a very bad idea - can you make sure that nobody will create spanning
    tree loop, intentionally or not?

    With best regards,
    Andrey.
     
    Andrey Tarasov, Nov 20, 2003
    #4
  5. :Switching spanning
    :tree off is a very bad idea - can you make sure that nobody will create spanning
    :tree loop, intentionally or not?

    It isn't -my- requirement that the port must come up in less than 17
    seconds. Someone who puts in a requirement like that must have
    A Very Good Reason and should be prepared for the consequences.
     
    Walter Roberson, Nov 20, 2003
    #5
  6. Hello, Walter!
    You wrote on 20 Nov 2003 22:34:37 GMT:

    WR> It isn't -my- requirement that the port must come up in less than 17
    WR> seconds. Someone who puts in a requirement like that must have
    WR> A Very Good Reason and should be prepared for the consequences.

    There is nothing special about Ethernet port coming up in less than 17 second.
    As I mentioned earlier today with portfast enabled it should take only 1 second.
    PAgP protocol adds 15 second delay, DTP - another 5 second before port gets
    handed over to spanning tree process. So making sure that they are disabled will
    do the trick.

    With best regards,
    Andrey.
     
    Andrey Tarasov, Nov 20, 2003
    #6
  7. Eddie

    phase90 Guest

    Do a "set port host" on the port. This macro automatically disable
    spanning-tree, trunking and
    channelling.


    Jerry
     
    phase90, Nov 21, 2003
    #7
  8. Eddie

    DMc Guest

    portfast is the command you want to use. It will cause the port to bypass
    the listening and learning stages. But you should ONLY use portfast on
    ports that connect to workstations and servers. You run the risk of
    accidentally causing a loop if you plug into a hub, switch or router with
    multiple connections to that switch.

    hth,
    DMc.
     
    DMc, Nov 21, 2003
    #8
  9. Eddie

    Ivan Guest

    An old Novell server?? :)

    Ivan
     
    Ivan, Nov 21, 2003
    #9
  10. Eddie

    Andre Beck Guest

    Hell. I've never come about these. Maybe due to me reflexively setting
    up any interface on 2950/3550s and other current Switch IOSes as
    "switchport nonegotiate" (no matter if access or trunk port)?
     
    Andre Beck, Nov 21, 2003
    #10
  11. Eddie

    Eddie Guest

    Thanks a lot for the various hints
    The "set port host", mentioned in several replies, was a really
    brillant command (all what I need included in a single command ...).
    I have set it on the specific port on which I've needed a very short
    availability delay and everything was fine after !
    Thanks again for your help,

    Eddie
     
    Eddie, Nov 21, 2003
    #11
  12. frans brinkman, Nov 21, 2003
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.