how to Print via USB with non USB (Serial port) Printer

Discussion in 'Computer Information' started by Mighty Magpie, Jan 25, 2006.

  1. Hello,

    My new computer only has USB ports and one of my printers is so old, it is
    not USB

    I have acquired a cable which apparently is idiot proof - not so!

    The cable fits the printer and the computer but should I have some drivers
    or something else to load?

    No drivers or software came with the cable and I wrongly assumed that i only
    had to plug it in to make it work.

    Help please would be appreciated


    TIA
     
    Mighty Magpie, Jan 25, 2006
    #1
    1. Advertisements

  2. Mighty Magpie

    Brian Guest

    since your printer is essentially Parallel you should be able to load the
    drivers for the printer and select the usb port as the print location in the
    driver setup. Without more info on the printer though that's about all I can
    guess. Your printer will not be automatically detected as a usb device since
    it is not really usb.
     
    Brian, Jan 26, 2006
    #2
    1. Advertisements

  3. Thanks for the response

    The printer is a Hewlett Packard Deskjet 510

    I have tried loading the drivers and have selected a USB port (tried
    several) but nothing works

    I simply get a message saying "error"
     
    Mighty Magpie, Jan 26, 2006
    #3
  4. Mighty Magpie

    Brian Guest

    Even when printing a test page?

    Unplug the printer from the computer

    Check to make sure you only have one instance of the printer installed,
    remove all the drivers so no printers are shown in the printers/faxes window
    (at least none related to the Deskjet)

    If you are familiar with the registry remove the usb reference for the
    printer in regedit (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB)
    there will be several hardware items under this tree starting with vid_,
    expand the tree and look on the right side for your deskjet, remove any you
    find. If you are not sure leave it installed (better safe than sorry), or if
    you are not sure about regedit dont use it, you can cause serious problems
    if you inadvertantly delete something.

    Restart and plug the printer back into the computer (it should be recognized
    by XP if all the registry entries have been removed)
    When XP tries to auto install cancel the setup

    Reinstall the drivers (download the latest for your OS (XP)) from www.hp.com
    Follow the prompts for the HP setup

    Here is a link to HP that has other setup info if you are interested:
    http://h10025.www1.hp.com/ewfrf/wc/...name=bpd09005&lang=en&cc=usdocs/bud09185.html

    Hope this helps
     
    Brian, Jan 28, 2006
    #4
  5. Many thanks for the info

    I shall try what you suggest

    (Yes, the message was appearing when trying to print a test page)

    Cheers
     
    Mighty Magpie, Jan 28, 2006
    #5
  6. When I looked via regedit I found no references at all to my printer
    (Deskjet 510)
    My other printers were visible but not this one

    I did find 4 instances of a "Bencent IEEE1284 Printer Cable (Device Desc -
    USB Printing support)

    Even using the FIND facility (CTRL+F) failed to locate any reference to my
    printer

    I shall locate the drivers you referred to and load them, and see what
    happens

    Cheers


    ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
     
    Mighty Magpie, Jan 28, 2006
    #6
  7. Mighty Magpie

    Brian Guest

    If that is the cable you are using to connect your printer then it would be
    safe to remove those entries. That cable is on the HCL for XP so it should
    be recognized again when re-connected. Whichever port (usb) the cable shows
    up on is the port you should select for your printer
     
    Brian, Jan 31, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.