how to configure 2nd router - please help

Discussion in 'Linux Networking' started by Adam, May 25, 2012.

  1. Adam

    Adam Guest

    Host OS: Ubuntu 10.04.4 LTS

    Trying to add the following wireless router ...
    http://www.mediabridgeproducts.com/store/pc/pdf/MWN-WAPR150N_User_Guide.pdf
    to my wired home network.

    Primary/existing (wired) router ...
    1) DHCP Server: Enabled
    2) Login (via PPPoE connection)
    3) IP address: 192.168.1.1
    4) Subnet Mask: 255.255.255.0

    Secondary/new (wireless) router ...
    A) DHCP Server: Disabled
    B) IP address: ???
    C) Subnet Mask: 255.255.255.0
    D) Other: ???

    Any ideas?
     
    Adam, May 25, 2012
    #1
    1. Advertisements

  2. Google?

    http://homecommunity.cisco.com/t5/Wireless-Routers/Connecting-two-routers-
    wired-the-definitive-answer/td-p/47006

    http://www.techrepublic.com/blog/doityourself-it-guy/diy-setting-up-
    wireless-access-points-as-repeaters-to-extend-wireless-range/141

    Make the second one an AP instead?

    http://www.dslreports.com/faq/11233

    http://www.speedguide.net/articles/how-to-set-a-wireless-router-as-an-
    access-point-2556
     
    *Hemidactylus*, May 25, 2012
    #2
    1. Advertisements

  3. Adam

    Adam Guest


    Thanks, yes, I tried searching but was confused by the many suggested ways
    to configure.
    And, I was surprised that your first URL said "Do not use the Internet/WAN
    port on the second router!"
    I don't understand it but it seems to be working so far.
     
    Adam, May 25, 2012
    #3
  4. Set the IP address of the second router to 192.168.1.2, set the DHCP range
    on the first router to 192.168.1.100-192.168.1.199. You can then
    use .3-.99 and .201-.255 for static IP addresses. Add entries for each
    router to /etc/hosts so that you can access them by name instead of
    numbers, also add all of your static IP machines to /etc/hosts.
     
    General Schvantzkoph, May 25, 2012
    #4
  5. Adam

    Adam Guest

    Thanks, now I have swapped the two routers so that
    the new (wireless) router is the primary one.

    Primary/new (wireless) router ...
    1) DHCP Server: Enabled
    2) DSL connection (via PPPoE)
    3) IP address: 192.168.1.2 (change to 192.168.1.2 to get print server
    working again?)
    4) Subnet Mask: 255.255.255.0
    5) UPLINK port connected to DSL modem
    6) LAN port connected to LAN (not UPLINK) port of secondary router
    7) MTU defaults to 1460 (should this be the same as the old router's MTU
    setting?)

    Secondary/old (wired) router ...
    A) DHCP Server: Disabled
    B) DSL connection (via PPPoE) (will setting both routers with login info
    cause conflict?)
    C) IP address: 192.168.1.1 (change to 192.168.1.2 to get print server
    working again?)
    D) Subnet Mask: 255.255.255.0
    E) UPLINK port (not used)
    F) LAN port connected to LAN port of primary router
    G) MTU set to 1492


    But, something broke the print server (probably because the gateway was set
    to 192.168.1.1).
    And, I can't login to the secondary/old router now.
     
    Adam, May 25, 2012
    #5
  6. Only the gateway router should be doing PPPoE to the DSL connection. The
    two routers must have different IP addresses, use .1 for the gateway
    router (the one connected to the DSL modem) and .2 for the other router.
    If you've changed the IP addresses on the routers make sure that you
    reboot them, better yet power off both routers and the DSL modem for about
    30 seconds, then you can power them all back on.
     
    General Schvantzkoph, May 25, 2012
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.