How do you stop a web page from "re-directing"

Discussion in 'Computer Information' started by Ben, Jan 1, 2008.

  1. Ben

    Ben Guest

    I was doing a google search and found a web page I wanted to read.

    When I click on the link, the desired page appears, and then is redirected
    to an online vendor.

    I want to stop the redirecting - so I can read the article.

    Any ideas.

    Here is the link:

    thanks for your help!
    Ben, Jan 1, 2008
    1. Advertisements

  2. Ben

    Paul Guest

    There are small programs that will get the contents of a URL, and store
    it to a file. This is one example.

    WinWGet - GUI for wget

    I tried the GUI but wasn't particularly impressed. The purpose
    of a GUI, is to make things more convenient, and this one failed.

    Notice that, inside that program install, is a copy of GNU WGET. You
    can run the wget.exe in the wget directory, in a DOS command shell.

    For example, while CD'ed to the wget directory, in a DOS command shell, you can do:

    wget -O output.txt

    The reason for renaming the file to "output.txt", is so that if you click on it
    in Windows, no web browser is started, or looks at it.

    You can open the "output.txt" file with Wordpad. Wordpad is needed, because
    the wrong line termination sequence is being used for the downloaded text.
    It doesn't look right in Notepad.

    It looks like a teaser page, and the main job of that page is to get you
    to click on it.

    You can think of "WGET" as being the equivalent of "FTP" but
    for HTTP protocol. There are other programs that do something

    Lynx is a text browser, that runs in a terminal window. Too
    bad the Windows version is not immediately available.

    To use Lynx, you press the "G" key, short for "Go", and then you'd
    type in http://some.web.addy to get your stuff.

    This is what a session in Lynx looks like. I used to use this
    program at work, in a Unix environment.

    I'm not sure of the security status of any of these tools! If you were
    thinking of visiting a site known to have viruses or Trojans, these
    tools might not be protected from them, so you would still be
    running a risk.

    Have fun,
    Paul, Jan 1, 2008
    1. Advertisements

  3. Ben

    Ben Guest

    Thanks Paul!

    I probably will just forgo all the trouble. But it is good to know about

    Ben -O
    Ben, Jan 1, 2008
  4. Ben

    bambam Guest

    Turn off javascript.
    Even better, download Firefox-

    Then get the NoScript extension-
    bambam, Jan 2, 2008
  5. Ben

    Mr. Arnold Guest

    You might be able to stop the redirect with the Host file. This is a
    misusage and abuse of the Host file, but you can block a site.

    The IP you would redirect to would back to your computer and not
    the the site's IP

    The entry in the Host file would be like this.
    Mr. Arnold, Jan 2, 2008
  6. Dude!!!!!!!!

    Click the STOP button in your browser before it redirects!!

    It works for your link, and works for any link that does that. I`ve
    always done that.

    The only way it can go wrong, is if it is a big page - like many
    pictures or loads and loads of links, and you click STOP - too early -
    i.e. before it has completely loaded. So then you won`t get the full
    page. So if you suspect that is the case, then click STOP at the last
    milisecond before it redirects!

    Other related things one could try is find the article in the Google
    Cache, and another is But I think both of those can
    redirect.. They are just older versions of the article, and may have
    been written prior to the redirection.
    jameshanley39, Jan 2, 2008
  7. Ben

    Jrludi Guest

    In Internet Explorer, go to Internet Options, click on the Security
    tab, click on "Restricted Sites", then click the "Sites" button below
    the panel, enter the site you want to block in there and save it. Now
    it should not Meta-Refresh. If it still does go back to the security
    tab, click "Restricted sites" again and then click "Custom level.."
    button down farther toward the bottom. Scroll down to Miscellaneous
    and about the second one will be "Allow META-REFRESH", make sure this
    is disabled. I hope this takes care of the problem. Good Luck.
    Jrludi, Jan 2, 2008
  8. Ben

    Ben Guest

    Hey Bambam

    Your advice worked. I used Mozilla and turned off Java Script. I read the
    page no problem.

    How do you turn off Java in IE?

    Thanks, Ben
    Ben, Jan 2, 2008
  9. Ben

    bambam Guest

    Java and javascript are completly different animals.
    Stick with your new browser for a while. ;)
    bambam, Jan 3, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.