How do you change the workgroup - TL-WDR3600?

Discussion in 'Network Routers' started by David, Nov 17, 2014.

  1. David

    David Guest


    Running Windows 8.1

    I am having trouble seeing the SMB share on my TPLink TL-WDR3600.
    I suspect that it may be because the router is in the work group WORKGROUP
    and my PCs aren't.

    On my Buffalo WZR-600DHP2 I have a setting for the work group but I can't
    find one on the TPLink router.

    The TPLink is being used as an AP so is connected LAN <-> LAN with the

    FTP works.
    The router is visible in Windows Explorer as a media device.
    I can manage the router via the LAN.
    I can use the router as an AP to get wireless devices onto the Internet.
    So IP address and wiring are all O.K.

    The only thing the router doesn't seem to do is participate in an SMB

    As far as I can see this would be the same problem if the TPLink was the
    main or only router.

    One puzzle - the instructions (XP/Vista/W7) say to use the Run dialogue
    box to issue the command "\\".
    I am assuming that this is a network location but haven't yet worked out
    if you can use this syntax if you aren't in the same work group.


    Dave R
    David, Nov 17, 2014
    1. Advertisements

  2. David

    David Guest


    net use p: \\\volume9 /user:workgroup\david

    This successfully maps the router's drive to my P: drive.
    Works both for W7 and W8.1.

    Windows 8.1 can actually see the router as a network device and a Media
    Device but Windows 7 can't even do this.

    I have concluded that the "" syntax must be tied in to the
    router acting as a DNS server as it is also used to open the management
    web page on the router.
    As I am using it an AP I am not using the WAN or DNS functions (which are
    closely linked, along with NTP use).

    Just checked, and using "\\\volume9" suddenly shows the router
    up in the network part of Windows Explorer (Windows 8.1).

    So apparently the work group thing may be a red herring, and
    "" may just be a way of not requiring the user to know the
    volume name for the file share. Which only works if the router is also
    your DNS server.


    Dav R
    David, Nov 17, 2014
    1. Advertisements

  3. David

    VanguardLH Guest

    You sure didn't get added to your hosts file by some
    software you ran that came with the router? It merely provides an
    alternate means of accessing the router using a hostname instead of an
    IP address. The router makes thinks they're providing a convenience by
    altering your hosts file so you can use a name instead of an IP address.
    As you found out, the UNC string with an IP address work. That doesn't
    involve any DNS server or your hosts file.

    It is possible the router's own DNS server (if it really has one versus
    just failing the lookup and passing it upstream to the next DNS server)
    will resolve the hostname ( to an IP address. I can't
    see how failing the lookup and passing it to the upstream (ISP's) DNS
    server would work. They wouldn't bother having an entry for
    "" so everyone with TPlink routers would get
    returned. Instead more likely is that the router shortcuts any DNS
    lookups (port 53) *if* the hostname in the lookup request is
    "". It will immediately return the IP address and no
    lookup request goes to the upstream DNS server. If this shortcut is how
    the router implements a pseudo-DNS lookup, and if you're disabling the
    router's DNS server (which apparently takes out the DNS shortcut in the
    router on just the "" lookup) then an entry in your hosts
    file should suffice to do the same thing. The OS will check the hosts
    file before it generates a DNS lookup request to send out on the

    In case you didn't know, you might get a focused community by posting
    over at TPlink's forums (

    " successfully maps the router's drive". Huh? The router has an
    inbuilt drive? No such mention at the web page describing that product
    ( You
    mean a NAS drive assigned a "volume9" in the router (so you can use a
    lookup instead of the IP address to the NAS drive)? Or maybe a USB
    drive plugged into the router's USB ports where you gave it the name
    Volume9 somewhere in the config of the router or the volumeID of the USB
    drive is "volume9"?
    VanguardLH, Nov 17, 2014
  4. David

    David Guest

    Sorry, posted in several places including the TPLink forum.
    I plugged a USB pen drive into the router to provide storage.
    The router (as far as I can tell) assigned it the name "volume9".
    It has been connected to another router and a PC but as far as I know it
    hasn't been given a label of "volume9".
    Nothing given by me in the config of the router.

    It is working but not by following the instructions from TPLink.


    Dave R
    David, Nov 17, 2014
  5. David

    VanguardLH Guest

    User Guide

    On page 64:

    Volume - The volume name of the USB drive the users have access to.
    Volume 1-8 is mapping to USB port1, and Volume 9-16 is
    mapping to USB port2.

    Says the same thing back on page 59 but other info on setting up the
    guest account. I strongly recommend you change to a strong password.

    So you have the USB drive plugged into the routers "USB2" port. Looks
    like you could add a USB hub and plug up to 8 devices into each hub with
    the hub then connected to the router's USB port.

    When you are in the router's config screens, is the USB drive listed
    there (when it is plugged in) enabled for sharing?
    Page 10 of the User Guide mentions the URL. If
    they (via software) did not update your hosts file to add that hostname
    then their DNS server (it really doesn't have one but fails the request
    and passes the request upstream) is shortcutting the DNS request by
    passing back the currently LAN-side IP address of the router. Your
    client makes a DNS request but the router intervenes and sends back its
    IP address.

    If I try to use that URL, my ISP's DNS server takes me to a squatter
    site (someone knew about that domain and registered it for themself and
    hopes to sell it off one day, like to TPlink). I could add:

    to my hosts file to have my web browser go to my router via its IP
    address when I entered in the web browser's
    address bar. I could use any hostname in my hosts file to do that
    lookup without the DNS request ever getting sent out from my computer.

    If they are doing the shortcut via their DNS server and because you
    disabled it then you'll have to use the hosts file to use that URL, or
    just keep using the LAN-side IP address of your router.

    In Windows 7, is SMB enabled?

    Are you using a homegroup on Windows 7?
    VanguardLH, Nov 17, 2014
  6. David

    David Guest

    Thanks for the comprehensive response.

    As far as I am aware SMB is working fine.

    I have four main systems:
    1 * Windows 7 server(ish) with two 3TB shared discs
    2 * Windows 8.1 laptops
    1 * Windows 8.1 floor stander

    The W7 system has insisted on creating a Homegroup but I have more or less
    ignored it.
    All four systems are set up in the same WorkGroup (which is not WORKGROUP)
    and they can all see each other.
    The W8.1 systems haven't joined the HomeGroup.
    File sharing works, printer sharing works, and they can see each other as
    network PCs in Windows Explorer.

    The router doesn't appear in the same Network list.

    This I think is down to the router being hard coded to be in the WORKGROUP
    WorkGroup - but again I can't be certain.
    Just putting in the IP address in the Run prompt makes the router
    available as a file server for the life of that Windows Explorer session.
    So you don't need to know the WorkGroup to access the drive.
    Just checked and the "net use" command works without the additional
    parameters " /user:workgroup\david" so the whole WorkGroup thing seems
    pointless apart from possibly making the router appear as a network host
    in Windows Explorer.

    Bottom line - the instructions in the manual could be a little more


    Dave R
    David, Nov 19, 2014
  7. David

    VanguardLH Guest

    I looked again in the online manual and didn't see anything, like in the
    LAN config screen, on how to assign a workgroup or homegroup name to the
    router. It isn't really a host so it is not surprising that many
    settings are fixed, like workgroup name.

    Do your Windows accounts have blank passwords? That is, you have a
    username defined but do you have a non-blank password defined for that
    account (when using it to access resources on differently named
    VanguardLH, Nov 19, 2014
  8. David

    David Guest

    Ummm....I'm not sure how it isn't a host if it offers file sharing,
    printer sharing and media sharing to the network.
    It may be that I am misunderstanding your meaning of 'host' in this
    I assumed that an SMB host is one which offered resources to an SMB client.

    All the four Windows computers are in the same WorkGroup, share common
    user IDs and passwords, and are set to use passwords when file sharing.

    Up to now I have always added new devices (including the Buffalo router)
    to my chosen WorkGroup.

    Do most people use the default "WORKGROUP" name?
    It seemed logical to change the name and then set passwords so that your
    PCs are not trivially obvious to an intruder (or guest) on your network.
    By "guest" I mean a visitor who has been added to the main network, not
    someone using the newer "guest LAN" feature of most modern routers.

    Oh, I had passwords turned on at the router but turned off during testing.
    The router also has a user id and password (same as my Windows account)
    which work for FTP but I haven't tested combinations of password on/off
    and different user IDs yet to see if the id/password makes any difference.


    Dave R
    David, Nov 20, 2014
  9. David

    Char Jackson Guest

    I don't know about most people, but I started ignoring workgroups (and now
    homegroups, as well) a very long time ago. I simply use IP addresses, in
    which case workgroups/homegroups become completely irrelevant.
    Char Jackson, Nov 20, 2014
  10. David

    VanguardLH Guest

    It's been way too long since Microsoft introduced workgroups but my
    recollection was that it was there way in a home network to provide the
    segmenting used in corporate networks to isolate or restrict traffic.
    Unless sharing was enabled, you couldn't get to a host in a different
    workgroup. The hosts in workgroup WorkAtHome were off-limits to the
    hosts in workgroup KidsPuter. You're in a domain at home and when using
    workgroups so this seemed a simpleton's means of isolating the hosts
    without express permission (sharing, passwords). It wasn't that great
    as you noted that just using a UNC with IP address might solve that (but
    it obviously wouldn't obviate the other host must express its desire to
    share to let you do the sharing). Does UNC with IP eliminate the need
    for login credentials to access the share on the other host (that
    expresses a share)?
    VanguardLH, Nov 21, 2014
  11. David

    Char Jackson Guest

    I think 'restrict' might be too strong a word. It's more about being able to
    graphically see the other hosts and browse to each of them by simply
    clicking on the object that references them. To a certain extent, if you
    can't see a certain host in your Network Neighborhood or whatever they call
    it now, you're possibly less likely to even know the host exists and by
    extension less likely to try to access a shared resource there. But if you
    do know that it exists, and you know its IP address, then the presence or
    absence of a workgroup/homegroup makes no difference.
    It's still true that *something* has to be shared, else you can't even
    Agreed. Something must be shared.
    No, you still need login credentials, unless the resource is shared with
    Everyone. Even then, I assume credentials are flying across the wire, but
    probably just ignored.
    Char Jackson, Nov 21, 2014
  12. David

    Daniel James Guest

    It's been a while since I looked at this stuff in detail, and
    newfangled nonsense like "Homegroups" may have changed things, but ...

    As you say here, a share has permissions and a user on another PC has
    to have permission to access that share in order to be able to do so.

    Unfortunately the default permission is for "Everyone", so by default
    anyone who can access you PC (by IP address, by knowing its hostname,
    etc.) can access shares.

    However, you can remove the default permission and set up new
    permissions based on users of the computer that hosts the share. That
    means that only people who can log on to that PC and who have access to
    that folder (the share point) can access it, either locally or over the

    What I do is to create a Group called "LanUsers" (or something similar)
    and create shares so that they can only be accessed by members of that
    group. Then I can give membership of the group to any user I want to
    have access to the share.

    I can also separate Work and Play shares by using different groups --
    just as I can use permissions on a particular PC to give some user(s)
    access to my confidential files while only allowing others access to
    Solitaire and Freecell!

    "Homegroups" do complicate things, though -- Microsoft are always
    adding "simplified" networking mechanisms to make it easier for naive
    users to get into a mess while ensuring that experienced networking
    professionals can't work out what the hell is going on -- my advice is
    to disable them entirely.

    Daniel James, Nov 21, 2014
  13. David

    David Guest

    On Fri, 21 Nov 2014 11:33:47 +0000, Daniel James wrote:

    Now looking for the upvote button.

    Homegroups was an absolute belter because it only worked with W7 and above
    so was as useful as an udder on a swing door for any network with Vista or

    When I have a moment I will test to see if the "security" mechanisms on
    the router are any good i.e. with passwords turned on it blocks any user
    without a matching ID/password on the router from accessing the SMB share.

    On a better news front one reason I bought this particular router is
    because it looked a useful test bed for DD-WRT and the like.


    Dave R
    David, Nov 21, 2014
  14. David

    Char Jackson Guest

    I don't think I've found that to be the case in Win 7 and 8. When I create a
    new share, by default it's shared with the Administrators group, of which I
    happen to be the only member, and it's shared with my user account, the
    account that initially created the share. If I want the Everyone group to
    have any kind of access, I have to explicitly configure that.

    Are you seeing different behavior?
    Char Jackson, Nov 21, 2014
  15. David

    Daniel James Guest

    Ah, quite right ... It seems that Win7, at least, lets you share with a
    Homegroup (either read-only or read/write) or "specific people" -- and you
    have to select which "people". I did say I hadn't done this for a while.

    Here on XP when you create a share it gets "Everyone" permission by default.
    I neither remember nor care what Vasti did.
    That's not what I'm seeing on 7 ... (Win7SP1 Enterprise).

    Daniel James, Nov 21, 2014
  16. David

    Char Jackson Guest

    Right, that's what I see as well.
    My user account is part of the Administrators group, so that may be why my
    default sharing permissions are Administrators and my own account.

    I haven't tried creating a new share from a non-admin account because I
    don't have such an account configured.
    Char Jackson, Nov 21, 2014
  17. By all means, pull the trigger and install DD-WRT in the box and be done
    with it. I strongly suspect you will then be able to assign the router
    to the workgroup of your choice once you locate the option.

    That is one reason all routers I purchase must be on the approved DD-WRT
    list and not listed as just a work in progress. True many of mine wind
    up with Tomato firmware but it's nice to have the option of replacing
    the crappy manufacturers firmware if I need an option that is missing.
    GlowingBlueMist, Nov 22, 2014
  18. David

    Daniel James Guest

    I had another looks ... and each of us is half-right!

    I hadn't noticed that when sharing with "Specific people" a default set
    of "people" had been preselected.

    I've run a couple of quick tests from my usual non-admin user account
    and from an admin account.

    It seems to me that the default set typically includes the owner of the
    folder being shared and the current user ... there aren't a lot of
    other users on my Win7 VM, but maybe it includes all users/groups that
    have access to the folder on the local system?

    I also notice that if an administrator right-clicks a system folder
    (such as "Program Files") the "Share with ..." menu pullout has a
    single entry "Advanced sharing", which looks much like the sharing
    dialog from XP.
    I always work from a non-admin account, and have done since Win2k. It's
    much easier to live in a non-admin world post-Vista with UAC than it
    used to be -- no more having to remember to "Run As ..." to do anything
    privileged -- but with UAC I'm not sure whether not being an
    Administrator still brings any worthwhile increase in security.

    Daniel James, Nov 22, 2014
  19. David

    Char Jackson Guest


    Thanks for playing with it and testing the results. It's good to know what
    others are seeing and how it fits into what I experience.
    Char Jackson, Nov 22, 2014
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.