How do I segment a Catalyst 2900XL

Discussion in 'Cisco' started by Jake, Sep 30, 2006.

  1. Jake

    Jake Guest

    Hi, I've need to segment out a catalyst 2900XL into 3 separate
    networks. What I need is as follows:

    Network 1:
    Ports 1-8 (port 8 is uplink)
    192.168.0.0 255.255.255.0

    Network 2:
    Ports 9-16 (port 9 is uplink)
    192.168.1.0 255.255.255.0

    Network 3:
    Ports 17-24 (port 17 is uplink)
    10.20.22.0 255.255.255.0

    I've been looking into vlans but everything I see seems to require a
    router on the other end that actually does the routing for the vlans
    and I won't have that available. The networks are all comming from
    three separate physical networks with assorted hardware upstream from
    my switch.

    Any ideas would be greatly appreciated.

    Thanks
     
    Jake, Sep 30, 2006
    #1
    1. Advertisements

  2. Jake

    Nicolai Guest

    Hi, I've need to segment out a catalyst 2900XL into 3 separate
    If the 3 vlans need to communicate you will need a router. Of not, a pure
    vlan setup will be fine.
     
    Nicolai, Sep 30, 2006
    #2
    1. Advertisements

  3. Then your actually not wrong. Create the three vlans and assign them to the
    ports as you described.

    The 3 vlans will not be able to see each other and will not be able to
    communicate from one vlan to another. The only issue can be that the XL
    switch is to old and do not have support for vlans.
     
    Martin Kiefer, Sep 30, 2006
    #3
  4. Something like the following, perhaps:

    int fa0/1
    description --- access port / network 1 ---
    switchport access vlan 101
    spanning-tree portfast
    no cdp enable
    !
    ! ports fa0/2..fa0/7 - similar to fa0/1
    !
    int fa0/8
    description --- uplink port / network 1 ---
    switchport trunk native vlan 101
    switchport mode trunk
    !

    Then similarly for network 2 ("vlan 102") and network 3 ("vlan 103").
     
    Andrei Ivanov, Oct 1, 2006
    #4
  5. Jake

    Jake Guest

    Thank you so much this is exactly what I was looking for. I was having
    trouble figureing out how to assign the ports to the vlans.

    Thanks again.
     
    Jake, Oct 1, 2006
    #5
  6. Jake

    Doan Guest

    Why trunk on int fa0/8 if no inter-vlan communication is needed?

    Doan
     
    Doan, Oct 1, 2006
    #6
  7. Exactly, do not use a different config for fa0/8, use the same for fa0/1 to
    fa0/8. And if I recall correctly the 2900xl's use ISL as their default
    trunking protocol and ISL tags all frames so the "switchport trunk native
    ...." statement will not work.
    My advise:

    int fa0/1
    description --- access port / network 1 ---
    switchport mode access
    switchport access vlan 101
    spanning-tree portfast
    no cdp enable


    for all ports and only vary the "switchport access vlan xxx" statement.

    Regards,
    erik
     
    Erik Tamminga, Oct 2, 2006
    #7
  8. Jake

    Jake Guest

    Thanks Everybody, your help has been great. I got this working with
    the following config:

    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname DellRackSwitch
    !
    enable secret <removed>
    !
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    !
    !
    interface FastEthernet0/1
    description ---CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/2
    description --CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/3
    description ---CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/4
    description ---CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/5
    description ---CWSIP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/6
    description ---CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/7
    description ---CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/8
    description ---CWISP Access Port
    switchport access vlan 102
    no cdp enable
    !
    interface FastEthernet0/9
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/10
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/11
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/12
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/13
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/14
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/15
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/16
    description ---Wireless Access Port
    switchport access vlan 101
    no cdp enable
    !
    interface FastEthernet0/17
    description --Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface FastEthernet0/18
    description ---Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface FastEthernet0/19
    description ---Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface FastEthernet0/20
    description ---Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface FastEthernet0/21
    description ---Shop Access Port
    switchport access vlan 100
    spanning-tree portfast
    no cdp enable
    !
    interface FastEthernet0/22
    description ---Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface FastEthernet0/23
    description ---Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface FastEthernet0/24
    description ---Shop Access Port
    switchport access vlan 100
    no cdp enable
    !
    interface VLAN100
    description Shop
    no ip directed-broadcast
    no ip route-cache
    !
    interface VLAN101
    description Wireless
    no ip directed-broadcast
    no ip route-cache
    !
    interface VLAN102
    description CWISP
    no ip directed-broadcast
    no ip route-cache
    !
    no ip http server
    no cdp run
    snmp-server community <removed> RO
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    password <removed>
    login
    line vty 5 15
    password <removed>
    login
    !
    end
     
    Jake, Oct 3, 2006
    #8
  9. Okay, hold on. So, does 2900XL support VLAN or not?
     
    Sarastra Maya, Oct 3, 2006
    #9
  10. Yes it does. Both versions of the 2924 support VLANing. Only the 2924XL with
    enterprise software does VLAN trunking. There's a bunch of non XL
    switches on eBay that don't do trunking, as well as some of the
    desktop XL version that won't do trunking either.
     
    Doug McIntyre, Oct 3, 2006
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.