how do I play a WAV file

Discussion in 'Computer Support' started by see.cher, Sep 5, 2005.

  1. see.cher

    see.cher Guest

    I want to click on a WAV file and have it play
    NOT open WMP or other program and sit there waiting for me.
    It used to work this way in the old days before WMP messed things up.

    How do I accomplish this??????? - maybe with sndrec32 - but I tried
    that and it just opens waiting.

    thanks
     
    see.cher, Sep 5, 2005
    #1
    1. Advertisements

  2. see.cher

    SgtMinor Guest

    WMP messed it up eh?

    If you have a player on your system, right click on the .wav file select
    "Open with" next choose program, scroll down to the program you want and
    select it. Be sure to place a tick in the box marked "Always use this
    program to open these files."
     
    SgtMinor, Sep 5, 2005
    #2
    1. Advertisements

  3. see.cher

    trout Guest

    Go to Folder Options; File types, and double-click Wave. In the
    properties, you should make sure that you have "Play" as the default
    (rather than Open).
    If you edit the properties for the Play command, it should look
    something like:
    "sndrec32.exe /play /close"
     
    trout, Sep 5, 2005
    #3
  4. see.cher

    Mitch Guest

    Everything depends on the program that you set to handle each specific
    filename extension.
    All you need to do is assign the tool you want to run WAV to the file
    type WAV, and you're done.

    I don't know from your note which program that would be.
     
    Mitch, Sep 5, 2005
    #4
  5. see.cher

    see.cher Guest

    Thanks y'all.
    The answer I was looking for, which I was trying to implement, was
    from trout. only problem is that the window I get is not like it used
    to be where I could specify /play /close.

    Old billy changed something and I can't do that there.

    Anyone know where to change the registry for this to work?????????//
     
    see.cher, Sep 5, 2005
    #5
  6. see.cher

    trout Guest

    What's the Operating System?
     
    trout, Sep 5, 2005
    #6
  7. see.cher

    see.cher Guest

    It's XP

    this is this entry under
    HKCR\Applications\sndrec32.exe\shell\open\command
    "C:\Windows\System32\sndrec32" "%1"

    I tried this
    "C:\Windows\System32\sndrec32" "/play /close" "%1"

    but that does the same thing as previous.
    I can put this in RUN and it will do exactly what I want it to do.
    sndrec32 /play /close chimes.wav

    How can I make it work in the registry???
     
    see.cher, Sep 5, 2005
    #7
  8. see.cher

    Toolman Tim Guest

    Skip the registry - go back to the folder options, file types, find the wav
    extension, select it, click on advanced, click on play, click on edit. Put
    the "C:\Windows\System32\sndrec32" /play /close "%1" in the application
    line. PLEASE NOTE I removed the quotes from around /play /close. See if that
    helps.
     
    Toolman Tim, Sep 5, 2005
    #8
  9. see.cher

    see.cher Guest

    I would have done that long ago, as I have in the past, but that
    function is no longer available on this XP SP2 window.
    There is no ADVANCE button.
    Is there a way to get the old window back?
     
    see.cher, Sep 6, 2005
    #9
  10. see.cher

    trout Guest

    Sorry, I don't use XP. But you can't do this through just the "edit"
    options?
    Are you unable to edit the properties of the file type, or the
    properties of the command?
     
    trout, Sep 6, 2005
    #10
  11. see.cher

    Toolman Tim Guest

    Yup. Sorry. My WAV files are registred to a different player. I assumed
    (incorrectly, obviously) that the advanced button would be there for the
    other programs.

    But I have another idea - how about a replacement program? I found a nice,
    small, fast, unobtrusive player at
    http://www.webxpace.net/software/software.html#WavPlayer

    This has no "install", no registry settings to play with, etc.

    Download the file, put it somplace you can remember, then edit your .wav
    extension to open waves with that program. Include the variable option in
    the settings. For example, if you put the program in c:\player, then the
    Play options would be "C:\player\wbwav.exe" "%1"

    I can't promise anything. I won't test it since I don't want to risk messing
    up my existing setup, but it looks like it should work.

    TT


    <snip>
     
    Toolman Tim, Sep 7, 2005
    #11
  12. see.cher

    trout Guest

    There's not a "New" button on that page to add a different command?
     
    trout, Sep 7, 2005
    #12
  13. see.cher

    see.cher Guest

    I can select what program I want to "OPEN with:".
    Nothing else.
     
    see.cher, Sep 7, 2005
    #13
  14. see.cher

    see.cher Guest

    The NEW button adds another extension.
     
    see.cher, Sep 7, 2005
    #14
  15. see.cher

    see.cher Guest

     
    see.cher, Sep 7, 2005
    #15
  16. see.cher

    trout Guest

    Hmm. I don't think we're talking about the same place. I mean on the
    page that shows the properties of the file type. Where you could edit
    the properties for "Open", there should be a "New" button to add "Play".
    Not the main "File Types" page.
     
    trout, Sep 7, 2005
    #16
  17. see.cher

    Toolman Tim Guest

    You're welcome :)

    Sometimes the best fix is a good work-around <g>
     
    Toolman Tim, Sep 7, 2005
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.