how do I ping/ join a windows domain across pix ipsec

Discussion in 'Cisco' started by none22, Jan 27, 2004.

  1. none22

    none22 Guest

    I need some assistance. All I need is for one network to ping th
    network of the other side through a pix ipsec tunnel. after the ping
    i want one network to join a windows domain of the other pix.
    help...and also, why can't i telnet to the outside int. of the pix.
    thanks in advance.
    192.168.0.0-->pix-->22.1.2.2---internet--33.1.2.1--Pix2-->10.1.1.1-->10.1.0.
    and 10.2.0.0:
    pixfirewall# sho run
    : Saved
    :
    PIX Version 6.3(1)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password nkDjLSwUHEy5A.bN encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname pixfirewall
    domain-name ciscopix.com
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    names
    access-list 101 permit ip 192.168.0.0 255.255.0.0
    10.1.0.0 255.255.0.0
    access-list 101 permit ip 192.168.0.0 255.255.0.0
    10.2.0.0 255.255.0.0
    access-list acl_in permit ip any any
    access-list acl_in permit icmp any any
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 22.1.2.2 255.255.255.248
    ip address inside 192.168.1.1 255.255.0.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 192.168.1.0 255.255.255.0 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (outside) 1 22.1.2.3
    nat (inside) 0 access-list 101
    nat (inside) 1 192.168.0.0 255.255.0.0 0 0
    access-group acl_in in interface inside
    route outside 0.0.0.0 0.0.0.0 22.1.2.3
    route inside 192.168.0.0 255.255.0.0 192.168.1.2 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00
    rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00
    sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set chevelle esp-des
    esp-md5-hmac
    crypto map transam 1 ipsec-isakmp
    crypto map transam 1 match address 101
    crypto map transam 1 set peer 33.1.2.1
    crypto map transam 1 set transform-set chevelle
    crypto map transam interface outside
    isakmp enable outside
    isakmp key ******** address 33.1.2.1 netmask
    255.255.255.255
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption des
    isakmp policy 1 hash md5
    isakmp policy 1 group 1
    isakmp policy 1 lifetime 86400
    telnet 33.21.12.81 255.255.255.255 outside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    Cryptochecksum:7482daa05cf70198321584497fb42c46
    : end
    pixfirewall

    none2
     
    none22, Jan 27, 2004
    #1
    1. Advertisements

  2. :I need some assistance. All I need is for one network to ping the
    :network of the other side through a pix ipsec tunnel. after the ping,
    :i want one network to join a windows domain of the other pix.

    To be able to join a Windows domain, you need a WINS server if the
    two ends are in different subnets.


    :192.168.0.0-->pix-->22.1.2.2---internet--33.1.2.1--Pix2-->10.1.1.1-->10.1.0.0
    :and 10.2.0.0:

    :pIX Version 6.3(1)

    :access-list 101 permit ip 192.168.0.0 255.255.0.0 10.1.0.0 255.255.0.0
    :access-list 101 permit ip 192.168.0.0 255.255.0.0 10.2.0.0 255.255.0.0

    :access-list acl_in permit ip any any
    :access-list acl_in permit icmp any any

    icmp is a subset of ip, so that second line is redundant.

    :ip address outside 22.1.2.2 255.255.255.248
    :ip address inside 192.168.1.1 255.255.0.0

    :global (outside) 1 interface
    :global (outside) 1 22.1.2.3

    You can't PAT to two different IPs. You should remove one of those
    two statements.

    :nat (inside) 0 access-list 101
    :nat (inside) 1 192.168.0.0 255.255.0.0 0 0

    :access-group acl_in in interface inside

    Allowing all traffic from the inside to the outside is the default,
    so you could do away with acl_in .

    :route outside 0.0.0.0 0.0.0.0 22.1.2.3
    :route inside 192.168.0.0 255.255.0.0 192.168.1.2 1

    Do you have an inside router you haven't mentioned? That route inside
    shouldn't be needed, as it is the same subnet as the static route that
    will be automatically created when the 192.168/16 IP address is assigned
    to the inside interface.

    :sysopt connection permit-ipsec

    :crypto map transam 1 match address 101

    Okay, you should be able to ping host-to-host across the network,
    provided the IPSec device at the other end allows it. You won't
    be able to ping the IPSec device -itself- across that tunnel, though.
    And they won't be able to ping your pix across the tunnel.
    [That's because you haven't included the endpoints -in- the tunnel.]


    :telnet 33.21.12.81 255.255.255.255 outside

    :help...and also, why can't i telnet to the outside int. of the pix.

    You can only telnet to the outside interface through an IPSec
    tunnel. The remote address 33.21.12.81 isn't in the IPSec tunnel
    you define via access list 101 -- only 10.1/16 and 10.2/16 .
    [33.21.12.81 also isn't the remote peer, which you said was 33.1.2.1 .]

    If you need to be able to get to the PIX remotely from outside the
    tunnel, then you should use a 'ca generate' command, then
    a 'ca save all' (important, don't forget that!), and then configure
    'ssh' access.
     
    Walter Roberson, Jan 28, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.