How do I modify security permission for this error

Discussion in 'Windows 64bit' started by Kue2, Oct 16, 2007.

  1. Kue2

    Kue2 Guest

    The application-specific permission settings do not grant Local Activation
    permission for the COM Server application with CLSID
    {0C0A3666-30C9-11D0-8F20-00805F2CD064}
    to the user Hugh-PC-Vista\Hugh SID
    (S-1-5-21-4283064427-2545207795-2372569307-1000) from address LocalHost
    (Using LRPC). This security permission can be modified using the Component
    Services administrative tool.

    Log Name: System
    Source: Microsoft-Windows-DistributedCOM
    Date: 15/10/2007 10:00:41 PM
    Event ID: 10016
    Task Category: None
    Level: Error
    Keywords: Classic
    User: Hugh-PC-Vista\Hugh
    Computer: Hugh-PC-Vista
    Description:
    The application-specific permission settings do not grant Local Activation
    permission for the COM Server application with CLSID
    {0C0A3666-30C9-11D0-8F20-00805F2CD064}
    to the user Hugh-PC-Vista\Hugh SID
    (S-1-5-21-4283064427-2545207795-2372569307-1000) from address LocalHost
    (Using LRPC). This security permission can be modified using the Component
    Services administrative tool.



    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Microsoft-Windows-DistributedCOM"
    Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    <EventID Qualifiers="49152">10016</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2007-10-16T02:00:41.000Z" />
    <EventRecordID>141881</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>System</Channel>
    <Computer>Hugh-PC-Vista</Computer>
    <Security UserID="S-1-5-21-4283064427-2545207795-2372569307-1000" />
    </System>
    <EventData>
    <Data Name="param1">application-specific</Data>
    <Data Name="param2">Local</Data>
    <Data Name="param3">Activation</Data>
    <Data Name="param4">{0C0A3666-30C9-11D0-8F20-00805F2CD064}</Data>
    <Data Name="param5">Hugh-PC-Vista</Data>
    <Data Name="param6">Hugh</Data>
    <Data
    Name="param7">S-1-5-21-4283064427-2545207795-2372569307-1000</Data>
    <Data Name="param8">LocalHost (Using LRPC)</Data>
    </EventData>
    </Event>
     
    Kue2, Oct 16, 2007
    #1
    1. Advertisements

  2. Kue2,

    I confess, this is beyond me, but curiosity arising by your earlier post -
    have you been experimenting turning off various services on random to slim
    down on the 'Background Processes'?

    Don't be offended - I've done much the same thing myself once ago. It's not
    the brightest idea! You'll need competent guidance to keep your nose above
    the water. Back then, I found

    BlackViper.com

    but this seems to be closed now.

    Sorry - it's back up again! It has gotten a significant makeover, it used to
    be a great site - I have no idea what they turned it into now.

    Others are bound to exist - I suggest digging deep on the topics of 'Windows
    Services' and 'Hardware Profiling' over Internet, if you want to learn
    something about the secrets. There are quite a few items that you simply do
    not want to touch.


    Tony. . .
     
    Tony Sperling, Oct 16, 2007
    #2
    1. Advertisements

  3. Kue2

    Kue2 Guest

    Hi Tony

    I just did a re-install of Vista 64.After re-install these errors appeared
    in event viewer.I have not tweaked nothing since re-install.
    I did a re-install because I was having major errors.I had Vista 64 loaded
    since Jan/07 & system was becoming progressively unstable. System now seems
    fine.I am just trying to find answers for these 2 error messages in the
    event viewer.

    Thanks
     
    Kue2, Oct 16, 2007
    #3
  4. Kue2

    Guest Guest

    Guest, Oct 16, 2007
    #4
  5. Kue2

    Kue2 Guest

    Hi Carlos
    Well I finally got to the place where to give application-specific
    permission. That's quite a process. I followed this guide,which was a help
    link in the error message. Event log online help took me here
    :http://www.microsoft.com/technet/su...ProdVer=5.2&EvtID=10016&EvtSrc=DCOM&LCID=4105
    To assign permissions

    1.. Using Regedit, navigate to the following registry value
    HKCR\Clsid\clsid value\localserver32
    The clsid value is the information displayed in the message.
    2.. In the right pane, double-click Default. The Edit String dialog box is
    displayed. Leave this dialog box open.
    3.. Click Start, and then click Control Panel.
    4.. Double-click Administrative Tools, and then double-click Component
    Services.
    5.. In the Component Services snap-in, expand Computers, expand My
    Computer, and double-click DCOM Config.
    6.. In the right pane, locate the program by using its friendly name.
    7.. Right-click the program name, and then select Properties.
    8.. On the Security tab, in the Launch and Activation Permissions group
    box, select Customize, and then click Edit.
    Add the user to the permissions list, and give the user the appropriate
    permissions.

    Hope this fixes that error message & does not lead to something else screwed
    up...LOL

    I wonder If I have to re-boot for that to take effect........better reboot
    to be on safe side.....

    CUL Carlos & thks again. rebooting..................
     
    Kue2, Oct 16, 2007
    #5
  6. Kue2

    Guest Guest

    Hi, Sometimes this error is caused by Machine Debug Manager. Search for
    mdm.exe on your computer(common files\microsoft). There is a Microsoft KB on
    deleting or disabling MDM from your system. Usually comes with MS Office (XP
    ?) as Visual Studio (VS7) debug. Also turn off script debugging in IE
    options (advanced tab). Cheers.
     
    Guest, Nov 12, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.