How do I host my Apache web site if my isp blocks port 80?

Discussion in 'Linux Networking' started by Leo, Jan 3, 2005.

  1. Leo

    Leo Guest

    I have been hosting my apache web site from home but since I went for a higher
    speed adsl and a new modem with router built-in I can't seem to do that now.
    My isp has apparently blocked port 80. Is there an easy way around this?
    I just play around with this apache web site. It is not serious enough to pay
    $10 to $15 per month to have it hosted outside my home.
     
    Leo, Jan 3, 2005
    #1
    1. Advertisements

  2. The modem/router is probably not forwarding any requests in (firewall). You
    can check the settings and see if you use a fixed internal IP can you
    forward port 80 requests.

    Another point small websites start at less than $15/yr with no banners (free
    with banners).

    Randy
     
    Randy McLaughlin, Jan 3, 2005
    #2
    1. Advertisements

  3. Leo

    Leo Guest

    Hi Randy; The modem seems to be set with fixed ip and set to use port 80 in and
    80 out. It seems to be set correctly but no one can get to my web page.
    So far; I have seen none that would host that cheaply. I will look around some
    more. My web site has virtually no traffic so it would qualify as small..
    Thanks much.
     
    Leo, Jan 3, 2005
    #3
  4. Leo

    Leo Guest

    Hi Randy; I just found one called
    onedollarhost.net
    I will try that out. You saved me much frustration.
     
    Leo, Jan 4, 2005
    #4
  5. Leo

    7 Guest

    Your ISP stinks - dump them and get a normal ISP.

    You can tell apache to listen to ports other than 80 - e.g. 8080
    by editing its configuration files.
    Then your router will have to be set to forward port 8080 to your
    machine and its port 8080.
    The web site on your computer will then be accessible as
    http://ipaddress:8080/
    If you have domain names being steered into your IP address
    then the web site address will be
    http://www.domainname.com:8080/
     
    7, Jan 4, 2005
    #5
  6. I agree, if your modem acts as a router then it should not automatically
    forward any ports from the internet to your computer. By definition the
    router handles multiple IP address to one. It needs to know which internal
    IP address to hand the traffic to.

    As far as commercial webhosting goes I have gone to
    http://www.findmyhosting.com/ in the past to compare prices & capabilities.

    Randy
     
    Randy McLaughlin, Jan 4, 2005
    #6
  7. Leo

    Leo Guest

    I just went to GRC.com and found the only port I have open is 81.
    There is a way to get into the modem software but I don't know the login and
    password. I put a terminal program and connected to the DB9 socket to look but
    can't get passed the login and password.
    I went to this site you mentioned and it looks good.
    Thanks.
     
    Leo, Jan 4, 2005
    #7
  8. <snip>

    What brand and model modem/router do you have?

    It may not be possible if either your isp is blocking port 80 or if your
    modem can not be configured.


    Randy
     
    Randy McLaughlin, Jan 4, 2005
    #8
  9. Leo

    Leo Guest

    The mode/router is a D-Link DSL-604+
    By the way; do you know what the hosters mean when they say the offer
    "Plan Type - Shared Hosting Plan" ?
     
    Leo, Jan 4, 2005
    #9

  10. Try userid = admin, password = admin.

    I assume by Shared Hosting Plan they refer to virtual hosting, more than one
    website per computer.


    Randy
     
    Randy McLaughlin, Jan 4, 2005
    #10
  11. Leo

    Tim Smith Guest

    That's a non-US DLink product (which makes sense, since you are posting from
    Canada). Unfortunately, the Canadian DLink website sucks compared to the US
    site. In particular, on their support page, that model does not appear.

    However, it is probably very similar to their other models of the same
    general family. If so, try going to 192.168.0.1 with your web browser.
    Try "admin" for the user name and a blank password.

    If that doesn't work, and you are feeling adventurous, you can try resetting
    the device. If it is like other DLink devices, that consists of pressing
    the reset switch on the back (probably in a hole that you'll have to use a
    paper clip or something similar to reach into) for about 10 seconds.

    Note there is some risk to this: if your ISP preconfigured the thing for
    you, you will lose those settings, and may not be able to figure out how to
    restore them.

    On the US DLink website, you can download manuals for most of their
    products, so perhaps you can find one that is similar to yours. I'd *guess*
    that the DI-604 is similar, for a start.
     
    Tim Smith, Jan 4, 2005
    #11
  12. Leo

    Mark South Guest

    That's standard product support strategy. Claim the offending article
    doesn't exist :)
    Or admin for the password as well. Did the OP **REALLY** not try that
    before asking???
    My experience with D-Link routers suggests that a power blip will clear
    the settings even faster than a paperclick up the rear orifice. So even
    if you don't use the paperclip, make a note of the settings the thing has
    (some D-Link stuff has an option on one of the internal pages to save the
    settings to your hard disk - use this).
    The "+" tacked on the end of D-Link product IDs apparently often means 22
    Mb/s as opposed to 11, or 108 Mb/s as opposed to 54, i.e. a dual-channel
    multiplexing version of the base model. If that's so then you'd be right.
     
    Mark South, Jan 4, 2005
    #12
  13. Leo

    Robert Guest

    Sounds like your new modem with the built-in router isn't forwarding your
    traffic. Check the setting and ensure that port 80 is being forwarded to
    your box. I am sure that this new router/switch/firewall is the root
    cause of your problem not you ISP.


    --

    Regards
    Robert

    Smile... it increases your face value!
     
    Robert, Jan 4, 2005
    #13
  14. Leo

    James Knott Guest

    If port 80 is blocked by your ISP, you can configure your server to run on a
    different port and then simply add (IIRC) ":<port #> to the URL. So, if
    you used port 500, you'd add ":500", to the URL.
     
    James Knott, Jan 8, 2005
    #14

  15. No. The built-in router of the modem needs to be configured to forward port
    80 traffic to the Apache server. This requires that the Apache server use a
    fixed IP address in the same subnet address range as the routers internal
    address.


    Randy
     
    Randy McLaughlin, Jan 8, 2005
    #15
  16. Leo

    Jim Berwick Guest

    This won't matter if the ISP is blocking all inbound port 80 traffic to
    their customers. Many ISPs do this.
     
    Jim Berwick, Jan 8, 2005
    #16
  17. You snipped the part where he said it was working until he upgraded to a
    modem with a built-in router. All routers block incoming requests until
    configured to forward to specific computers on the otherside.

    I have seen lots of posts with the same problem.

    Having a built-in router makes it a snap to share the internet. People
    expect the new modem to act like their old one, surprise there are things
    that need to be configured.

    It's no big deal but everyone jumps to the conclusion that port 80 has been
    blocked by the isp.

    It's simple if you change something that totally changes how your internet
    service works and something stops working look to what you just changed
    first.


    Randy
     
    Randy McLaughlin, Jan 8, 2005
    #17
  18. Leo

    Jim Berwick Guest

    When the OP said "went to a higher speed DSL and new modem", I was assuming
    that means they did not have DSL prior and now have it, in which case it is
    very possible the ISP is blocking port 80. Unless we know which is the
    case, and/or who the ISP in question is, we won't really know for sure.
     
    Jim Berwick, Jan 9, 2005
    #18
  19. Leo

    Leo Guest

    I have been running ADSL for about 3 years that gave about 1500 download and
    about 600 upload. I was using a D-Link DSL-300i modem and a SMC7400VBR router.
    My ISP offered to up my speed to 2500 if I signed up for 3 years and changed to
    the ISP supplied D-Link DSL-604+ modem/router unit. Up till I changed I was
    running an Apache web page/site and I was able to ssh from work to my home setup
    and up or download files as I needed. Now I can only browse from Home. Granted
    the speed is a bit better but If I had known they were going make things that
    much different, I would have not gone this route. With the SMC router, I had
    ports 80 and I think 23 opened and although I have opened these in the new
    router, I still can't get anywhere. I have a fiend who will try the connection
    from his place when I want to test. I went to http://www.grc.com and checked "my
    ports", I see that all ports are closed tight except port 81. I have no idea why
    port 81 would be open. It never was with the old system.
     
    Leo, Jan 9, 2005
    #19
  20. Try logging into the new router using userid = admin, and password = admin.
    Then see if you have a port forwarding table. As I said routers come
    without port forwarding enabled which means you have no access from port 80.


    Randy
     
    Randy McLaughlin, Jan 9, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.