Home Network Router Question

Discussion in 'Cisco' started by mortal, Mar 17, 2010.

  1. mortal

    mortal

    Joined:
    Mar 17, 2010
    Messages:
    2
    Likes Received:
    0
    Currently I have a simple flat network at home. I've used all the 100mb ports in my Belkin N+ wireless router and now I need to add 2 more wired devices (DirecTV boxes). I was given a Cisco 831 by a friend but I'm not sure how to get it going. I'd like the end result to be the two routers connected together and having two VLANs (192.168.0.x and 192.168.1.x). It seems overkill but I did a quick Visio of what I want the end result to be. Any help with config settings would be fantastic.
     

    Attached Files:

    mortal, Mar 17, 2010
    #1
    1. Advertisements

  2. mortal

    mortal

    Joined:
    Mar 17, 2010
    Messages:
    2
    Likes Received:
    0
    I came up with this config with the help of a website. I won't get to actually try it until later tonight. Any thoughts on what my chances are of it working?

    Code:
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    service sequence-numbers
    no service dhcp
    !
    hostname xxxxxx
    !
    aaa new-model
    aaa authentication login default local
    enable secret xxxxxx
    !
    username admin secret xxxxxx
    clock timezone CST -6
    clock summer-time CDT recurring
    ip subnet-zero
    !
    ip domain-name xxxxxx.com
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    interface FastEthernet0/1
     description Normal User
     switchport mode access
     spanning-tree portfast
     spanning-tree bpduguard enable
     speed 100
     duplex full
    !
    interface FastEthernet0/2
     description Normal User
     switchport mode access
     spanning-tree portfast
     spanning-tree bpduguard enable
     speed 100
     duplex full
    !
    interface FastEthernet0/3
     description Normal User
     switchport mode access
     spanning-tree portfast
     spanning-tree bpduguard enable
     speed 100
     duplex full
    !
    interface FastEthernet0/4
     description Normal User
     switchport mode access
     spanning-tree portfast
     spanning-tree bpduguard enable
     speed 100
     duplex full
    !
    interface Vlan1
     ip address 192.168.1.1 255.255.255.0
     exit
    !
    ip default-gateway 192.168.1.1
    ip http server
    ip http access-class 2
    access-list 2 remark Where remote management can be done from
    access-list 2 permit 192.168.1.0 0.0.0.255
    banner motd |
    
    You require authorisation to connect to this device.
    If you are not authorised to connect to this device please disconnect now.
    |
    !
    line vty 0 15
     access-class 2 in
    
     
    mortal, Mar 24, 2010
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.