Help with simple point-to-point setup, pls

Discussion in 'Cisco' started by Ken, Apr 5, 2007.

  1. Ken

    Ken Guest

    Hello,

    I'm trying to set up a point to point connection over T-1 with the
    goal that computers at the main office can access computers at the
    remote office and vice versa. Also, computers at the remote office
    will access the internet through the gateway of 192.168.12.1 at the
    main office. On each side of the point-to-point circuit are Cisco
    routers with default HDLC settings.

    So far, from either network, I am able to ping to the far side of the
    router on the other side but nowhere past that.

    For example, from 192.168.15.20, I can reach 192.168.12.2 but not
    192.168.12.1 (a sonicwall connected to the ISP's router).

    Do you have any pointers for me? Following are the essential router
    config as well as the results of a "sho ip route" on each router.

    ! *****************************
    ! ** For this router, FA 0/0 connects
    ! ** to the network of the main office lan.
    ! ** S 0/0/0 connects to a Point-to-point t-1
    ! ** connection (i.e Remote-Rtr)
    ! *****************************
    hostname Main-Rtr
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.12.2 255.255.255.0
    speed auto
    full-duplex
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    ip address 192.168.13.1 255.255.255.0
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.0.0 0.0.255.255 area 1
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
    !
    no ip http server
    !
    !
    control-plane
    ! ****************************
    ! ** end Main-Rtr
    ! ****************************

    ======================================
    ****************************
    **** Remote-Rtr results for "sho ip route"
    ****************************

    C 192.168.12.0/24 is directly connected, FastEthernet0/0
    C 192.168.13.0/24 is directly connected, Serial0/0/0
    O 192.168.15.0/24 [110/65] via 192.168.13.2, 00:44:25, Serial0/0/0
    S* 0.0.0.0/0 is directly connected, FastEthernet0/0

    ======================================

    ! *****************************
    ! ** For this router, FA 0/0 connects
    ! ** to the network of the remote office lan.
    ! ** S 0/0/0 connects to a Point-to-point t-1
    ! ** connection (i.e Main-Rtr)
    ! *****************************
    hostname Remote-Rtr
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.15.2 255.255.255.0
    speed auto
    full-duplex
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    ip address 192.168.13.2 255.255.255.0
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.0.0 0.0.255.255 area 1
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0/0
    !
    ip http server
    !
    dialer-list 1 protocol ip permit
    !
    control-plane

    ! ****************************
    ! ** end Remote-Rtr
    ! ****************************

    =========================
    ****************************
    ** Remote-Rtr results for "sho ip route"
    ****************************

    O 192.168.12.0/24 [110/65] via 192.168.13.1, 00:43:08, Serial0/0/0
    C 192.168.13.0/24 is directly connected, Serial0/0/0
    C 192.168.15.0/24 is directly connected, FastEthernet0/0
    S* 0.0.0.0/0 is directly connected, Serial0/0/0
     
    Ken, Apr 5, 2007
    #1
    1. Advertisements

  2. Hi,
    Why are you using OSPF?
    As I have undertood, you have two different local networks connected
    to two different routers, and one of them is connected to the
    internet.
    All the routing you need is the following:
    1. On the remote router:
    ip route 0.0.0.0 0.0.0.0 Serial0
    ip classless

    2. On the main router:
    ip route 192.168.15.0 255.255.255.0 Serial0
    ip route 0.0.0.0 0.0.0.0 FastEthernet0

    This is the clear way to do it. But if just wanna get it to work, you
    can just do the following command on the main router:
    ip route 0.0.0.0 0.0.0.0 FastEthernet0 150
    This way you will give the default route an Administrative Distance
    that is higher than the OSPF. I believe what happening with your pings
    is that the reply sent from the main LAN to the remote LAN are using
    the default route and loosing the way back to the remote router
    because the default route has an AD that is lower than OSPF.
    Please let me know how it goes.


    Mohammed
    http://www.RouterGeek.net
     
    Mohammed Alani, Apr 5, 2007
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.