Help With Old EZ-TREE Family Tree Program

Discussion in 'Computer Support' started by Jeff Wisnia, Jul 23, 2007.

  1. Jeff Wisnia

    Jeff Wisnia Guest

    About 15 years ago I started compiling genealogical data on my family
    and purchased the EZ-TREE software, ver 2.3.

    I put a lot of family data into a file named TREE1.EZT back then.

    Other things occupied my spare time for a number of years, but I'm
    retired now and would like to get back to working on my family tree
    while I'm still "on the right side of the grass".

    So it's time to get some contemporary family tree software and get back
    to work.

    I'm running a Windows VISTA machine, and thus far I've been unable to
    figure out get the olde EZ-TREE program to load and run on it.

    I can look at the contents of that TREE1.EZT data file with with a text
    editor, and I'd doped out and wrote up the data storage format back when
    I had to repair the file when it got corrupted.

    But, I'd like to avoid having to key all that data into a contemporary
    program if I can.

    So, any hints on how I might be able to transfer the data from that
    "TREE1.EZT" file into current software or even help on how to get the
    EZ-TREE program loaded and running on my VISTA machine would be appreciated.

    Jeff Wisnia, Jul 23, 2007
    1. Advertisements

  2. Jeff Wisnia

    Stevo Guest

    Don't know the software but if you can read the data file with a text
    editor, then you should be able to pull it into Excel or similar without
    too much trouble?
    Stevo, Jul 23, 2007
    1. Advertisements

  3. Jeff Wisnia

    Pennywise Guest

    Assume you have an icon on your desktop, if so right click on it and
    select a compatibility mode.
    Pennywise, Jul 23, 2007
  4. Jeff Wisnia

    Jeff Wisnia Guest

    I should have mentioned that EZ-TREE is so olde it's an MS-DOS program.
    I tried running "command" under Vista which gave me what sure looks like
    a DOS screen, and one which seemed to respond to the few simple DOS
    commands I remembered and tried.

    But, running the "install.bat" program off the EZ-TREE floppy didn't
    seem to do it's thing. Just in case my old orioginal floppy with the
    EZ.TREE installer on it had gotten munged I tried downloading a zip file
    of the latest version of EZ-TREE from an archive and unzipped it onto a
    clean floppy. That didn't work any better that the "factory" one did.

    Tried the same things with the oldest operating system I could find
    running, Win 98SE, with no better results.

    I think when I was using the program it was on an old 386 machine
    running Windows 3.1, with good MS-DOS capability. <G>

    Jeff Wisnia, Jul 23, 2007
  5. Jeff Wisnia

    Mara Guest

    Have you tried DOSBox?
    Mara, Jul 23, 2007
  6. Jeff Wisnia

    Mike Easter Guest

    You don't want to /use/ the old app; you only want to use it to
    'extract' the data to enter into another app.
    I don't think you are going to be able to avoid that. You aren't going
    to be able to find software to convert the .ezt files to gedcom and then
    to gramps or similar modern. The gedcom is 'ubiquitous' to aid in
    exchanging data between dissimilar genealogy programs. Gramps is an
    open source app which is available and popular in the linux versions and
    also has an experimental win version. Whether or not it will run on
    vista is another problem. Vista is a problem.
    By choosing your platform to be vista, you are severely restricted in
    terms of what software might be compatible.

    You might consider choosing another operating system to dual boot into.
    You could use vista to run the dos app with a virtual machine, or if you
    chose a linux distro for an OS, then you could run a dos virtual machine
    use the VM to run eztree and print out the results of the .ezt files.
    Then you could use the same linux distro to run gramps.

    All free. Not buying any commercial genealogy programs which don't run
    on vista yet.
    Mike Easter, Jul 23, 2007
  7. Jeff Wisnia

    Jeff Wisnia Guest

    Thanks much!

    I installed dosbox and my world came together again. I can run that old
    EZ-TREE program fine now. All but printing from it that is. <G>

    When I try and print from the program it's clear that "something" is
    happening, because my Samsung laser printer immediatly fires up and goes
    into it's warmup, but that's all it does.

    I suppose if I dig around enough I'll figure out what's going on figure
    out how to get things onto paper.

    Thanks again,

    Jeff Wisnia, Jul 24, 2007
  8. Jeff Wisnia

    Mara Guest

    Try this:

    Mara, Jul 24, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.