Help! Socket error! What do I do?

Discussion in 'Computer Support' started by Fidcal, Jun 22, 2003.

  1. Fidcal

    Fidcal Guest

    Help! Socket error! What do I do? Apart from panic that is?
    I just re-partitioned my hard drive and all seemed OK until I
    tried to log on to the Internet. Now I can't access the net on
    my main install. I get this error in one of my programs...

    Started up Microsoft wsock32.dll, ver2.2, 32bit of Apr 28 1998,
    at 19:33:24.
    Socket -1 created
    WSAAsyncSelect() error:10038
    Socket operation on non-socket.
    An operation was attempted on something that is not a socket.

    I replaced wsock32.dll in case the file was corrupt but no luck!
    PLEASE help!
     
    Fidcal, Jun 22, 2003
    #1
    1. Advertisements

  2. Fidcal

    why? Guest

    X-No-Archive: Yes
    <snip>
    Service Packs / Updates / application patch could be any of these or
    more.
    1998, what ver of Windows? Ver 2.2 seems almost wrong somehow or a non
    MS one.
    Long version / description
    http://www.sockets.com/err_lst1.htm
    going by the Winsock functions listes, it does seem like a patch/service
    pack file is out of date.

    You could try removing all networking components, TCP/IP etc and NIC
    drivers then reinstall, taking notes of important settings first.
    <snip>

    The version above, with one from where?
    MS DLL version check.
    http://support.microsoft.com/default.aspx?scid=/servicedesks/fileversion/dllinfo.asp&SD=MSDN&FR=0
    or same but shorter URL http://tinyurl.com/4lyn

    <snip>
    Me
     
    why?, Jun 22, 2003
    #2
    1. Advertisements

  3. Fidcal

    Fidcal Guest

    It's 4.10.1998, the first edition. Been working fine for years.
    I'm using it now for this connection. Thank God I had another
    Win98 install on another partition just for games. At least I
    got the modem installed and got usenet at least!

    I'll try out your ideas and links when I get a browser
    installed. Many thanks.
     
    Fidcal, Jun 22, 2003
    #3
  4. Fidcal

    Fidcal Guest

    Well, I had the silly notion that Internet Explorer took a while
    to set up but since I'd already manually configured Dial Up
    Networking and used the default V4 IE it was almost ready to go.

    Following these links this seems to be the error but the
    solution given is not helpful. Any more ideas? Meanwhile, now
    I've got a browser I'll continue searching the WWW.

    WINSOCK Error: Socket operation on non-socket.

    Explanation:
    The socket input parameter is not a valid socket handle: either
    it never was valid; or it is a file handle (not a socket
    handle); or, if it was a socket handle, it has been closed.

    User Action:
    Developer suggestions: Use socket state in an application or
    handle this error as a non-fatal error. [Duh?]
     
    Fidcal, Jun 23, 2003
    #4
  5. Fidcal

    °Mike° Guest

    Default v4 IE? What operating system are you using?

    Have you tried removing/re-installing your networking components?

    How to Remove and Reinstall Dial-Up Networking and TCP-IP Files
    http://support.microsoft.com/search/preview.aspx?id=kb;en-us;181599


     
    °Mike°, Jun 23, 2003
    #5
  6. Fidcal

    °Mike° Guest

    Oh well, I'm glad it's sorted, and you're welcome.


    <snip>
     
    °Mike°, Jun 23, 2003
    #6
  7. Fidcal

    why? Guest

    That may be it, the DUN / Service pack or other patch overwrote a DLL IE
    was using and an equally old part of IE4 called a function in the
    old/newer wsock32.dll? Do you have IE5.x on a CD you can up grade to?
    Which browser? , Maybe try MSIE5.5 SP2 www.evolt.org
    Getting a bit deep here, socket programming. Basically the developer bit
    says manage the socket state (opening/closing a connection) or use an
    error handler to show a non-fatal message.

    There is a utility depends.exe (dependency walker) that may have only
    been in the NT resource kits, but this may be handy in another form.
    Basically it's a dll/ocx viewer info list. You select a DLL and it shows
    what other DLLs it needs.

    So wsock32.dll gives these requirements, on Win NT4 SP6 (more info is
    given, incl versions / dates)

    ADVAPI32.DLL
    GDI32.DLL
    KERNEL32.DLL
    MSVCRT.DLL
    NTDLL.DLL
    RPCRT4.DLL
    USER32.DLL
    WS2HELP.DLL
    WS2_32.DLL
    WSOCK32.DLL

    It may also be that you simply need to d/l the MS Visual C++ Runtimes
    from MS or here
    http://www.david-taylor.pwp.blueyonder.co.uk/software/runtime.html#MSVCRT

    Even better the utility is here
    http://www.dependencywalker.com/

    Me
     
    why?, Jun 23, 2003
    #7
  8. Fidcal

    Fidcal Guest

    Thanks for this input why? but I've now restored my complete
    Windows backup and more or less abandoned trying to understand
    why the problem happened. I did compare the two Windows folder
    trees (bad and restored backup) but could not see any relevant
    discrepancies that made any sense. I found an overload of info
    about winsock errors on the net which just overwhelms even a
    moderately computer-literate person like myself!
     
    Fidcal, Jun 25, 2003
    #8
  9. Fidcal

    why? Guest

    X-No-Archive: Yes
    Fine, that's more often the important bit.
    I know what you mean :)

    Me
     
    why?, Jun 25, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.