Help pls Win2k

Discussion in 'Computer Information' started by Robert Baer, Aug 6, 2013.

  1. Robert Baer

    Robert Baer Guest

    I have a (SATA) DVD RW drive and it works fine with ONE exception
    that is driving me nuts.
    The exception is: if i insert a BLANK disk (to write for any reason),
    the system crashes (usually complaining about HAL.DLL); must turn off
    external power source or reset.

    All driver software related is dated 6/19/2003, listed below:
    G:\WINNT\system32\HAL.DLL 66K
    G:\WINNT\system32\storprop.dll 35K
    G:\WINNT\system32\drivers\cdrom.sys 28K
    G:\WINNT\system32\drivers\redbook.sys 35K

    Previously, i found "originals" somewhere (cannot find now), replaced
    them and then marked them as ReadOnly; that worked for a number of months.
    This "fix" no longer works.

    1: Where can i find reliable originals of these files?
    2: What else can i do to protect their integrity to prevent the crash
    problem from repeating?
    Robert Baer, Aug 6, 2013
    1. Advertisements

  2. Robert Baer

    Paul Guest

    That's not quite what mine uses.

    I plugged in the SATA DVD here, booted Win2K, then
    opened setupapi.log, and I can see "cdrom.inf" is the
    last thing to run (at the bottom of setupapi.log).
    You can also check the date stamp, to understand
    when cdrom.inf was used.

    So when the SATA drive was seen, that triggered cdrom.inf
    as the driver to install (driver from Microsoft).

    There is no hal.dll mentioned in cdrom.inf

    In Device Manager, the driver files used for the DVD are:


    That was it.

    You need to figure out, what included HAL or hardware
    abstraction layer. That does not sound normal. It
    should not have installed as part of a DVD driver.
    You'll need to read cdrom.inf, and see how the HAL file
    got included.

    You might want to upload HAL.dll to
    and have it scanned. Just in case.

    Paul, Aug 6, 2013
    1. Advertisements

  3. Robert Baer

    Robert Baer Guest

    * Check; last 3 lines:
    Selected driver installs from section cdrom_install in
    Changed class GUID of device to {4D36E965-E325-11CE-BFC1-08002BE10318}.
    Set selected driver.
    * file date of cdrom.inf is 5/8/2001 which significantly predates files
    * Correct; the stop error message stated error via hal.dll and that is
    why i included it for replacement; i think that was the significant file
    * Check; Same here.
    I note that cdrom.inf also lists changer.sys; what does that do?
    * I do not think that happened; only the stop error message mentions it.
    Too bad it is impossible to print or capture the screen.
    * The text "hal" does not exist anywhere in cdrom.inf (case ignored).
    * I used Avast! and scanned all versions (original, replacements and
    present versions) of HAL.DLL and all passed.
    I also scanned all of the other files mentioned, including the
    mysterious changer.sys and all passed.
    Thanks for the ideas.
    Once upon a time, there was a CD/DVD burner that somehow bypassed
    that error problem and wold wait "forever" for a write disk,and then
    started to burn it when available.
    No other CD/DVD copy program immediately starts burning when
    available, they all wait (must click on "retry" incessantly in futile
    attempt to bypass error problem) and then crash.

    Presently found programs have the following problems:
    a) many require M$ .NET Framework
    b) numerous require a BS initial "install" program; i refuse these on
    General Principles.
    c) numerous do not run in Win2K
    d) numerous so-called "free" progs are trials and i may have tried them.
    Robert Baer, Aug 7, 2013
  4. Robert Baer

    Paul Guest

    Good. So HAL.dll is not actually a driver for the CDROM.

    You will need to record the BSOD on the screen, and work with
    that. To help you, see the STOP page.

    Some STOP errors, you need to also record up to four parameters,
    as they tell you the sub-type. For example, the first number
    might be 0xC0000005.

    For example, if I see this one, it gives the error name,
    and in this case, also names the responsible driver file.

    STOP: 0x0000007E (0xC0000005, 0x804E518E, 0xFC938104, 0xFC937E04)

    WUSB54GCx86.sys- Address 92D89498 base at 92D7c000, Datestamp 45c04cc9

    I use the above web site, look up the "7E" first, see if there
    is info on decoding the subtype (C0000005 is probably an access
    violation). And the all-important driver file name is below that.

    You can shoot a picture of the screen, with a digital camera.

    Paul, Aug 7, 2013
  5. Robert Baer

    Robert Baer Guest

    Digital camera seems the only way to fly; my video card has 3 outputs
    and i can select which 2 to use and mode.
    I selected my Dell CRT monitor and TV in clone mode, and used my VCR
    recorder in a futile attempt to capture the error message.
    Futility level #1: the damn image is too fuzzy to read, futility
    level #2: TV out went black (with grey border = ???).

    Trying camera next.
    Robert Baer, Aug 7, 2013
  6. Robert Baer

    Robert Baer Guest

    Camera helped; was a bit fuzzy and had "fat" ("bold"?) characters,
    both made OCR messy.
    In any case, the first 2 lines said:

    STOP: 0x000000lE <0xC0000005,0x80001FD4,0x00000001.0x00000001>

    *** Address 80001FD4 base at 80001000, DateStamp 3e7a7338 - hal.dll
    Robert Baer, Aug 7, 2013
  7. Robert Baer

    Paul Guest


    The Windows kernel detected an illegal or unknown processor instruction.

    A Stop 0x1E condition can be caused by invalid memory and access violations
    similar to those that generate Stop 0xA errors.

    This default Windows error handler typically intercepts these problems if
    error-handling routines are not present in the code itself.

    [And it happened in HAL.dll, which is partnered with the kernel.]


    From the 0x0A article, references.

    "Possible Resolutions to STOP 0x0A, 0x01E, and 0x50 Errors"

    These errors may be caused by one or more of the following:

    * Hardware failure (memory, processor, or motherboard).
    * Anti-virus software that is running on your computer.
    * Drivers installed by third-party software <--- sniff, sniff

    I wonder if maybe there is a foreign filter driver involved.

    Get a copy of devcon.exe, and run "devcon stack gencdrom".

    [ Devcon x86 (32 bit), is the only useful download in here. ];EN-US;Q311272

    From the command prompt, I get this for my ancient CD-RW drive:

    Name: MSI CD-RW CR52
    Setup Class: {4D36E965-E325-11CE-BFC1-08002BE10318} CDROM
    Upper filters:
    Controlling service:
    Lower filters:
    1 matching device(s) found.

    There are no custom entries there. IMAPI is used by the built-in
    CD burning (drag and drop) interface. Redbook, I haven't a clue,
    but we know that one is provided by Microsoft, as is cdrom.sys
    or whatever. So it doesn't look like Nero inserted a filter
    driver in there for me.

    Take a look at your stack, and see how it differs.

    Sometimes, the problem is not the DVD drive, it's a virtual CD
    mounter (mounts ISO9660 files to look like a CDROM). That can
    interfere with real drives. I had to turn mine off.

    There's no guarantee that's the answer. Continue working
    your way through the list for 0x0A. If an article cannot
    be found, track it down in , as it will be
    in there. They've been slowly deleting the old content from, so it becomes harder and harder to get a complete
    picture for an older OS.

    Paul, Aug 7, 2013
  8. Robert Baer

    Robert Baer Guest

    Frozen screen message was:
    STOP: 0x000000lE <0xC0000005,0x80001FD4,0x00000001.0x00000001>
    The article was not helpful.
    Yes, i found 0x0000001E: KMODE_EXCEPTION_NOT_HANDLED
    (Click to consult the online MSDN article.)
    BUT the MSDN article did not exist, and NONE of the bulleted items
    So now what?
    Robert Baer, Aug 7, 2013
  9. Robert Baer

    Paul Guest

    In a thread here, the OP found that "Pinnacle Instant CD/DVD" application,
    needed to be repaired, and then the crashes stopped.

    Paul, Aug 7, 2013
  10. Robert Baer

    Robert Baer Guest

    I see that they also found that HAL, of A.Clark SF fame, got involved...
    Will uninstall Pinnacle (with less capabilities via Custom), clear
    registry and see what happens.
    Robert Baer, Aug 7, 2013
  11. Robert Baer

    Paul Guest

    At least it isn't hardware for a change.

    And I have no clue, how HAL got in on this.
    You'd think HAL would have better things to do.

    Paul, Aug 8, 2013
  12. Robert Baer

    Robert Baer Guest

    Uninstall of Pinnacle FIXED it; verified by re-installing and getting
    same crash; nail in coffin when uninstall fixed again.
    So..even tho for ages the Pinnacle Instant CD/DVD suite worked
    without problems, and now is PITRA, it goes in the trash.
    Replaced with Nero 6 Ultra which seems to be able to all that i need
    (never cared for or used the "instant R/W virtual CD drive" anyway).

    Robert Baer, Aug 8, 2013
  13. Robert Baer

    Daniel47 Guest

    Ah!! But HAL (of A. C. Clark SF fame) was driven mad (by it's programming!!)

    Daniel47, Aug 8, 2013
  14. Robert Baer

    Robert Baer Guest

    (Almost) always it is a programming problem; poorly written software.
    "Memory leaks" are caused by poor allocation of memory for a task, so
    that release of that memory block is then incomplete and leaves behind
    an inaccessible region of memory.
    There is at least one OS that "helps" to create that problem - using
    that OS memory allocation scheme would always slice out extra space
    before the requested block, along with the block itself; the release
    call would release only the requested block and thus making an
    inaccessible space AKA "memory leak" (OS/2 if i remember correctly).

    I said "almost" because it IS possible to write 100% bug-free
    software; i know someone that did that with great success.
    Robert Baer, Aug 8, 2013
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.