Help - locked out of Gigaset S450IP

Discussion in 'UK VOIP' started by Dave Saville, Oct 13, 2013.

  1. Dave Saville

    Dave Saville Guest

    I can no longer get into the settings of my S450IP - I get an "Access
    is denied because there is already a session initialized by another
    client" There isn't. I have power cycled the 450 twice.

    Any ideas?
     
    Dave Saville, Oct 13, 2013
    #1
    1. Advertisements

  2. Dave Saville

    Woody Guest

    Woody, Oct 13, 2013
    #2
    1. Advertisements

  3. Dave Saville

    Dave Saville Guest

    Dave Saville, Oct 13, 2013
    #3
  4. Dave Saville

    Bob Eager Guest

    Does it have anything like the Linksys ones? You can download an XML fle
    *to* them with all the settings.

    I wrote a script (in REXX) to generate the XML for me, and all I do is
    edit that if I want to change a setting.

    I know it's shutting the stable door, but might help for the future.
     
    Bob Eager, Oct 13, 2013
    #4
  5. Dave Saville

    Dave Saville Guest

    Unfortunately no :-(
     
    Dave Saville, Oct 14, 2013
    #5
  6. Dave Saville

    Dave Saville Guest

    Well it seems well stuck. I have also tried turning the power off for
    an hour, using different machines and different browsers. All no go.

    I am loath to do a reset as if something is failing - say a stuck bit
    - then it might not recover. I still might not be able to get in and
    then I have no phone. As all I wanted to do was alter the dial plan I
    can live with it until it fails.

    Anyone know if later Gigasets can save their config externally? What
    is the curent version of the 450? Does anyone else do a DECT POTS/VOIP
    beast like the Gigasets?

    TIA
     
    Dave Saville, Oct 14, 2013
    #6
  7. Dave Saville

    Woody Guest

    Try disconnecting your network whilst the unit is powered down
    (and that includes the handset,) then power up. It may come up
    with a default setting, otherwise it may try to get its settings
    from the network/outside world. I have a Grandstream BT200 that
    does that.
     
    Woody, Oct 14, 2013
    #7
  8. Dave Saville

    Dave Saville Guest

    Well an hour made no difference. Have not tried a boot with no
    connections.

    I have come to the conclusion that there is a hardware fault that
    *may* preclude me even getting a reset to give me a working box.
    Whilst it's working I will leave well alone until it is broke.
    Which is what I would do if I could get in - Been looking at
    replacements "in case" and it seems that the later versions *do* have
    a config save. Although one report I read said when it came to the
    crunch the saved file would not restore. That was a N300IP which is
    just a base unit which otherwise has good reviews. Wonder if later f/w
    also lets you dial an IP? ie [email protected]? My first SIP box was a
    Zyxel and that could and was years before the Gigaset. What's the
    betting that the saved config file is in a non editable format?

    Gigaset "help line" weren't of course.
     
    Dave Saville, Oct 14, 2013
    #8
  9. Dave Saville

    Dave Saville Guest

    Of which I have no record of all providers. The password isn't the
    problem. If you give it the wrong password it complains but give it
    the right one and it says there is a session already.
     
    Dave Saville, Oct 14, 2013
    #9
  10. Dave Saville

    ßodincus Guest

    | · : · : · : · : · : · : · Original Message · : · : ·: · : · : · : ·
    | From: Dave Saville
    | Date: 14/10/13 17:17
    Old Gigaset DECT phones were consumer / household oriented devices, a
    save/restore option was deemed as not required.

    Is the base getting its IP via DHCP or is it on a fixed IP?

    If the latter, set your PC on a fixed IP in the same range and connect
    the two (and only the two) via a switch or a cross cable, so you're sure
    nothing else can initiate a session with the base.

    Is the "Allow access from external networks" enabled?

    I've had problems with phantom sessions when that was enabled.

    Also try a different PSU, Gigaset bases go nuts if the PSU is off the mark.

    If a factory reset doesn't cure the problem you're pretty [email protected]@@@d up.
     
    ßodincus, Oct 14, 2013
    #10
  11. Dave Saville

    Dave Saville Guest

    The problem was that I was on the learning curve for Cookie Controller
    at just the wrong time :)
     
    Dave Saville, Oct 15, 2013
    #11
  12. Dave Saville

    Dave Saville Guest

    Slight correction after running an IP trace.

    The lock does seem to be early but the cookie is not sent until the
    PIN is accepted.What was happening is that the response + cookie says
    what page to load next and of course blocking the cookie meant it the
    next wasn't requested correctly and the login screen was resent with
    the override of existing session.

    Now trying to knock up some perl to pull the config data.
     
    Dave Saville, Oct 15, 2013
    #12
  13. Dave Saville

    Dave Saville Guest

    Well I can now pull a lot of the config out of the Gigaset with perl,
    but lots of the page setup where there are multiples of the same thing
    - like dial plans - is done by javascript :-( They even use javascript
    to set the item in a select field. What's wrong with <option
    selected="selected" ... ?

    Need to think on how to get around the javascript problem - and
    without using anything other than perl base modules.
     
    Dave Saville, Oct 21, 2013
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.