Hardware profile recovery menu

Discussion in 'Computer Information' started by zaqxws, Jun 8, 2014.

  1. zaqxws

    zaqxws Guest

    OK I had put my drive from my old PC into a USB enclosure to and then read the drive via usb on my new machine, it came a cross a permission problem and I let it go ahead and change the permissions so it would read it.

    Now when I boot up with that drive back in the old machine it boots up to a hardware profile recovery menu.

    I don't know what to do, I exited.
    zaqxws, Jun 8, 2014
    1. Advertisements

  2. zaqxws

    zaqxws Guest

    OK I exited and rebooted again and the problem did not reoccur!! Phew!!
    zaqxws, Jun 8, 2014
    1. Advertisements

  3. zaqxws

    Paul Guest

    Does it look something like this ?


    If you look in the ENUM key, it should have a list of
    all the hardware that was detected in the computer.
    In the Hardware Profiles,

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Hardware Profiles

    It's possible booting to "Last Known Good" would return things
    to the way they were.

    Press F8 at the appropriate time (when the OS boot has
    just started and the BIOS screen disappeared) and Safe Mode
    should have a Last Known Good. All that Last Known Good is
    doing, is looking at the Control Sets, and using a Control Set
    that seemed to be working. This is why there are so many of
    them. You'll notice I listed "CurrentControlSet" above, because
    I think that is the one the OS is currently using for the session.


    There is something on the hardware profiles here.


    Now on my WinXP machine, I'm seeing the Hardware Profile
    menu in the System control panel, under Hardware tab, then
    click Hardware Profiles near the bottom. Since I currently
    only have one hardware profile, there is no selection menu
    for it presented during boot. A Delete key exists down there.
    In a normal situation, the user applies descriptive names,
    such as Portable or Docking Station, so later when it is
    desired to delete one, you'd delete the Docking Station one
    and keep the one that say, a laptop, needs. I would hope
    it wouldn't allow you to delete all of them.

    I think on my Win2K setup, you could copy a profile and
    clean out the ENUM key on it, and that was a mechanism to
    boot Win2K on new hardware (i.e. move it). That's why my Win2K
    disk has four hardware profiles on it in the menu. But on WinXP,
    you can copy a profile and that's usually about it. On WinXP,
    there would be activation to deal with, and too large a hardware
    profile change, would require re-activation. Which is why, other
    than a docking station on a laptop, there's less reason to be using
    additional hardware profiles on WinXP. That's why I only have
    one at the moment, and I don't have sufficient structure
    in Regedit to tell you what multiple profiles would looks like.

    As to why this is happening to you, I haven't a clue. Only if
    you attempted to boot the WinXP hard drive on the wrong computer,
    could strange things happen like this. Just reading the hard
    drive, should not have touched that stuff. (That stuff should
    be in the Registry files.)

    I wouldn't go around using my OS drive as a guinea pig for busted
    hardware. I use data-only drives for that. Not that I would be
    expecting your kind of trouble or anything :) I don't really
    know what happened to it.

    On later OSes, solving ownership problems is done with
    things like TakeOwn. But that is not recommended to be
    done to an entire C: with the OS on it. You have to be
    careful where you apply that, to some data folders perhaps.


    There are sites with a .reg file for download, which
    adds a TakeOwn command to the right-click context menu,
    which is an alternative to using scripts as the previous
    article describes.

    I don't know what's different about your environment. I probably
    use the same username and password on WinXP and Windows 8, and
    amongst my three disks, I don't think I've ever had a problem
    reading files (with any OS). I didn't even install TakeOwn as a context
    menu thing. My Windows 8.1 seems to be pretty laid back.
    I've probably seen problems in the past, with the Preview
    versions of the OS, as I've had several of those installed.
    And I used to have CHKDSK problems as well, and those
    have stopped for the most part (since turning off a few things).

    Using multiple OSes is "creaky" at best - mine is stable
    at the moment. If you don't do anything to the OSes at all,
    they don't really seem to play together all that nice. On
    WinXP, I turned off System Restore. On Win8, I turned off
    Hibernate (powercfg -h off) and stopped drives from spinning down.
    And I think that about did it for me. Peace in the valley.

    Paul, Jun 8, 2014
  4. zaqxws

    zaqxws Guest

    Yes just like that except the screen resolution was screwed up and I could not
    see half of it. However I exited it with out doing anything. Next time I booted up it booted up normally with out that screen appearing.
    Also mine only had one profiles listed so no real choice.

    So........it does not appear to be a problem for me now, it seems to have 'fixed' itself.

    As to why it happened it happened right after I put the drive in my new machine on a second SATA connection, clearly the new machine did something.

    I have now idea about which drive my new machine boots from, I just connected to the spare SATA, maybe that caused a problem ie it tried to boot form there failed and booted normally. I really should have checked before diving it.
    How is the boot drive determined? By jumpers? Cable select?
    I should have check first but thought I 'd be OK.

    I would not normally have used my operating system drive, even for an old machine) but it was the only working drive I had left and needed to know if the USB enclosure worked OK and the test showed it did.

    Anyhow I will now report some stuff in the other thread about the 3 terabyte drive first.
    zaqxws, Jun 8, 2014
  5. zaqxws

    Paul Guest

    Any time you connect a hard drive to an internal SATA port
    (or to an external ESATA port), enter the BIOS setup screen
    and examine the boot order. The BIOS will do "random" things,
    which must be corrected by the user. That's why the wrong
    hard drive ends up booting.


    The thing is, the BIOS attempts to store all the hardware details,
    in 256 bytes of battery-backed RAM. This places rather severe
    limitations on how they remember hard drives. And that's why the
    boot order thing is a trifle "dumb". Apparently, the way it
    works, is the best they could come up with.

    Paul, Jun 9, 2014
  6. zaqxws

    Robert Baer Guest

    * What the heck do those hex values in the tiny boxes mean?
    Robert Baer, Jun 11, 2014
  7. zaqxws

    Paul Guest

    That's some Chinese character set not being handled properly somewhere.

    If the software properly handled the submitted comment, the
    characters would have been rendered properly.

    Paul, Jun 11, 2014
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.