"Handle" does not work

Discussion in 'Computer Information' started by Robert Baer, Dec 21, 2013.

  1. Robert Baer

    Robert Baer Guest

    "error loading driver T"

    So, now what?
    Robert Baer, Dec 21, 2013
    1. Advertisements

  2. Robert Baer

    Paul Guest

    Use a time machine.

    I had to do that with the Sysinternals Contig program.
    I dug up copies from 2006, 2008, and a current one from
    2013. It turned out, the older ones had the ability to
    scan the entire C: drive, which I liked. So I keep
    all three versions handy.

    You can try www.archive.org, to find old ones.
    Download an older version, and test it and see
    if the error goes away. (Note that on Windows 7,
    some of these programs need a "Run As Administrator"
    to coax them along.)


    When you click the "Handle" link, and the
    page appears, look in the upper right hand
    corner for the Download link.

    The thing about archive.org, is the Download links
    seldom work. It's usually an exception when they
    do work. But in this case, you're in luck.
    The reason that happens, is not a failing of archive.org
    as such (they're not being mean), but more the twisted
    way that downloads are served. For example, if the
    download link is ftp://ftp.somesite.com then
    archive.org does not archive FTP servers. That
    would take a lot more disks, than its got. It only
    has around 5,500 disk drives.

    I have downloaded a file around 800MB in size,
    so if you look in the right place, archive.org
    does serve up some damn big downloads. I often
    wonder whether they know they're there. Archive.org
    also responds to takedown notices, and some of the
    missing downloads got whacked. Those ones weren't
    an accident. I particularly like in one case, how
    an old favorite of mine got whacked, then
    after some hardware upgrade, it accidentally
    reappeared. Thank goodness for happy accidents :)
    The miscreant who had it removed, will now have
    to file another complaint.

    Have fun testing,
    Paul, Dec 21, 2013
    1. Advertisements

  3. Robert Baer

    Robert Baer Guest

    As normal for me, i found no such link anywhere in the page except
    one about 2/3 the way down; advertised v3.30 2007.
    So,after re-naming what i had, i downloaded and renamed that,which
    turned out to actually be ver 2006.
    It works. now all i need to do is wrap a BATch file around it so the
    output goes into a file for viewing [it runs in a CMD box and output
    sails by like greased lightning].
    Robert Baer, Dec 21, 2013
  4. Robert Baer

    Robert Baer Guest

    "handle" does not work; frozen by another process that i cannot find.
    Robert Baer, Dec 21, 2013
  5. Robert Baer

    Paul Guest

    I gave you the link, to the entire page of old Sysinternals
    software, so if you need Process Monitor or Process Explorer
    next week, you can go to that page and find an old copy
    that runs on Win2K.

    Don't forget to bookmark that.

    Paul, Dec 21, 2013
  6. Robert Baer

    Robert Baer Guest

    As per normal operation, computer had to be turned off; then handle

    There were a number of processes i object to (snipped from output of
    handle and re-ordered):

    would be nice to remove the following (in order of priority)

    Useless GARBAGE:
    3D0: File (RW-) C:\Program Files\Outlook Express
    394: File (RW-) C:\Program Files\Windows NT\Pinball
    390: File (RW-) C:\Program Files\NetMeeting
    404: File (RW-) C:\Program Files\microsoft frontpage\version3.0\bin
    39C: File (RW-) C:\WINNT\Speech

    1B8: File (RW-) C:\Program Files\Internet Explorer
    41C: File (RW-) C:\Program Files\Internet Explorer\Connection Wizard

    Other junk:
    4E8: File (RW-) C:\Program Files\Common Files\Microsoft
    548: File (RW-) C:\WINNT\mww32\modem

    3EC: File (RW-) C:\WINNT\system32\os2\dll
    3F4: File (RW-) C:\WINNT\system32\export
    54C: File (RW-) C:\WINNT\system32\rocket

    1C0: File (RW-) C:\Program Files\Common Files\Microsoft Shared\Triedit
    38C: File (RW-) C:\Program Files\Common Files\Microsoft Shared\MSInfo
    3FC: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\servsupp
    400: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\bots\vinavbar
    408: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\admcgi\scripts
    40C: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\admisapi\scripts
    410: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\isapi
    414: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\bin\1033
    52C: File (RW-) C:\Program Files\Common Files\Microsoft Shared\web
    server extensions\40\_vti_bin
    540: File (RW-) C:\Program Files\Common Files\Microsoft Shared\VGX
    Robert Baer, Dec 22, 2013
  7. Robert Baer

    Paul Guest

    I think what might be going on there, is Winlogon has opened
    a handle to executables (programs), to prevent malware
    from replacing them. That's my guess. And these would be executables
    that came with the OS. Instead of the executables you have installed.

    I think you'd be more interested, in what program is opening handles
    to your data files.

    Just a guess,
    Paul, Dec 22, 2013
  8. Robert Baer

    Robert Baer Guest

    That is an excellent idea but i have no clue as how to do that.
    Am guessing that having a program that logs PC activity from start of
    boot to completion might help.
    But that argues such a program be FIRST to run and (until OS is fully
    loaded) be as impossible to kill as OE.
    Robert Baer, Dec 23, 2013
  9. Robert Baer

    Robert Baer Guest

    ** Snip a bunch **
    Handle ver 2006 works in console mode, *BUT* is not
    recognized as a program in a batch file (!!).
    ** Snip a bunch **
    * Absolutely NOTHING can ermove tese; Regedit delete, file delete,nothig.
    They all pop back.
    Who gives a rat about pinball as a permanent fixture of any OS?
    But there it is, wasting space, courtesy of His Nibs.
    * Very possible, but Handle and ProcessExplorer, to me, gives no clear
    Maybe because i do not know what exactly to look for.

    A) Starting at initial install of Win2K (SP2), then SP4, then rollup,
    there are a number of devices as seen in device manager that are not
    B) Motherboard sound, video, and Ethernet port are next (via ASUS driver
    C) Then since i have a video capture card, its driver.
    If i do not get the video drivers installed in the "proper" order i
    sometimes need to re-do the video crossbar driver.
    Still not completely happy.
    D) Next is my flatbed scanner which satisfies most of the remaining USB
    E) Lastly, Paraben Screen Capture program which links to the scanner

    I think that makes it complete.
    As to which driver(s) are being replaced, Hoo Nose?
    Only (so-called) clue is that if i do a fresh install of Win7, i
    cannot (normally) use ANY of the ASUS drivers for the motherboard - BUT
    (when Win7 might be treating me right) it all works. Status always
    different WRT previous installs. Sometimes one or more of the ASUS
    drivers is allowed if and only if done outside the ASUS CD "shell".
    A given Win7 install does not change device driver attributes unless
    i fiddle with a driver in trying to make it happy.
    The only point WRT Win7, is that a driver CAN come from the OS even
    tho there is none for the obsolete hardware.
    So..that opens the possibility that you mentioned.
    Robert Baer, Dec 24, 2013
  10. Robert Baer

    Paul Guest

    First, I tried to find an article about removing the games folder
    in Win2K. Some of the other OSes, they do this via Add/Remove Programs
    control panel, via a separate section that controls Windows Components.
    But I don't see one of those in Win2K. So I'll have to give up
    on that idea for now.


    And this link, covers System File Protection. What I found interesting
    about this, is the registry key is part of Winlogon. The very same
    process that has "handles" on those system files. In this article,
    they review a setting to disable SFC. I don't know if the registry key
    itself is protected in any way, with permissions or not. That tends
    to be more of an issue with later OSes. (Adding an extra step to
    disable the permission on a registry key, before you can edit it.)

    This isn't exactly a wise idea, but it could, in theory, stop
    Winlogon from having those handles. It would no longer have a reason
    to open a handle, if SFC function is not required.


    But it does make me wonder about one thing. Are you storing user
    data files *inside* an OS folder ?

    And a second question would be, if you create a new user account
    and password (creating a new user profile), then log in as that user,
    does the nightmare behavior with regard to locked files continue
    or not ?

    If your setup is otherwise working OK, maybe it's better just
    left alone :) Make a backup at least, before breaking something.

    Paul, Dec 25, 2013
  11. Robert Baer

    Robert Baer Guest

    * Removing games seems simple: Start/Programs highlight Games and
    delete. That is all i have ever done. Doing a search for "games" gives
    games.inf, games.pnf, nvgames.dll and nvgamesr.dll (DLLs in system 32
    * Almost all of my data files & folders are on another partition/drive.
    The few exceptions are related to/in:
    C:\Documents and Settings\Robert Baer\Application Data
    C:\Documents and Settings\Robert Baer\My Documents
    C:\Documents and Settings\Robert Baer\Personal
    C:\Program Files
    * I have never created a new user account.
    As far as this funnybusiness concerning data files, i have yet to
    figure out how to repeat a failure mode.
    It seems that when i am doing a lot of work on one or more files: say
    in CorelDraw), it may happen - but only when i care about results AKA
    real work.
    Fiddling around with a file in attempt to get a glitch so far has failed.
    Extremely frustrating.
    A friend of mine said "RAM is cheap, try new RAM".
    So, since i have a 1GB stick, i ordered two 1GB sticks same speed as
    what i have now.
    Am doing that, using UBCD - and then fiddle on the backup, and
    finding no faults. Yet.
    Ran two different memtest progs in UBCD - all pass.
    No surprise.
    In my experience, no memtest program will find fault in memory unless
    the memory is so bad as to make the computer virtually useless.
    The only "acid test" for memory is to replace it; if you see
    improvement then you had bad RAM (memtest program will NEVER find fault).
    And this is since 1980 when there was 65K max RAM.
    Robert Baer, Dec 26, 2013
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.