Hal.dll missing in dell com.

Discussion in 'Computer Support' started by bdeditch, Jan 23, 2008.

  1. bdeditch

    bdeditch Guest

    I started up my computer this morning to see the message missing
    hal.dll. I googled, another computer, it and found out that all I had
    to do was reinstall it. I can't get the computer to even go into safe
    mode, so I thought I would put in my dell Reinstallation CD. I booted
    from cd and everything was fine untillit asked for adminstrator
    password. I have no idea what this is. I tryed the one I log on with
    and nothing worked. What the next step?
     
    bdeditch, Jan 23, 2008
    #1
    1. Advertisements

  2. bdeditch

    meerkat Guest

    Ask Dell ?.
     
    meerkat, Jan 23, 2008
    #2
    1. Advertisements

  3. --

    Ford Electronics Ltd
    01902 851715

    www.fordelectronics.co.uk


    is it a 'blank' password

    roy
     
    Roy Collingwood, Jan 23, 2008
    #3
  4. bdeditch

    Pennywise Guest

    A Hal.dll missing error is usually an error in the Boot.ini or it's
    missing (boot.ini).

    Enter the recovery console and type:
    Bootcfg /Rebuild
    http://articles.techrepublic.com.com/5100-10877_11-6031733.html
    #4 and #5
     
    Pennywise, Jan 23, 2008
    #4
  5. bdeditch

    bdeditch Guest

    I Tried blank for the password or do you mean type in blank?
     
    bdeditch, Jan 23, 2008
    #5
  6. bdeditch

    bdeditch Guest


    What I did called Dell support this morning. Theis what they got me to
    do. By the way the password was blank.
    first we tried bootcfg/list
    That didn't work, said it was bad command
    then we tried

    expand cd-rom:\e386\ntoskrnl.ex_drive:\windows\system32

    that didn't work either, then tried

    expand cd-rom:\e386\ntkrmlmp.ex_drive:\windows\system32\ntoskrml.exe
    didn't work either

    now trying
    chkdsk /r
    After that I typed in
    fixboot press enter

    then enter Y for yes
    and then exit to reboot system.

    None of that worked either, guess its time to reformat and install
    new.
     
    bdeditch, Jan 24, 2008
    #6
  7. bdeditch

    Pennywise Guest

    Because it's bootcfg /list
    (notice the space), but that's a useless step.

    Just use:
    Bootcfg /Rebuild
     
    Pennywise, Jan 24, 2008
    #7
  8. bdeditch

    Pennywise Guest

    Just in case,
    Assuming you have D:\ drive as your CD drive, and C your OS drive.
    the commands should be:

    expand D:\i386\ntoskrnl.ex_ C:\windows\system32
    (it's i386 not e386)

    expand D:\i386\ntkrmlmp.ex_ C:\windows\system32\ntoskrml.exe
    (it's i386 not e386)
     
    Pennywise, Jan 24, 2008
    #8
  9. bdeditch

    bdeditch Guest

    I tried the rebuild it didn't work. They did put a space in there as
    well with the bootcfg /list
     
    bdeditch, Jan 24, 2008
    #9
  10. bdeditch

    bdeditch Guest

    That is what I was thinking as well about using D not cd-rom
     
    bdeditch, Jan 24, 2008
    #10
  11. bdeditch

    Pennywise Guest

    Give it another try and I made a mistake:

    So run these two commands they are different than above:

    expand D:\i386\ntoskrnl.ex_ C:\windows\system32\ntoskrnl.exe
    and
    expand D:\i386\ntkrmlmp.ex_ C:\windows\system32\ntkrmlmp.exe

    (space between _ C)
     
    Pennywise, Jan 24, 2008
    #11
  12. bdeditch

    bdeditch Guest

    What do I do after that if it works?
     
    bdeditch, Jan 25, 2008
    #12
  13. bdeditch

    Pennywise Guest

    If it works you would remove the XP CD from the CD drive and reboot,
    and it will :)
     
    Pennywise, Jan 25, 2008
    #13
  14. bdeditch

    Plato Guest

    Your boot.ini is incorrect.
     
    Plato, Jan 25, 2008
    #14
  15. bdeditch

    bdeditch Guest

    Thanks Penny I will try that and let you know later if it worked :eek:)
     
    bdeditch, Jan 25, 2008
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.