Grandstream BT200

Discussion in 'UK VOIP' started by Woody, May 10, 2013.

  1. Woody

    Woody Guest

    I have just acquired one of these beasties and it set up and
    registered with my voip provider through its web interface
    quickly amd easily.

    I went into it to change the ringing cadence to make it similar
    to UK. When I rebooted it went off line (deregistered) and would
    not reconnect.

    So I did a full reset on it - MISTAKE! It has come back with DHCP
    on and collected its IP address from my router (and for that
    matter the time as well.) However whenever I try to access its
    browser interface to set it up again it rejects the password I
    enter - that is any password I can think of including 'admin'
    which is its default.

    Anyone come across this or got any ideas? Grandstream seem pretty
    hopeless at support as far as I can see.
     
    Woody, May 10, 2013
    #1
    1. Advertisements

  2. Woody

    Graham. Guest


    Is it possible it was origanaly locked to a provider and subsequently
    unlocked, and you resetting it has loaded the defaults which
    reprovisioned it?

    Just thinking alowed really, I have no idea if the BT200 supports
    remote provisioning, but one of my PAP2s would become a Vonage brick
    if I made the same mistake.
     
    Graham., May 10, 2013
    #2
    1. Advertisements

  3. Woody

    Woody Guest


    Thanks for the reply. The phone, when bought a few days ago,
    was/is brand new and boxed. It had never had any settings in it
    other than default as far as I can see.

    The handbook says that after a hard reset as I have done -
    twice - the admin password is admin and it is that that is being
    rejected.

    I have resigned myself to this being a £24 (inc postage) brick.
    You live and learn, or at least you are supposed to!
     
    Woody, May 10, 2013
    #3
  4. Woody

    tony sayer Guest

    Try "admin" and then "123"

    You shouldn't really be locked out like that. I remember we set up some
    of these or similar units a while ago and it was something odd the
    password or there just wasn't one!..

    Cheers...
     
    tony sayer, May 10, 2013
    #4
  5. Woody

    Graham. Guest

    Try user=admin password=123
     
    Graham., May 10, 2013
    #5
  6. Woody

    Woody Guest



    Who's been looking at the manual then?

    You only get the option to enter a password, not a username. If
    you enter 'admin' you go into admin mode, if you enter '123' you
    go into user mode. Simples. Trouble is neither work!

    However in the light of your comment about Vonage ATA's (yes, I
    have a couple of them as well!!) I have mailed the original
    supplier just in case they did change the default password.

    Time will tell no doubt.................
     
    Woody, May 10, 2013
    #6
  7. Woody

    Woody Guest



    Later last night I noticed the phone was and still is on line. I
    tried to make a call and it asked me to end my Freewire ID or
    voucher code. This is a 'service' provided for university
    students so I have a horrible feeling the phone may be hard
    coded.
     
    Woody, May 11, 2013
    #7
  8. There's a replacement firmware here:
    http://devel.0cpm.org/firmerware/

    Installing it looks rather involved, but the reverse engineering notes may
    be of use.

    Theo
     
    Theo Markettos, May 12, 2013
    #8
  9. Not very, I've just found BT200 firmware 1.2.5.3 (dated 9 December 2010)
    stored on an old computer here.
     
    Andrew Benham, May 13, 2013
    #9
  10. 1.2.5.3 is the latest firmware available for the BT200:
    http://www.grandstream.com/support/firmware

    You can configure the BT200 to upgrade firmware from a TFTP server from
    the keypad - Menu, option 06, enter the IP address, Menu to save, reboot
    the phone and it should download and upgrade the firmware.
     
    Andrew Benham, May 13, 2013
    #10
  11. Woody

    Woody Guest



    Tried that, no joy. It seems the phone was originally used on the
    Freewire service used in many universities and that is what the
    phone has defaulted to - it even registers on my broadband.
    However if I try to make a call it asks for a Freewire ID or
    voucher code. Maybe that is why it is showing a number xxx-xxxx
    on the screen?

    I couldn't imagine that a small company like Freewire would have
    special firmware built in by the manufacturer so I can only
    assume there is some sort of hard reset default - which is what I
    have found - to stop clever students making the phone work for
    them doubtless at considerably cheaper rates.
     
    Woody, May 14, 2013
    #11
  12. Woody

    Woody Guest

    Further on that. I notice that Freewire do not have a web site -
    maybe they are no more? If I dial the number on my display I get
    a US engaged tone and the display shows 486.

    Eh?
     
    Woody, May 14, 2013
    #12
  13. 486 = Busy Here (i.e. the called party is busy)

    http://www.websitepulse.com/kb/sip_status_codes.html
     
    Anthony R. Gold, May 14, 2013
    #13
  14. Woody

    Woody Guest

    Call to the supplier sorted it. Disconnect my router from web,
    then reset phone. Access internal web server and bingo, access at
    last.

    Seems the phone goes on line and asks a tftp server for its info.
    Cut that off and you can access it.

    Many thanks to all for suggestions.
     
    Woody, May 14, 2013
    #14
  15. Check all the configuration menus, there may be an option somewhere for the
    location of the configuration. I played with the autoconfiguration options
    of the grandstream BT101 once and there is an option for a configuration
    via tftp or http.

    (yes, interesting loops are possible. As well as neat auto-provisioning
    systems)

    The BT101 also fetches firmware updates from that same location.

    Koos van den Hout
     
    Koos van den Hout, May 15, 2013
    #15
  16. Woody

    Woody Guest


    Yep, found that and deleted it.
     
    Woody, May 16, 2013
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.