Google Search engine in Firefox not in my language

Discussion in 'Firefox' started by Thomas, Feb 8, 2005.

  1. Thomas

    Thomas Guest


    I have Firefox 1.0. When I use the google window on the top-right
    corner, it opens automatically the website which is in
    german... but i don't speak german.
    I can understand that it opens since i'm located in
    Switzerland (though I don't know how it can know that and how to change
    that)... but how to configure this google tool in Firefox to be on automatically instead of (i'm french-speaking).

    Thanks for your help !

    Thomas, Feb 8, 2005
    1. Advertisements

  2. Thomas

    Splibbilla Guest

    in the optoins, there might be a language selection.

    or maybe...
    in folder
    there might be a google.src
    that you can open wiht text editor (notepad) to change teh http to your langauge google.

    you also *might* have to comment-out the update function, or ff might 'update' teh src back to google-wrong-language. i
    assume that would happen.
    Splibbilla, Feb 9, 2005
    1. Advertisements

  3. Thomas

    Neil Guest

    I don't know how it would work in FireFox but in the Suite it might help
    set your language preference to fr-ch.
    Neil, Feb 10, 2005
  4. Thomas

    Thomas Guest

    Neil a écrit :
    Indeed my language preference is first French (french-ch, french-fr...)
    then english. No mention of the german. So i doesn't fix the problem. I
    think the explanation above stating that google is redirecting to (which default language is german) automatically might be the
    correct one.
    So not possible to change that ?
    Of course i downloaded other search engines in the search bar (including
    google FR) but the default search item at the opening will be always, right ?? ('cuz i tried to rename the google FR src file with
    the goole src default file thinking that it will replace it but it
    doesn't work...)
    Thomas, Feb 11, 2005
  5. Thomas

    Thomas Guest

    It seems to work,

    Thank you

    Simon Kellett a écrit :
    Thomas, Feb 12, 2005
  6. I had the same problem: I am English but live in Germany. English is
    still my preferred language. I think Google must lookup you IP address or

    IIRC my solution was to configure Google, not Firefox. Go to Google,
    find the preferences and select your preferred language and save the
    preferences. I guess it saves a cookie to remember it for next time.
    Simon Kellett, Feb 12, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.