Ghost restore and HAL.DLL is missing?

Discussion in 'Computer Support' started by John, Oct 2, 2005.

  1. John

    John Guest

    I have purchased a new hard drive, and partitioned it with Powerquests
    Partition Magic. I then tried to restore a "Ghost backup" of my old drive
    to the active primary partition. The restoration went ok, but the new disc
    will not boot.
    It states HAL.DLL is missing or corrupt, "Please replace a copy of the
    file". I have tried using a copy from the still working "old hard drive"
    and also from a win XP installation disc, but I still get the same error.
    Anyone know hot to fix this? What is the point of a "Ghost" backup, if I
    cannot install it to another HDD! I know HAL means "Hardware Abstract
    Layer", but is this just another Microsoft anti piracy cockup?

    John
     
    John, Oct 2, 2005
    #1
    1. Advertisements

  2. John

    doS Guest

    How did you format the new drive, if you have ddo THAT IS THE PROBLEM.
     
    doS, Oct 2, 2005
    #2
    1. Advertisements

  3. John

    John Guest

    Partition manager dealt with all that, and copied all the files. I think it
    is becase I have added another Fat32 4gig partition before the other
    partitions.
    I now have 4gig (Fat32 Primary) 30gig (NTFS Primary) 30gig (NTFS Extended)
    220gig (NTFS Extended) (300gig HDD)
    The old HDD was a 300gig, but partitioned to 60gig, and 220gig.

    The idea is to have a small XP partition that is normally "Hidden" on the
    4gig fat32, and the main system on the Primary 30gig. The other 30gig is a
    backup.

    John
     
    John, Oct 2, 2005
    #3
  4. John

    Unk Guest

    RTFM - You did it wrong.
    Guide to Norton Ghost - http://ghost.radified.com/
     
    Unk, Oct 3, 2005
    #4
  5. John

    FullName Guest

    Correct. BOOT.INI now does not point to the correct partition number where
    the Windows directory is located.

    BOOT.INI probably looks like this

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP" /fastdetect

    But your installation may have that FAT32 partitiion on "partition(1)" in
    the above BOOT.INI lines. May need to point to e.g.,

    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    ^^^
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows XP" /fastdetect
    ^^^

    See here
    http://www.terabyteunlimited.com/kb/article.php?id=130
    and perhaps use EDITBINI.EXE copied to a 9x boot floppy to fix your BOOT.INI
    http://www.terabyteunlimited.com/utilities.html
     
    FullName, Oct 3, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.