ftp through cisco vpn client fails - any idea why?

Discussion in 'Cisco' started by porky_pig_jr, Feb 22, 2005.

  1. porky_pig_jr

    porky_pig_jr Guest

    [this is the question not about the cisco routers, but the problem
    related to Cisco VPN]

    In our school, we use cisco vpn on WLAN (I have client software version
    4.05 installed on my laptop). Everything works except ftp transfer from
    client (that is me) to server. When I'm watching ftp log, seems like
    everything works fine, the directory entry is created on a server, then
    just as transfer of actualy data presumably start, it hangs. The
    transfer from server to client works fine. The transfer from client to
    server when I connect my laptop to ethernet and bypass vpn completely -
    well, that works fine as well.

    (I"m runing Windows XP, Pre-SP2).

    PC Support is completely stumbled. First they have told me to turn off
    the firewall (I run zone alarm). That didn't help. Second they told me
    to use passive mode of ftp. I have Absolute FTP client and Filezilla,
    so I have enabled passive mode on both of them. Both failed, with the
    timeout. I have also tried scp, timeout again. Boo hoo, I know very
    little about VPN, no idea what to try next, and what is the culprit.
    Anyone here who had similar problem?

    [sorry if this is not the best usenet group to post this question. I
    did some searches on 'vpn' and 'ftp' and got this one, and since the
    software I use *is* cisco vpn, I've decided to take the chance.]
     
    porky_pig_jr, Feb 22, 2005
    #1
    1. Advertisements

  2. :In our school, we use cisco vpn on WLAN (I have client software version
    :4.05 installed on my laptop). Everything works except ftp transfer from
    :client (that is me) to server. When I'm watching ftp log, seems like
    :everything works fine, the directory entry is created on a server, then
    :just as transfer of actualy data presumably start, it hangs. The
    :transfer from server to client works fine.

    Try lowering your MTU or turning on Path MTU Detection on
    your XP machine.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q314825

    http://www.cisco.com/warp/public/471/l2tp_mtu_tuning.html#tuning_methods
    [I know you aren't using LT2P but the MTU information there is
    the same as it would be for IPSec.]
     
    Walter Roberson, Feb 22, 2005
    #2
    1. Advertisements

  3. porky_pig_jr

    Rocky Smith Guest

    I agree. I have seen this problem before. An application will work
    fine until you attempt to push some data.

    MTU is the answer!
     
    Rocky Smith, Feb 22, 2005
    #3
  4. porky_pig_jr

    porky_pig_jr Guest

    To those who replied: thanks a lot, that's a great idea. I"ve made the
    changes in the registry, will be testing it tomorrow. Hope it will
    work.

    Incidently, I did work with cisco routers, and as you probably well
    know, MTU settings on serial links default to the ethernet, so no
    problems there, and I've never worked with VPN - so I kind of took for
    granted that MTU normally match, and never even thought of them. Oh
    well ...
     
    porky_pig_jr, Feb 24, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.