FTP download doesn't work

Discussion in 'Cisco' started by rhille69, Oct 16, 2005.

  1. rhille69

    rhille69 Guest

    Hi,

    I try to download a new IOS from my ftp server. The upload of the old
    (running) IOS is working fine but the download of the new IOS doesn't
    work. I have no access-list active.
    The command that I use is

    copy ftp://user:p[email protected]//ciscoIOS/2600.bin flash:2600.bin

    The file on the ftp server has 777 permission. As I said, if I upload
    the running IOS

    copy flash:2600.bin ftp://user:p[email protected]//ciscoIOS/2600.bin

    it works and I see the image in the same directory where the new one
    is.

    Thank you
    Reinhard
     
    rhille69, Oct 16, 2005
    #1
    1. Advertisements

  2. rhille69

    tibo Guest

    What are the error message on the router and on the ftp server ? Have you
    tried tftp ?
     
    tibo, Oct 16, 2005
    #2
    1. Advertisements

  3. rhille69

    Napik Guest

    I think you typed too many slashes ("/"), it should be like
    ftp://user:p[email protected]/ciscoIOS/2600.bin
     
    Napik, Oct 17, 2005
    #3
  4. rhille69

    rhille69 Guest

    Hello Napik,
    thank you for your answer and sorry for answering so late, I was ill. I
    don't agree even I'm not 100% sure but if you use just one slash than
    it is looking under the ftp root directory for a directory called
    ciscoIOS but this directory is under the root (/) directory - and why
    is it work the other way?
    Nevertheless I will give it a try.

    Reinhard
     
    rhille69, Oct 19, 2005
    #4
  5. rhille69

    rhille69 Guest

    Hi tibo,
    thank you fro your answer and also sorry for answering so late.
    That's the weird thing - I discovered (using snoop) that no ftp
    connection will be opened if I want to download the IOS but as I said
    bevor no problem if I upload the IOS.
    The router shows only

    copy ftp://user:p[email protected]//ciscoIOS/2600.bin flash:2600.bin...

    and that's it. No entries in the log and also on the router no hint
    that an connection will be opened to a ftp-server.

    I'm not a router expert but I believe that must be a bug in the IOS.

    Thank you
    Reinhard
     
    rhille69, Oct 19, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.