FreePBX Inbound Calls Problem (do i need another trunk to VoIP Talk? or summut)

Discussion in 'UK VOIP' started by dune73, Jul 12, 2007.

  1. dune73

    dune73 Guest

    Heya everyone... i got a slight problem

    My outgoing calls work fine, but i got a slight problem with incoming
    calls, im running Asterisk (Ver. SVN-branch-1.2-r74427), with FreePBX
    2.2.2

    iv got an outbound trunk through VoIPCheap, and 3 incoming number from
    VoIPTalk

    the voiptalk numbers are being routed to a SIP Compatible PBX, then
    using "inbound routes" inside freepbx the numbers are entered into the
    "DID Number" and set to goto the correct extension !

    Unfortunatly, if someone calls into any of those numbers, they can
    hear me fine ! but i cannot hear anything they are saying and then
    after 20 seconds (exactly, every time) it closes the channel, which
    results in the calling party's phone still appearing to be on a call
    (hence when i call from my mobile, the line stays active but my
    FreePBX asterisk info module reports no active channels)

    Anyone got any ideas, im a complete newby at this, and followed this
    installation guide to get to where i am "http://aussievoip.com.au/wiki/
    freePBX-Centos" but did not do addition configuration to zaptel as i
    dont think im using this, just SIP Trunks to voipCheap !

    Check out my Asterisk Log File at http://www.fluxbox.co.uk/AsteriskLog.rtf

    PLEASE HELP ME LOL !
     
    dune73, Jul 12, 2007
    #1
    1. Advertisements

  2. dune73

    Jono Guest

    used his keyboard to write :
    Voiptalk is a bit if a PITA to set up for inbound calls.

    It's so long ago that I got mine working, I'm not sure I can remember
    the steps I took. However......

    Post the contents of your sip.conf file, the PEER details & the USER
    details from the trunk itself and we'll have a look
     
    Jono, Jul 13, 2007
    #2
    1. Advertisements

  3. dune73

    alexd Guest

    Do inbound calls work fine with handsets connected directly to the "SIP
    Compatible PBX"?
    Poor them :p
    Are you using NAT? One-way audio is invariably NAT-related. What do you have
    for

    localip=
    externip=
    nat=

    in your various sip*.conf files in /etc/asterisk ?
    Correct, if you're just using IP trunks, ignore Zaptel.
    Plain text next time, please.
    Riiiiiiiiiiiight.
     
    alexd, Jul 13, 2007
    #3
  4. dune73

    dune73 Guest

    okay, few config details, firstly iv got the machine sat inside the
    DMZ of my Draytek 2900 router, so the firewall hopefully should be a
    mute point !, due to the fact im on a vigin media connection, i have a
    dynamic IP, hence im using enternhost in my sip.conf file (which i
    only added yesterday, didnt help)

    SIP.CONF

    -----------------------------------------------
    ; Note: If your SIP devices are behind a NAT and your Asterisk
    ; server isn't, try adding "nat=1" to each peer definition to
    ; solve translation problems.

    [general]

    externhost = testing.dnsalias.com
    externrefresh = 60
    bindport = 5060 ; Port to bind to (SIP is 5060)
    bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
    disallow=all
    allow=ulaw
    allow=alaw
    ; If you need to answer unauthenticated calls, you should change this
    ; next line to 'from-trunk', rather than 'from-sip-external'.
    ; You'll know this is happening if when you call in you get a message
    ; saying "The number you have dialed is not in service. Please check
    the
    ; number and try again."
    context = from-sip-external ; Send unknown SIP callers to this context
    callerid = Unknown
    tos=0x68

    ; #, in this configuration file, is NOT A COMMENT. This is exactly
    ; how it should be.
    #include sip_nat.conf
    #include sip_registrations_custom.conf
    #include sip_registrations.conf
    #include sip_custom.conf
    #include sip_additional.conf
    --------------------------------------------------------------------------------------------

    Trunks currently setup
    1.
    VoIPCheap
    GENERAL SETTINGS--------------------------
    Outbound caller ID - BLANK
    NEVER OVERIRE - NOT TICKED
    MAX CHANNELS - BLANK

    OUTGOING DIAL RULES -----------------------
    DIAL RULES - BLANK
    OUTBOUND DIAL PREFIX - 0044

    OUTGOING SETTINGS------------------------
    TRUNK NAME - VoIPCheap
    PEER DETAILS -
    call-limit=5
    canreinvite=no
    dtmfmode=inband
    fromdomain=voipcheap.com
    fromuser=Aaron.Smith
    host=sip.voipcheap.com
    insecure=very
    qualify=yes
    secret=PASSWORD
    type=friend
    username=Aaron.Smith

    INCOMING SETTINGS------------------------
    USER CONTEXT - BLANK
    USER DETAILS - BLANK

    REGISTRATION-------------------------
    REGISTER STRING - Aaron.Smith:p/Aaron.Smith


    I HAVE SETUP A VOIPTALK TRUNK AS WELL USING
    PEER DETAILS -
    context=default
    dtmfmode=rfc2833
    fromdomain=voiptalk.org
    fromuser=84454340
    host=voiptalk.org
    insecure=very
    qualify=yes
    secret=PASSWORD
    type=friend
    username=84454340

    REGISTER STRING -
    84454340:p/84454340

    But nothing seems to work, as for incoming im simply setting the PSTN
    numbers in incoming routes as the DID Number

    e.g
    Route: 01752548878//
    DID Number - 01752548878
    CID Number - BLANK
    Destination - CORE AARON SMITH <5001>

    ---------------------------------------------- The Alternate
    ----------------------------------------
    I got all paranoid that it was summut i hadnt done during the
    installation, so i downloaded and installed a copy of TrixBox (which
    is a complete ISO off all relevant files, it basically installs
    asterisk, FreePBX and a shed load of other stuff and config's it all
    for ya)

    Installed that into a virtual machine, again inside the DMZ (VM had
    its own IP address) set up the configuration the same as shown above
    and i got exactly the same problem (but with a slight laggy voice
    connection, Parallels did its best lol)
     
    dune73, Jul 14, 2007
    #4
  5. dune73

    Jono Guest

    formulated on Saturday :
    change the above line to:

    externip = testing.dnsalias.com ; assuming testing.dnsalias.com points
    to your actual IP

    You also need to add a line such as:
    localnet=192.168.1.0/255.255.255.0 ; where the first 3 octets match
    your network
    Comment out the above line and add immediately below it:
    context = from-trunk

    Below is my sip.conf for ref:

    [general]

    port = 5060 ; Port to bind to (SIP is 5060)
    bindaddr = 0.0.0.0 ; Address to bind to (all addresses on machine)
    disallow=all
    allow=ulaw
    allow=alaw
    allow=gsm
    ;context = from-sip-external ; Send unknown SIP callers to this context
    context = from-trunk
    ;defaultexpirey = 600 ; include this only if necessary
    ;maxexpirey = 3600 ; include this only if necessary
    progressinband = yes
    ;dtmfmode=auto

    callerid = Unknown
    externip = my.dyndns.hostname
    localnet=192.168.1.0/255.255.255.0
    nat=yes

    #include sip_nat.conf
    #include sip_custom.conf
    #include sip_additional.conf



    My Voiptalk Trunk

    (Outgoing Part)

    allow=ulaw
    authuser=8digitVTusername
    canreinvite=no
    context=from-pstn
    defaultexpirey=160
    disallow=all
    fromdomain=voiptalk.org
    fromuser=8digitVTusername
    host=voiptalk.org
    insecure=very
    maxexpirey=180
    nat=yes
    secret=secret
    type=friend
    username=8digitVTusername

    (Incoming part)

    Context ext-did

    allow=ulaw
    authuser=8digitVTusername
    canreinvite=no
    context=ext-did
    defaultexpirey=160
    disallow=all
    fromdomain=voiptalk.org
    fromuser=8digitVTusername
    host=voiptalk.org
    insecure=very
    maxexpirey=180
    nat=yes
    secret=secret
    type=peer
    username=8digitVTusername

    Register
    8digitVTusername:/8digitVTusername

    In extensions_custom.conf, I added the following:
    [custom-voiptalk]
    exten => 8digitVTusername,1,Goto(ext-did,8digitVTusername,1)

    In DID route create a DID that matches your 8digitVTusername, not your
    PSTN number.
     
    Jono, Jul 14, 2007
    #5
  6. dune73

    dune73 Guest

    jono... worked awsom, was one of them lines added to sip.conf i didn't
    have to add any of the other stuff, thanks a load ! my desk also
    thanks you (as my repeated impacts by my head were starting to make a
    dent !)
     
    dune73, Jul 14, 2007
    #6
  7. dune73

    Jono Guest

    Jolly good. Don't recall ever being thanked by a desk before!
     
    Jono, Jul 14, 2007
    #7
  8. dune73

    alexd Guest

    That should have been localnet=, of course.
     
    alexd, Jul 14, 2007
    #8
  9. dune73

    dune73 Guest

    Okay thanks again mate, but its still being a little buggy, every now
    and then (random intervals) im loosing calls, their just dropping,
    also although most calls are fine now with 2 way audio im still
    getting the occasional one where i cant hear the person calling in !
     
    dune73, Aug 2, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.