Freepbx + grandstream GS-HT702 woes

Discussion in 'UK VOIP' started by Evan Platt, Nov 16, 2013.

  1. Evan Platt

    Evan Platt Guest

    So - I'm in the US if that matters, but couldn't locate another voip
    group :)

    I have Freepbx and a grandstream hs-ht702.

    I've tried every combination of codecs, to no avail. Initially, I
    configured (by accident) the grandstream to connect directly to
    flowroute. It worked. Then, I reconfigured the grandstream to
    correctly connect to my pbx server. I get a dialtone, and dial, but
    get no audio. People can hear me, but I can't hear anything. I've
    tried codec by codec, only using one codec on both the pbx and on the
    grandstream.

    I have in Codecs on the server g723 and lbc enabled, and on the
    grandstream g723 & ilbc. In the extension, I have "g723&ilbc" for
    Allow.

    Here's one of the most recent logs.

    Any suggestions / ideas?

    Thanks. (Not sure if more is needed from the logs- numbers munged.)

    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] netsock2.c: == Using
    SIP RTP TOS bits 184
    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] netsock2.c: == Using
    SIP RTP CoS mark 5
    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] app_dial.c: -- Called
    SIP/flowroute/###########
    [2013-11-15 23:21:18] WARNING[29893][C-00000031] channel.c: No path to
    translate from SIP/flowroute-00000032 to SIP/1-00000031
    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] app_macro.c: == Spawn
    extension (macro-dialout-trunk, s, 22) exited non-zero on
    'SIP/1-00000031' in macro 'dialout-trunk'
    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] pbx.c: == Spawn
    extension (from-internal, ###########, 5) exited non-zero on
    'SIP/1-00000031'
    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] pbx.c: -- Executing
    [[email protected]:1] Hangup("SIP/1-00000031", "") in new stack
    [2013-11-15 23:21:18] VERBOSE[29893][C-00000031] pbx.c: == Spawn
    extension (from-internal, h, 1) exited non-zero on 'SIP/1-00000031'
     
    Evan Platt, Nov 16, 2013
    #1
    1. Advertisements

  2. Evan Platt

    Graham. Guest


    Welcome aboard, this group needs the traffic.

    I am not a SIP expert but I will try to help.

    Is your VoIP kit behind a NAT router?

    If yes, that is likley to be the issue rather than codec
    incompatability, and The rest of this reply assumes that it the case.

    Perhaps your Grandstream uses STUN, Asterisk does not use it for some
    reason.

    First thing, if your router has a SIP ALG setting, turn it off, quite
    often it doesn't help, and can actually cause more problems.

    How have you set the NAT setings "Astrisk SIP Settings in Freepbx?

    Is there a valid setting for your external static IP address or
    dymamic host (dyndns etc)?

    I happen to have a Flowroute account and FreePBX (RASPBX actually) so
    I might have a play with it later.
     
    Graham., Nov 16, 2013
    #2
    1. Advertisements

  3. Evan Platt

    Evan Platt Guest

    The ATA? Yes. But it worked fine when 'connected' directly to
    flowroute instead of my pbx... But I agree, could be some other issue.
    Well - With some CODEC settings, I get a fast busy signal, and a codec
    error in the logs. With other setting combinations, I get a fast busy
    BUT the call works (I'm calling my cell phone). Even though I hear on
    the phone a fast busy, the call is going through. On other codec
    settings, I hear nothing.
    Grandstream supports STUN:

    Use STUN to detect network connectivity: No
    is selected.

    Only other STUN setting I see is:

    NAT Traversal: No Keep-Alive STUN UPnP
    No is selected. I'll try maybe UPnP?
    I'll look again, didn't see it.
    My Freepbx isn't behind NAT. Public IP.
    Yep.. It's set.
    Thanks for the help :)
     
    Evan Platt, Nov 17, 2013
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.