Free Dialers, dialer config messed up?

Discussion in 'Cisco' started by Jeff, Feb 16, 2004.

  1. Jeff

    Jeff Guest

    I seem to be having issues with a standard router config we send out
    to most of our routers. I'm getting multiple "Di0: No free dialer -
    starting fast idle timer" messages when I debug dialer events. It's a
    simple external modem attached via aux port and it does seem to work
    at some sites. At others the thing just sits there and never dials out
    like it should.

    Could someone tell me what I'm doing wrong?

    Thanks

    s038rtr001#sh ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
    level-2
    ia - IS-IS inter area, * - candidate default, U - per-user
    static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C 192.168.138.0/24 is directly connected, FastEthernet0/0
    S* 0.0.0.0/0 is directly connected, Dialer0




    version 12.3
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    !
    hostname s038rtr001
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 12000 debugging
    enable secret 5 xxxx
    !
    username s038rtr001 password 7 xxxx
    memory-size iomem 20
    clock timezone central -6
    no aaa new-model
    ip subnet-zero
    !
    !
    no ip domain lookup
    ip name-server xxxx
    ip name-server xxxx
    !
    ip cef
    ip audit notify log
    ip audit po max-events 100
    ip ssh break-string
    no ftp-server write-enable
    chat-script dialback ABORT ERROR ABORT BUSY "" "AT" OK "ATDT T"
    TIMEOUT 45 CONNE
    CT J!
    !
    !
    !
    !
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp key xxxx address xxxx
    !
    !
    crypto ipsec transform-set cm-transformset-1 esp-3des esp-sha-hmac
    !
    crypto map cm-cryptomap 1 ipsec-isakmp
    set peer xxxx
    set transform-set cm-transformset-1
    match address 120
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.138.254 255.255.255.0
    ip helper-address 192.168.5.203
    ip helper-address 192.168.254.204
    ip nat inside
    speed auto
    !
    interface Serial0/0
    ip address xxxx 255.255.255.252
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    shutdown
    service-module t1 remote-alarm-enable
    crypto map cm-cryptomap
    ip rtp header-compression
    !
    interface Ethernet1/0
    no ip address
    ip nat outside
    no ip route-cache
    no ip mroute-cache
    shutdown
    half-duplex
    crypto map cm-cryptomap
    !
    interface Async5
    no ip address
    encapsulation ppp
    dialer in-band
    dialer pool-member 20
    no peer default ip address
    ppp authentication chap callin
    !
    interface Dialer0
    ip address negotiated
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer pool 20
    dialer remote-name AUSTSRVRAS001
    dialer string xxxx
    dialer hold-queue 30 timeout 60
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname s038rtr001
    ppp chap password 7 xxxx
    !
    router eigrp 1
    redistribute connected
    passive-interface FastEthernet0/0
    network 192.168.138.0
    network 192.168.251.0
    auto-summary
    no eigrp log-neighbor-changes
    !
    ip nat pool branch xxxx xxxx netmask 255.255.255.252
    ip nat inside source route-map nonat pool branch overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0
    ip route 0.0.0.0 0.0.0.0 Dialer0 150
    no ip http server
    no ip http secure-server
    !
    !
    logging trap debugging
    logging facility local0
    logging source-interface FastEthernet0/0
    logging 192.168.247.2
    access-list 87 permit xxxx 0.0.0.31
    access-list 100 deny eigrp any any
    access-list 100 permit ip any any
    access-list 120 permit ip 192.168.138.0 0.0.0.255 192.168.0.0
    0.0.255.255
    access-list 130 deny ip 192.168.138.0 0.0.0.255 192.168.0.0
    0.0.255.255
    access-list 130 permit ip 192.168.138.0 0.0.0.255 any
    dialer-list 1 protocol ip list 100
    !
    route-map nonat permit 10
    match ip address 130
    !
    snmp-server community xxxx RO 87
    snmp-server enable traps tty
    !
    line con 0
    password 7 xxxx
    login
    line aux 0
    password 7 xxxx
    script dialer Dialback
    login
    modem InOut
    modem autoconfigure type usr_sportster
    transport input all
    transport output pad udptn telnet rlogin ssh
    stopbits 1
    speed 115200
    flowcontrol hardware
    line vty 0 4
    password 7 xxxx
    login
    !
    no scheduler allocate
    ntp server 192.168.247.2 source FastEthernet0/0 prefer
    !
    end
     
    Jeff, Feb 16, 2004
    #1
    1. Advertisements

  2. Jeff

    Jeff Guest

    Anyone?

     
    Jeff, Feb 27, 2004
    #2
    1. Advertisements

  3. At the time when you get this "no free dialer" message,
    is the aux line busy?

    Is the aux only supposed to be used for dialout, never
    dialin? If so, then I'd put "no exec" on the line, and
    also modify my modemcap to set S0=0 (to prevent the
    modem from ever answering an incoming call.)

    Aaron

    ---

    ~ Anyone?
    ~
    ~ (Jeff) wrote in message ~ > I seem to be having issues with a standard router config we send out
    ~ > to most of our routers. I'm getting multiple "Di0: No free dialer -
    ~ > starting fast idle timer" messages when I debug dialer events. It's a
    ~ > simple external modem attached via aux port and it does seem to work
    ~ > at some sites. At others the thing just sits there and never dials out
    ~ > like it should.
    ~ >
    ~ > Could someone tell me what I'm doing wrong?
    ~ >
    ~ > Thanks
    ~ >
    ~ > s038rtr001#sh ip route
    ~ > Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    ~ > D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    ~ > N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    ~ > E1 - OSPF external type 1, E2 - OSPF external type 2
    ~ > i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
    ~ > level-2
    ~ > ia - IS-IS inter area, * - candidate default, U - per-user
    ~ > static route
    ~ > o - ODR, P - periodic downloaded static route
    ~ >
    ~ > Gateway of last resort is 0.0.0.0 to network 0.0.0.0
    ~ >
    ~ > C 192.168.138.0/24 is directly connected, FastEthernet0/0
    ~ > S* 0.0.0.0/0 is directly connected, Dialer0
    ~ >
    ~ >
    ~ >
    ~ >
    ~ > version 12.3
    ~ > service timestamps debug datetime localtime show-timezone
    ~ > service timestamps log datetime localtime show-timezone
    ~ > service password-encryption
    ~ > !
    ~ > hostname s038rtr001
    ~ > !
    ~ > boot-start-marker
    ~ > boot-end-marker
    ~ > !
    ~ > logging buffered 12000 debugging
    ~ > enable secret 5 xxxx
    ~ > !
    ~ > username s038rtr001 password 7 xxxx
    ~ > memory-size iomem 20
    ~ > clock timezone central -6
    ~ > no aaa new-model
    ~ > ip subnet-zero
    ~ > !
    ~ > !
    ~ > no ip domain lookup
    ~ > ip name-server xxxx
    ~ > ip name-server xxxx
    ~ > !
    ~ > ip cef
    ~ > ip audit notify log
    ~ > ip audit po max-events 100
    ~ > ip ssh break-string
    ~ > no ftp-server write-enable
    ~ > chat-script dialback ABORT ERROR ABORT BUSY "" "AT" OK "ATDT T"
    ~ > TIMEOUT 45 CONNE
    ~ > CT J!
    ~ > !
    ~ > !
    ~ > !
    ~ > !
    ~ > crypto isakmp policy 1
    ~ > encr 3des
    ~ > authentication pre-share
    ~ > group 2
    ~ > crypto isakmp key xxxx address xxxx
    ~ > !
    ~ > !
    ~ > crypto ipsec transform-set cm-transformset-1 esp-3des esp-sha-hmac
    ~ > !
    ~ > crypto map cm-cryptomap 1 ipsec-isakmp
    ~ > set peer xxxx
    ~ > set transform-set cm-transformset-1
    ~ > match address 120
    ~ > !
    ~ > !
    ~ > !
    ~ > !
    ~ > interface FastEthernet0/0
    ~ > ip address 192.168.138.254 255.255.255.0
    ~ > ip helper-address 192.168.5.203
    ~ > ip helper-address 192.168.254.204
    ~ > ip nat inside
    ~ > speed auto
    ~ > !
    ~ > interface Serial0/0
    ~ > ip address xxxx 255.255.255.252
    ~ > ip nat outside
    ~ > no ip route-cache
    ~ > no ip mroute-cache
    ~ > no fair-queue
    ~ > shutdown
    ~ > service-module t1 remote-alarm-enable
    ~ > crypto map cm-cryptomap
    ~ > ip rtp header-compression
    ~ > !
    ~ > interface Ethernet1/0
    ~ > no ip address
    ~ > ip nat outside
    ~ > no ip route-cache
    ~ > no ip mroute-cache
    ~ > shutdown
    ~ > half-duplex
    ~ > crypto map cm-cryptomap
    ~ > !
    ~ > interface Async5
    ~ > no ip address
    ~ > encapsulation ppp
    ~ > dialer in-band
    ~ > dialer pool-member 20
    ~ > no peer default ip address
    ~ > ppp authentication chap callin
    ~ > !
    ~ > interface Dialer0
    ~ > ip address negotiated
    ~ > encapsulation ppp
    ~ > no ip route-cache
    ~ > no ip mroute-cache
    ~ > dialer pool 20
    ~ > dialer remote-name AUSTSRVRAS001
    ~ > dialer string xxxx
    ~ > dialer hold-queue 30 timeout 60
    ~ > dialer-group 1
    ~ > ppp authentication chap callin
    ~ > ppp chap hostname s038rtr001
    ~ > ppp chap password 7 xxxx
    ~ > !
    ~ > router eigrp 1
    ~ > redistribute connected
    ~ > passive-interface FastEthernet0/0
    ~ > network 192.168.138.0
    ~ > network 192.168.251.0
    ~ > auto-summary
    ~ > no eigrp log-neighbor-changes
    ~ > !
    ~ > ip nat pool branch xxxx xxxx netmask 255.255.255.252
    ~ > ip nat inside source route-map nonat pool branch overload
    ~ > ip classless
    ~ > ip route 0.0.0.0 0.0.0.0 Serial0/0
    ~ > ip route 0.0.0.0 0.0.0.0 Dialer0 150
    ~ > no ip http server
    ~ > no ip http secure-server
    ~ > !
    ~ > !
    ~ > logging trap debugging
    ~ > logging facility local0
    ~ > logging source-interface FastEthernet0/0
    ~ > logging 192.168.247.2
    ~ > access-list 87 permit xxxx 0.0.0.31
    ~ > access-list 100 deny eigrp any any
    ~ > access-list 100 permit ip any any
    ~ > access-list 120 permit ip 192.168.138.0 0.0.0.255 192.168.0.0
    ~ > 0.0.255.255
    ~ > access-list 130 deny ip 192.168.138.0 0.0.0.255 192.168.0.0
    ~ > 0.0.255.255
    ~ > access-list 130 permit ip 192.168.138.0 0.0.0.255 any
    ~ > dialer-list 1 protocol ip list 100
    ~ > !
    ~ > route-map nonat permit 10
    ~ > match ip address 130
    ~ > !
    ~ > snmp-server community xxxx RO 87
    ~ > snmp-server enable traps tty
    ~ > !
    ~ > line con 0
    ~ > password 7 xxxx
    ~ > login
    ~ > line aux 0
    ~ > password 7 xxxx
    ~ > script dialer Dialback
    ~ > login
    ~ > modem InOut
    ~ > modem autoconfigure type usr_sportster
    ~ > transport input all
    ~ > transport output pad udptn telnet rlogin ssh
    ~ > stopbits 1
    ~ > speed 115200
    ~ > flowcontrol hardware
    ~ > line vty 0 4
    ~ > password 7 xxxx
    ~ > login
    ~ > !
    ~ > no scheduler allocate
    ~ > ntp server 192.168.247.2 source FastEthernet0/0 prefer
    ~ > !
    ~ > end
     
    Aaron Leonard, Mar 1, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.