frame relay speed change

Discussion in 'Cisco' started by Jai Ramachandran, Jan 22, 2004.

  1. To whomever,
    The routers I am in charge of are all connected to a frame relay
    cloud. In the next week we are changing the speed of the frame relay
    cloud from 64 kbps to 128 kbps, and to do this I have to change (by my
    count) 5 lines of the router config. The problem with this is the
    only way I have access to these routers is through the said frame
    relay cloud, so once I change one of the lines I need to change, the
    frame relay connection goes down. At the bottom of this post is the
    router config to the router, any help would be appreciated because as
    of right now I am sending out laptops and console cables to our sales
    guys in the markets with the routers so that they can change the
    config manually.



    AFS3-Cleveland#sh ru
    Building configuration...

    Current configuration:
    !
    ! Last configuration change at 10:46:55 EST Wed Jul 23 2003
    ! NVRAM config last updated at 09:32:49 EST Thu May 8 2003
    !
    version 12.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname AFS3-Cleveland
    !
    logging buffered 40000 debugging
    enable password 7 101F5949041101
    !
    username AFS1-Rochester password 7 072308626B491803041F5B02063F
    !
    !
    !
    !
    clock timezone gmt5 5
    clock summer-time EST recurring
    ip subnet-zero
    no ip domain-lookup
    !
    chat-script dialnum "" "atdt\T" TIMEOUT 60 CONNECT \c
    chat-script rst "" "AT&FS0=1&D3&C1&H1&R2&B1&W" "O
    modemcap entry usrmodem:MSC=&FS0=1&C1&D3&H1&R2&B1
    !
    !
    !
    interface Ethernet0/0
    description Cleveland RTU
    ip address 172.16.3.1 255.255.255.0
    no ip directed-broadcast
    !
    interface Serial0/0
    description Sprint Frame Relay to Rochester,NY
    bandwidth 64
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    no ip route-cache
    no ip mroute-cache
    no fair-queue
    service-module t1 timeslots 1
    frame-relay traffic-shaping
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    !
    interface Serial0/0.1 point-to-point
    bandwidth 64
    backup delay 5 10
    backup interface Dialer1
    ip address 172.16.1.3 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    frame-relay class 64
    frame-relay interface-dlci 301
    !
    interface Async65
    bandwidth 15
    no ip address
    no ip directed-broadcast
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer in-band
    dialer pool-member 2
    async default routing
    no peer default ip address
    no fair-queue
    pulse-time 3
    ppp authentication chap
    !
    interface Dialer1
    bandwidth 15
    ip address 172.22.31.253 255.255.255.0
    no ip directed-broadcast
    encapsulation ppp
    dialer pool 2
    dialer idle-timeout 300
    dialer string 15857561967
    dialer-group 1
    no peer default ip address
    no cdp enable
    ppp authentication chap
    !
    router eigrp 1
    network 172.16.1.0 0.0.0.255
    network 172.16.3.0 0.0.0.255
    network 172.22.31.0 0.0.0.255
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.16.1.1
    ip route 0.0.0.0 0.0.0.0 Dialer1 200
    no ip http server
    !
    !
    map-class frame-relay 64
    no frame-relay adaptive-shaping
    frame-relay cir 32000
    frame-relay be 32000
    dialer-list 1 protocol ip permit
    snmp-server engineID local 00000009020000E01EFFB641
    snmp-server community RO RO
    snmp-server community AFShub RW
    snmp-server community NKC-Denver RW 50
    snmp-server community NKC-Denverro RO 50
    snmp-server packetsize 8192
    snmp-server location Lucent Aurora,CO
    snmp-server contact Lucent Technologies 800-572-8443
    snmp-server enable traps snmp
    snmp-server enable traps config
    snmp-server enable traps frame-relay
    snmp-server enable traps syslog
    snmp-server host 192.234.243.10 NKC-Denverro snmp
    snmp-server host 192.234.243.145 NKC-Denverro snmp
    banner exec ^C
    ** Your consent to the above conditions is acknowledged....
    **^C
    banner motd ^C**
    **
    ** This system is for authorized use only. Individuals using this
    **
    ** computer system without authority, or in excess of their
    **
    ** authority, are subject to having all of their activities on this
    **
    ** system monitored and recorded by system personnel. In the course
    **
    ** of monitoring individuals improperly using this system, or in the
    **
    ** course of system maintenance, the activities of authorized users
    **
    ** may be monitored, Anyone using this system expressly consents to
    **
    ** such monitoring and is advised that if such monitoring reveals
    **
    ** possible evidence of criminal activity, system personnel may
    **
    ** provide evidence of such monitoring to law enforcement officials.
    **
    **
    **!
    line con 0
    session-timeout 30
    exec-timeout 15 0
    password 7 11081F16
    login
    transport input none
    line aux 0
    autoselect ppp
    script dialer dialnum
    modem InOut
    modem autoconfigure type usrmodem
    transport input all
    stopbits 1
    speed 115200
    flowcontrol hardware
    line vty 0 4
    password 7 02070248
    login
    !
    end
     
    Jai Ramachandran, Jan 22, 2004
    #1
    1. Advertisements

  2. Hi,
    first of all,
    thank you for your detailed information about your router-config.
    Nice to have a point to break into without effort.
    Seriously, please do never post passwords, IP-addresses and/or
    Telephonenumbers on the net!

    To your question:
    One solution could be writing a new statup-configuration, putting that
    into the router (copy tftp: startup)
    and make a scheduled reload.

    Second solution could be writing a partial configuration that does
    change the f/r setup, upload it into the flash and then do
    "copy flash:<filename> running"
    This might not work, I've not recently checked if this process will
    abort when the telnet-session is disconnected. It did work some time ago...
    In the latter case it is advisable to have a scheduled reload pending so
    that in the case this process is not working a reload will restore the
    old config.


    Good luck

    Mathias
    --
    CCIE #11220
    Everything written is MY opinion only, not the one of my company or
    employer unless otherwise noted

    The early bird gets the worm, but the second mouse gets the cheese

    My signature is certified by Fraunhofer Society.
    The root-ca IS trusted but the browser-manufacturers want big $ to have
    it included
     
    Mathias Gaertner, Jan 22, 2004
    #2
    1. Advertisements

  3. Hi.

    What exactly are the changes you are planning to make?

    Can you not telnet to the router via the dialer interface?

    Another thing to try is to do a 'reload in 10' before you do any
    config changes. Then if you are thrown out of the router by a config
    line it will reload in 10 minutes back to the old config. Don't forget
    to do a 'reload cancel' if all goes well though.

    Simon
     
    Simon Tibbitts, Jan 22, 2004
    #3
  4. Jai Ramachandran

    News Account Guest

    News Account, Jan 23, 2004
    #4
  5. Jai Ramachandran

    AnyBody43 Guest

    OP said:
    The problem with this is the
    only way I have access to these routers is through the said frame
    relay cloud, so once I change one of the lines I need to change, the
    frame relay connection goes down.

    (Simon Tibbitts) wrote
    Someone posted various solutions to this problem recently and
    I used one of these myself recently.


    Consider using the "reload in XX" command to automatically
    recover from a change that does not work.

    tftp the new config on to the router.

    copy tftp run

    e.g.
    int e0
    ip address x.x.x.x y.y.y.z
    ip route a.a.a.a b.b.b.b c.c.c.c
    end

    If you don't put in the "end" you get an error message but it
    still works.

    The file is completely uploaded before any changes are applied.

    BTW in my case there was a _very_ worrying pause during the
    process. On an 800 series it seemed to take a minute or so
    (more?) to apply the changes. Phew!

    If you are still in touch then cancel the reload.
    I have never done this, test it first.

    Alternatively I would suppose that you could "copy tftp start"
    and then verify that the config was what you wanted and
    then reload. There is of course no recovery from this if it
    doesn't work.

    The key point is:
    Copy tftp "run or start" works in exactly the same way as
    "conf t" in that the new config is "merged" with the
    existing config.
     
    AnyBody43, Jan 27, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.