Frame relay configuration

Discussion in 'Cisco' started by squid3570, Sep 10, 2006.

  1. squid3570

    squid3570 Guest

    Hi,
    I am doing a test.I have 3 routers cisco 805,2500 and 1600.

    The cisco 2500 will do a frame relay switching and has the following
    setup:
    interface Serial0
    no ip address
    encapsulation frame-relay
    no ip route-cache
    bandwidth 64
    no keepalive
    frame-relay intf-type dce
    frame-relay route 16 interface Serial1 16
    !
    interface Serial0.1 point-to-point
    no ip address
    !
    interface Serial1
    no ip address
    encapsulation frame-relay
    no ip route-cache
    bandwidth 64
    no keepalive
    frame-relay intf-type dce
    frame-relay route 16 interface Serial0 16
    !
    interface Serial1.1 point-to-point
    no ip address



    The cisco 805 has the following serial configuration:

    interface Serial0
    bandwidth 64
    no ip address
    encapsulation frame-relay IETF
    no ip mroute-cache
    no keepalive
    !
    interface Serial0.1 point-to-point
    ip address 172.21.3.2 255.255.255.252
    frame-relay interface-dlci 16

    THe cisco 1600 has :

    interface Serial0
    bandwidth 64
    no ip address
    encapsulation frame-relay IETF
    no ip mroute-cache
    no keepalive
    !
    interface Serial0.1 point-to-point
    ip address 172.21.3.1 255.255.255.252
    frame-relay interface-dlci 16


    My problem is that i can not ping from the cisco 805 to the cisco 1600
    sh frame relay pvc:

    DLCI = 16, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
    Serial0

    input pkts 0 output pkts 0 in bytes 0
    out bytes 0 dropped pkts 0 in FECN pkts 0
    in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
    in DE pkts 0 out DE pkts 0
    pvc create time 0:28:00 last time pvc status changed 0:27:29
    Num Pkts Switched 0
    Pls can anybody help me ???

    Thanks
     
    squid3570, Sep 10, 2006
    #1
    1. Advertisements

  2. squid3570

    vreyesii Guest

    Hi squid3570,

    If you issue a sh frame-relay map on the 805 and thr 1600 router. What
    do you get?
     
    vreyesii, Sep 10, 2006
    #2
    1. Advertisements

  3. squid3570

    squid3570 Guest

    1600#
    1600#sh frame-relay map
    Serial0.2 (up): point-to-point dlci, dlci 17(0x11,0x410), broadcast
    Serial0.1 (up): point-to-point dlci, dlci 16(0x10,0x400), broadcast

    805#sh frame-relay map
    Serial0.2 (up): point-to-point dlci, dlci 17(0x11,0x410), broadcast
    Serial0.1 (up): point-to-point dlci, dlci 16(0x10,0x400), broadcast
    805#
     
    squid3570, Sep 10, 2006
    #3
  4. squid3570

    vreyesii Guest

    Alright, here is what I suggest. I the dlci's you can change if you
    want. I test this config on my lab and it should work perfect. I had
    the 850 connected to the S0 on the Frame Relay Switch and the 1600
    connected to S1 on the Frame Relay Switch.

    The frame relay switch should a config like this:

    interface Serial0
    no ip address
    encapsulation frame-relay
    clockrate 56000
    frame-relay intf-type dce
    frame-relay route 201 interface Serial1 102
    !
    interface Serial1
    no ip address
    encapsulation frame-relay
    clockrate 56000
    frame-relay intf-type dce
    frame-relay route 102 interface Serial0 201

    The 850 Router:

    interface Serial0
    no ip address
    encapsulation frame-relay
    !
    interface Serial0.1 point-to-point
    ip address 172.21.3.2 255.255.255.252
    frame-relay interface-dlci 201


    The 1600 Router:

    interface Serial1
    no ip address
    encapsulation frame-relay
    !
    interface Serial1.1 point-to-point
    ip address 172.21.3.1 255.255.255.252
    frame-relay interface-dlci 102
     
    vreyesii, Sep 10, 2006
    #4
  5. squid3570

    vreyesii Guest

    Another thing is that you do not need to enter "ietf" after the
    interface-dlci command unless you are connecting to non-Cisco
    equipment. By default, the router will use a Cisco proprietary
    encapsulation format for the data payload of each packet.

    vreyesii
     
    vreyesii, Sep 10, 2006
    #5
  6. squid3570

    squid3570 Guest

    Still not working!

    Here are the sh output on the switch:

    switch#sh frame-relay route
    Input Intf Input Dlci Output Intf Output Dlci Status
    Serial0 201 Serial1 102 static
    Serial1 102 Serial0 201 static


    PVC Statistics for interface Serial0 (Frame Relay DCE)

    DLCI = 201, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
    Serial0

    input pkts 0 output pkts 0 in bytes 0
    out bytes 0 dropped pkts 0 in FECN pkts 0
    in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
    in DE pkts 0 out DE pkts 0
    pvc create time 0:07:45 last time pvc status changed 0:07:35
    Num Pkts Switched 0

    PVC Statistics for interface Serial1 (Frame Relay DCE)

    DLCI = 102, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
    Serial1

    input pkts 0 output pkts 0 in bytes 0
    out bytes 0 dropped pkts 0 in FECN pkts 0
    in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
    in DE pkts 0 out DE pkts 0
    pvc create time 0:07:52 last time pvc status changed 0:07:42
    Num Pkts Switched 0
    switch#
     
    squid3570, Sep 10, 2006
    #6
  7. squid3570

    vreyesii Guest

    Post the config of the Frame Relay switch.
     
    vreyesii, Sep 10, 2006
    #7
  8. squid3570

    squid3570 Guest

    switch#sh run
    Building configuration...

    Current configuration:
    !
    version 10.3
    service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname switch
    !
    enable secret 5 $1$25G3$Gw1tKIcrtSyDvgUfgymbJ/

    !
    no ip routing
    frame-relay switching

    auto-polarity
    !
    interface Ethernet0
    no ip address
    no ip route-cache

    !
    interface Serial0
    no ip address
    encapsulation frame-relay
    no ip route-cache
    bandwidth 64
    no keepalive
    frame-relay intf-type dce
    frame-relay route 201 interface Serial1 102
    !
    interface Serial1
    no ip address
    encapsulation frame-relay
    no ip route-cache
    bandwidth 64
    no keepalive
    frame-relay intf-type dce
    frame-relay route 102 interface Serial0 201
    !
    --More--
    ip classless
     
    squid3570, Sep 10, 2006
    #8
  9. squid3570

    vreyesii Guest

    The frame relay switch config looks good. Can you post the configs for
    the other two routers?

    vreyesii
     
    vreyesii, Sep 10, 2006
    #9
  10. squid3570

    vreyesii Guest

    The only thing that I see that you are missing is that you forgot the
    set clock rate on the two serial intefaces. As I posted earlier. That
    can cause issues such as this. Set the clock rate to 56000.

    vreyesii
     
    vreyesii, Sep 10, 2006
    #10
  11. squid3570

    vreyesii Guest

    Also do a "no keepalive" on each serial interfaces on the frame-relay
    switch.

    vreyesii
     
    vreyesii, Sep 10, 2006
    #11
  12. squid3570

    vreyesii Guest

    Also do a "keepalive" on each serial interfaces on the frame-relay
    switch.
     
    vreyesii, Sep 10, 2006
    #12
  13. squid3570

    squid3570 Guest

    When I do a "keepalive",the interfaces go down!!!!
     
    squid3570, Sep 10, 2006
    #13
  14. squid3570

    squid3570 Guest

    I want to change the switch! and see


     
    squid3570, Sep 10, 2006
    #14
  15. squid3570

    vreyesii Guest

    The interface should not go down. Are the physical cables connected
    properply such as which side is connected to the frame relay switch
    DCE side of the cable or the DTE side of the cable. Also, when you do
    keepalive on the Frame Relay Switch side you have to do the same for
    the Routers, so they can match on both sides. Post the config for
    Routers.

    vreyesii
     
    vreyesii, Sep 10, 2006
    #15
  16. squid3570

    squid3570 Guest

    ok
    I did a mistake ....it is now ok !!!

    Thanks a lot
     
    squid3570, Sep 11, 2006
    #16
  17. squid3570

    squid3570 Guest

    But when I ping from any of the routers,it give me 32ms for the remote
    router and 64ms on the local interface.It looks strange!
     
    squid3570, Sep 11, 2006
    #17
  18. squid3570

    vreyesii Guest

    Hello,

    Can you issue a sh interface and show frame-relay pvc and post the
    results.

    vreyesii
     
    vreyesii, Sep 11, 2006
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.