forward multicast between 2 interfaces on a cisco router

Discussion in 'Cisco' started by programmer.phillip, Apr 20, 2013.

  1. Hi,
    I want to forward multicast packets:

    Src 192.168.2.12 multicast dst 225.2.1.14
    And
    Src 192.168.2.22 multicast dst 225.2.1.24

    They are going to an address 10.100.1.8

    So basically I want to forward from eth0 to eth1
    I have played with pim and access lists but nothing seems to work.
    Unicast and icmp all work fine just not multicast.

    Any ideas?

    Thanks in advance.

    Router#
    Router#
    Router#write term
    Building configuration...
    Current configuration : 557 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 redacted
    enable password redacted
    !
    ip subnet-zero
    !
    !
    !
    ip multicast-routing
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.2.254 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 10.100.1.254 255.255.255.0
    duplex auto
    speed auto
    !
    ip classless
    no ip http server
    ip pim bidir-enable
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password redacted
    login
    !
    !
    end
    Router#
     
    programmer.phillip, Apr 20, 2013
    #1
    1. Advertisements

  2. Does 10.100.1.8 know the multicast is coming, i.e. does it
    send IGMP joins for 225.2.1.14 and 225.2.1.24?

    You do need to at least enable multicast on the interfaces
    That might just work.

    "show ip mroute" and "show ip mroute count" would be helpful.

    Or slightly more sophisticated:
    interface loopback0
    ip address 1.1.1.1 255.255.255.255
    ip pim sparse-dense-mode
    REF:
    ====
    Multicast Quick-Start Configuration Guide
    www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a0080094821.shtml
     
    Martin Gallagher, Apr 21, 2013
    #2
    1. Advertisements

  3. it does work if they are configured for the same subnet I do see the join going to 224.0.0.22 for the 225 groups.
     
    Phillip Programmer, Apr 22, 2013
    #3
  4. So that's IGMPv3, in which case you also need to add "ip igmp version 3" to
    F0/0 and F0/1.
     
    Martin Gallagher, Apr 22, 2013
    #4
  5. Hi,
    Figured it out.

    All that was needed was the igmp on the interfaces and ip multicast routing
    The traffic I was trying to route had a ttl of 1 so once the traffic was fixed it worked
     
    Phillip Programmer, Apr 23, 2013
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.