Firefox doesn't load Amazon websites properly

Discussion in 'Firefox' started by Zygon Curry, Jul 31, 2006.

  1. Zygon Curry

    Zygon Curry Guest


    I'm having a really werid problem.

    Whenever I visit any Amazon website, Firefox doesn't load the Amazon
    page properly. It loads half then stops with reported 'Done' in the
    corner to say the website is finished.

    If I then press Reload, the website loads properly and everything is

    It's affecting,, ca, etc and to my knowledge it's no
    affecting other non Amazon sites.

    I've even uninstalled Firefox, and deleted related files that I could
    find in the profiles and the Windows registery.

    Even after I reinstalled the latest version of Firefox, the problem is
    still happening.

    Any ideas?


    Zygon Curry, Jul 31, 2006
    1. Advertisements

  2. ANY ? Amazon page?
    How 'bout this one
    Mozilla Champion (Dan), Jul 31, 2006
    1. Advertisements

  3. Zygon Curry

    Zygon Curry Guest

    Thanks for the reply.

    Yes, even that one. It loads partially, but not all. The links along
    the left side load up, and the top of the page above 'Hello. Sign in
    to get personalized recommendations' gets loaded and displayed.
    Everything else doesn't get displayed until I press Reload, and then
    it loads everything normally.

    The occassional page from within an Amazon search sometimes loads ok
    and withough problem.

    It's weird, and it only appears to affect Amazon websites from what I
    can tell, although it may affect others but I've not really noticed.

    I have Firefox installed on two other computers and they both load
    Amazon sites fine. The other browsers on this computer, IE, Opera, and
    Mozilla Suite all load up Amazon ok without problems. It's only
    Firefox on this computer that appears to have a problem and I don't
    know why.

    Any ideas?


    Zygon Curry, Jul 31, 2006
  4. Zygon Curry

    gwtc Guest

    check the following settings: Tools, Options, Content, and make sure
    that Load Images is checked and "for the originating web site only" is
    unchecked. And, make sure that javascript is checked. Does it work
    now? If it doesn't, when reload the page by pressing F5
    gwtc, Jul 31, 2006
  5. Zygon Curry

    Zygon Curry Guest

    Checked the options and all are as they should be:

    Load Images was checked

    'For the originating web site only' was unchecked

    Javascript was checked

    The page did not load successfully at first with the same problem

    Pressing F5 reloaded the page successfully.
    Zygon Curry, Jul 31, 2006
  6. Zygon Curry

    gwtc Guest

    then empty your cache: Tools, Options Privacy, Cache
    gwtc, Aug 1, 2006
  7. Zygon Curry

    Zygon Curry Guest

    I did that as well. No difference in loading.

    Might be worth mentioning again that I have already totally removed
    and reinstalled Firefox as well to try and get the problem resolved,
    without any luck.
    Zygon Curry, Aug 1, 2006
  8. Zygon Curry

    Troy Piggins Guest

    Are you using a caching proxy server, or direct connection to internet?
    What plugins/extensions are your using?
    Troy Piggins, Aug 1, 2006
  9. Zygon Curry

    gwtc Guest

    stop wasting your time uninstalling and reinstalling. All your
    settings, prefs, bookmarks, passwords, etc, are stored in an area
    called the FF profile. When you uninstall all you're doing is
    removing the program, the profile is not touched, and your problem is
    within your profile.

    OK, close FF and start it in Safe Mode. Click on Start, Run and enter:

    firefox.exe -safe-mode

    When you start in safe mode, all your extensions and themes are
    disabled. Does this work now?
    gwtc, Aug 1, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.