Firefox "Auto Detect" for Character Encoding: how to turn it on?

Discussion in 'Computer Support' started by *alan*, Mar 6, 2007.

  1. *alan*

    *alan* Guest

    The "Auto Detect" feature for character encoding (found under the "View"
    options) indicates that it is "off". It would seem a good idea for this
    feature to be "on", but there does not appear to be a way to do this.
    Firefox "Help" is not helpful.

    I just noticed this when I was trying to view this Wikipedia page:
    http://en.wikipedia.org/wiki/Bopomofo. None of the Chinese characters were
    presented properly, having been turned into question marks. I tried
    manually selecting all the available versions of Chinese encoding, UTF8 and
    UTF7 and nothing worked.

    I should note that I have absolutely no trouble getting accurately
    represented Arabic web-pages such as http://www.aljazeera.net/portal, but I
    notice that the "Auto-detect" feature for this is also "off" when viewing
    this (and other) Arabic pages.

    Does Firefox actually have an "Auto-Detect" feature? Does it work? If so,
    how can it be turned "on"?

    Thanks for your help.
     
    *alan*, Mar 6, 2007
    #1
    1. Advertisements

  2. *alan*

    McFly Guest

    Alan,

    Since you found where the character encoding settings are located,
    have you tried to set it to Universal?

    -fly-
     
    McFly, Mar 6, 2007
    #2
    1. Advertisements

  3. *alan*

    *alan* Guest

    Yes. In addition to having tried "Universal" (which didn't work --- still
    the same question marks in place of the Chinese characters), I also tried
    Japanese and Korean for good measure, and even UTF16 (which I'd never heard
    of --- it turned even the English into question marks, lol).
     
    *alan*, Mar 6, 2007
    #3
  4. *alan*

    why? Guest

    Looks okay in FF 2.0.0.1 / SeaMonkey 1.1

    The page encoding is set at the top
    html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en"
    meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    With the few <span lang="zh-Hant" xml:lang="zh-Hant">????</span>;
    otherwise view source in FF shows the graphical character with no
    html/xml source showing.
    FF is Auto Off, UTF-8, however when I look in the View / Encoding I see
    West / East Europe 3 lots of Asian selections. Do your More Encodings
    expand out showing all the options?

    I think at one point I was looking at Indian pages for someone and added
    lots of different languages to Control Panel / Regional Settings.

    Was hoping a raw fetch of the page would show the background coding
    before it hits a browser but no such luck, it looks like

    (zié, now pronounced <i>jié</i>)

    So no clues there.
    Maybe try Newsgroups / Forums at http://www.mozilla.org/support/
    Me
     
    why?, Mar 6, 2007
    #4
  5. *alan*

    *alan* Guest


    And that may very well be the source of my problem. Going to Control Panel,
    Regional and Language settings, I tried to add languages, was prompted to
    "insert disk labelled XP Professional Service Pack2" ---- well, I don't
    have the disk, so I guess I'm out of luck . . . oh well.
     
    *alan*, Mar 7, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.