Firefox and Adobe Reader in Web Pages

Discussion in 'Firefox' started by Marek Williams, Sep 25, 2005.

  1. Firefox 1.07, Adobe Reader 6.0

    When I click on a link that takes me to a web page that is a PDF, it
    opens a new tab, but the PDF file is not displayed. I discovered (by
    accident) a sort-of fix -- if I have Adobe Reader running when I
    launch Firefox it works. But that is kind of a pain.

    Does anyone know how to get PDF files to open in a new tab in Firefox
    the way they do in Opera or Internet Explorer (gag)?
     
    Marek Williams, Sep 25, 2005
    #1
    1. Advertisements

  2. Marek Williams

    Moz Champion Guest

    I use a seperate PDF plug in to get them to display in the browser
     
    Moz Champion, Sep 25, 2005
    #2
    1. Advertisements

  3. [email protected], Sep 25, 2005
    #3
  4. Thanks for the information. But it still doesn't work.

    I installed PDF Download, closed Firefox, restarted it, went to a web
    page I know had PDFs on it, clicked on a link (selecting "Open in a
    new tab"). It opened a new tab, the tab said "done," and nothing was
    displayed. Same as before.

    Any other suggestions?
     
    Marek Williams, Sep 26, 2005
    #4
  5. As a test, go to:

    Tools>>Options>>Downloads

    Click the Plugins button under File Types. Disable the PDF plugin.

    Navigate to a PDF on the web and click on it. You should get a dialog
    to either open it or save it. Choose open with the system default.

    If the PDF opens the file outside of FF, the problem is with FF. If it
    doesn't, the problem is with the Reader.

    Lee
     
    Leonidas Jones, Sep 26, 2005
    #5
  6. OK, I did that. I have several sites bookmarked that are really PDFs.
    I went to one and Firefox asked me if I wanted to open it or save it
    to disk. The "open" option was selected by default, and the dialog box
    had AcroExch selected. I clicked on OK and it opened it in Reader
    outside of Firefox. From previous experience, if I chose save to disk
    it would just save it to the default location on my hard disk.

    I tried this with several sites that I know are PDFs. Same results
    each time.

    So this must mean the problem is with Firefox. How do I fix it?
     
    Marek Williams, Sep 27, 2005
    #6
  7. Okay, enable the plugin again, and see what about:plugins has to say
    about Adobe.

    Lee
     
    Leonidas Jones, Sep 27, 2005
    #7
  8. Ummm, big problem. The PDF plugin is no longer listed. I guess when I
    disabled it, it went away. I click on "Plugins" and it lists a lot of
    file types, but PDF is no longer there. I poked all over the place,
    but I can't find any way to add it back.
     
    Marek Williams, Sep 30, 2005
    #8
  9. Hm, that's odd. I disabled the PDF plugin quite a while ago, since I
    prefer PDF's to display outside the browser. I just checked:

    Tools>>Options>>Downloads

    and clicked the plugins button. PDF sits there, waiting to be reenabled.

    Did you click the Plugins button?

    Lee
     
    Leonidas Jones, Sep 30, 2005
    #9
  10. Yep. Tried all kinds of buttons. It's not there and I can't find any
    way to add it to the list.

    When I click on Plugins I get a list containing:

    DIR
    FDF
    ODB
    ODF
    ODG
    ODM
    ODP
    ODS
    ODT
    OTH
    RPM
    SDA
    SDC
    SDD
    SDP
    SDS
    SDL
    SMF
    SPL
    SWF
    SXC
    SXD
    SXG
    SXI
    SXM
    SXW
    VOR
    XDP Adobe Acrobat XML Data Package
    XFD Adobe Forms Client Data File
    XFDF Adobe Acrobat Forms Document

    All of the above are shown as enabled (blue checkmark to the right).

    Most of the above list deal with StarOffice and a few for other
    programs. I didn't type in the descriptions of these in the above
    list. I typed in the description of the last three because they have
    something to do with Acrobat Reader. "PDF" is simply not on the list.
    "PDF" *was* on the list before I disabled it.

    In the previous window (the one with the Plugins button on it) there
    is a window with a scroll bar showing actions to be performed on
    different file types. There are two listed: RPM (download always) and
    DOC (Open with soffice.exe). The window with the scroll bar is not
    editable. That is, there is a button for Change Action and a button
    for Remove, but no button for Add. Evidently those two got put in
    there some other way, but I don't recall how. I do recall once having
    a problem downloading an RPM file (a program package for my Linux
    computer) and I did something to stop Firefox from trying to launch
    it. And I probably am the reason the DOC file type is in there --
    because I do have Word 2000 still installed on this computer, but no
    way would I ever want it to open a file from the internet. In fact, I
    haven't launched Word in over a year. Again, I don't recall how I got
    that DOC entry in there. There must be a dialog box somewhere else,
    but I'll be darned if I can find it now.
     
    Marek Williams, Sep 30, 2005
    #10
  11. Okay. Type about:plugins into your location bar. Is there an entry for
    Adobe Acrobat, or the Reader?

    For that matter, do you have the full Acrobat, or the Reader?

    AN easy fix might be just to reinstall Acrobat.

    By the way, your sig delimiter is broken. I've been stripping your sig
    manually, but I left it this time so you could see it. It should be
    dash dash space. Yours is missing the space, so my newsreader does not
    strip it automatically.

    Lee
     
    Leonidas Jones, Sep 30, 2005
    #11
  12. Yes, it shows the following:

    application/pdf Acrobat Portable Document Format pdf Yes
    application/vnd.fdf Acrobat Forms Data Format fdf Yes
    application/vnd.adobe.xfdf XML Version of Acrobat Forms Data Format
    xfdf Yes
    application/vnd.adobe.xdp+xml Acrobat XML Data Package xdp Yes
    application/vnd.adobe.xfd+xml Adobe FormFlow99 Data File xfd Yes
    Reader only.
    But from your original suggestion we determined that the problem was
    in Firefox, not in Reader.
    See if it works now.
     
    Marek Williams, Oct 4, 2005
    #12
  13. Reinstalling the reader would reinstall the browser plugin and might
    solve the issue.

    Delimiter working fine now, thanks!

    Lee
     
    Leonidas Jones, Oct 4, 2005
    #13
  14. I hate installing new software, especially software from Adobe and
    Microsoft, because they usually hijack preferences and take me a long
    time to get rid of all the crap they install with the application.

    But I decided to go ahead and install Reader 7.0. I have my firewall
    set to disallow any application access to the net except those I have
    specifically allowed. Sure enough, Reader 7.0 wouldn't install unless
    Internet Explorer was allowed access (it is blocked). But I finally
    managed to download the full program instead of just a little file
    that launches IE and sends it off to somewhere on Adobe.com. Even then
    it automatically started the setup utility as soon as the download was
    complete, instead of waiting for me to double-click on the .exe file.
    And it uninstalled Reader 6.0 without asking permission. Every time
    something like this happens it reminds me of why I am trying to
    migrate to Linux.

    The good news is that PDF files on websites now open in Firefox as
    they should.

    Now I need to figure out how to get it to stop loading the Reader 7.0
    toolbar in the Firefox tab that has the PDF file displayed. It is
    especially annoying to see the Yahoo button there. (Wondering how much
    Yahoo paid Adobe to get their button on the toolbar, and set so the
    user can't delete it.) I got rid of all the toolbars in standalone
    Reader 7.0, but those preferences don't seem to extend to a tab in
    Firefox.
     
    Marek Williams, Oct 9, 2005
    #14
  15. If you're going to use the Reader to view PDF files, I don't think there
    is any choice about having the toolbar display.

    I don;t know, I disabled having the pdf display in the browser window,
    and started using Foxit as a pdf reader.

    Lee
     
    Leonidas Jones, Oct 10, 2005
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.