Firefox 4 & Windows 7

Discussion in 'Firefox' started by Porter Smith, Apr 7, 2011.

  1. Porter Smith

    Porter Smith Guest

    I just got s new PC with Windows 7 (64bit). I installed FF 3.6 and copied
    over the profiel from my old Windows XP PC. It ran fine for a few days
    then I upgraded to FF 4.

    FF will run fine ofr a while and then suddenly when I click on a link the
    tab flashes "Connecting" and it just sits there forever. If I close FF and
    then try to reatart it say FF is already running. Eventually I have to go
    into TaskManager and kill the process.

    FF then starts normally and runs fine for a while anywhere from 2 to 20
    minutes and then I'll click on a link and it goes into COnnecting again.

    My other PC runs fine with FF 3.6 and WIndows XP.

    Has anyone seen this? Any ideas how to fix it?
     
    Porter Smith, Apr 7, 2011
    #1
    1. Advertisements

  2. Porter Smith

    Justin Guest

    Porter Smith wrote on [06 Apr 2011 23:44:28 GMT]:
    FF4 seems to kind of suck. It crashes a LOT
     
    Justin, Apr 7, 2011
    #2
    1. Advertisements

  3. Porter Smith

    Ralph Fox Guest


    Curious. I am running Firefox 4 on Win7 64-bit.
    Firefox 4 works OK for me.
    And I have not seen any FF4 crashes at all.

    Q. If you close Firefox completely, wait a minute, and the start FF up
    again, does Firefox go back to working OK?


    It sounds like it might possibly be a problem with the Internet
    connection, maybe your router (if you have one), or maybe your ISP.
    I do remember seeing suggestions on what to check, but I don't have
    a router myself.


    Q. If it happens again connecting to (say) http://www.website.example/
    then open a command prompt window and type the command
    tracert.exe www.website.example
    (using the correct site name).
    What happens?
     
    Ralph Fox, Apr 7, 2011
    #3
  4. Porter Smith

    Ken Guest

    No.
     
    Ken, Apr 7, 2011
    #4
  5. Porter Smith

    Justin Guest

    Ken wrote on [Thu, 07 Apr 2011 14:54:44 +0200]:
    I find it has crashed every time I come back to the PC in the morning.
    That's a lot
     
    Justin, Apr 7, 2011
    #5
  6. Porter Smith

    Porter Smith Guest

    Don't think it's the router or internet connection, Another PC running
    FF 3.6/Windows XP on the same router works fine. And when FF is hung,
    PING, TRACERT, and other apps that us the Internet (Thunderbird) work
    fine.

    I think it was the Online Armor firewall. Once I disabled it things
    worked OK. Then I enabled it, FF loaded one page and hung as soon as I
    clicked on a link.

    So I punted OA and am trying Comodo firewall. Been running for a few
    hours and everything is OK.

    And aside from this FF4 has performed flawlessly.
     
    Porter Smith, Apr 7, 2011
    #6
  7. Porter Smith

    Ralph Fox Guest

    It is good to hear that the problem is resolved.
     
    Ralph Fox, Apr 8, 2011
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.