File/resource sharing problem over existing wireless network

Discussion in 'Wireless Networking' started by Guest, Dec 6, 2004.

  1. Guest

    Guest Guest

    My existing wireless network was working fine until the laptop hard disk
    crashed last week and I'm in the process of rebuilding it. The nework was set
    up as follows:

    - Laptop running XP Pro, McAfee firewall (trusted IP addresses set).
    Connects directly to internet via broadband
    - Desktop running XP Home, McAfee firewall (trusted IP addresses set).
    Printers directly connected to this machine. Connects to internet through
    laptop via wireless network
    - Linksys Access Control Point

    Both machines can ping each other. Both machines have the same folders set
    for sharing.

    Laptop can access shared folders on desktop and print through the desktop.

    Desktop can 'see' laptop via 'view workgroup computers'. However, when try
    to connect to laptop from this screen, via start-run-"cmd" or drive mapping
    get error:

    "\\Clive-laptop is not accessible. You might not have permission to use this
    network resource. Contact the administrator of this server to find out if you
    haqve access permissions. Logon failure: the user has not been granted the
    requested logon type at this computer."

    Having read through postings to this forum, the Guest account has now been
    enabled on both computers (though it wasn't originally). This still hasn't
    worked. The restrictanonymous and restrictanonymoussam registry keys are
    unchanged at 1. The server service is running on both machines.

    The problem must be with the laptop as everything worked before the hard
    disk crash... Any suggestions?

    Many thanks.
     
    Guest, Dec 6, 2004
    #1
    1. Advertisements

  2. Guest

    Chuck Guest

    Clive,

    On the laptop, check to see if Simple File Sharing (Control Panel - Folder
    Options - View - Advanced settings) is enabled or disabled. With your LAN, you
    need to have SFS enabled.

    Did you enable Guest using Start - Run - "cmd", then type "net user guest
    /active:yes" in the command window?

    On the laptop, check your Local Security Policy (Control Panel - Administrative
    Tools) - User Rights Assignment, and look at "Deny access to this computer from
    the network". Make sure Guest is not in the list.
     
    Chuck, Dec 9, 2004
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    Chuck

    On the laptop:

    1) Simple File Sharing was already enabled
    2) Guest was already enabled
    3) Guest was not on the "Deny access..." list

    So it was not these. By the way, when I type in "Net view clive-laptop" to
    the cmd window on the desktop, I get the error "System error 5 has occurred.
    Access is denied."

    Regards,

    Clive.
     
    Guest, Dec 11, 2004
    #3
  4. On the laptop, click Start, click Run, type:
    Regedit (hit enter)

    Next, locate HKLM\System\CurrentControlSet\Control\Lsa

    Ensure that "RestrictAnonymous" is set to 0.

    Close and reboot.
    That should solve it.

    Carey
     
    Carey Holzman, Dec 11, 2004
    #4
  5. Guest

    Guest Guest

    Carey

    Thanks for the suggestion. I've set "RestrictAnonymous" to 0 on both
    machines and rebooted. I still have the problem.

    Regards,

    Clive.
     
    Guest, Dec 11, 2004
    #5
  6. In the network properties of each machine, do you have Client for MS
    Networks and File and Printer Sharing installed (Also, on the xp pc, do they
    have checks next to them?)

    Carey
     
    Carey Holzman, Dec 11, 2004
    #6
  7. Guest

    Guest Guest

    Carey

    Thanks for the suggestion. I've looked at both machines and Client for MS
    Networks and File and Printer Sharing were installed and they had checks next
    to them. So, I still have the problem.

    Regards,

    Clive.
     
    Guest, Dec 12, 2004
    #7
  8. Please send me the IPCONFIG info from each PC

    Click Start, click Run, type: cmd (and hit enter)

    Type: ipconfig /all >c:\ipconfig.txt (and hit enter)

    Use Notepad to open c:\ipconfig.txt and copy and paste entire contents into
    your next post.

    Thanks,
    Carey
     
    Carey Holzman, Dec 12, 2004
    #8
  9. Guest

    Guest Guest

    Carey

    ipconfig /all for the laptop as follows:


    Windows IP Configuration
    Host Name . . . . . . . . . . . . : CLIVE-LAPTOP
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : Yes
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Network Bridge (Network Bridge) 6:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : MAC Bridge Miniport
    Physical Address. . . . . . . . . : 02-04-23-4C-58-FF
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.1.100
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

    PPP adapter BT Broadband:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
    Physical Address. . . . . . . . . : 00-53-45-00-00-00
    Dhcp Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 81.157.0.215
    Subnet Mask . . . . . . . . . . . : 255.255.255.255
    Default Gateway . . . . . . . . . : 81.157.0.215
    DNS Servers . . . . . . . . . . . : 194.74.65.69
    194.72.9.38



    ipconfig /all for the desktop as follows:


    Windows IP Configuration
    Host Name . . . . . . . . . . . . : TAYLOR
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection 3:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Instant Wireless USB Network
    Adapter ver.2.6
    Physical Address. . . . . . . . . : 00-06-25-0E-58-8A
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.1.101
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    Lease Obtained. . . . . . . . . . : 13 December 2004 07:35:25
    Lease Expires . . . . . . . . . . : 13 December 2004 07:40:25


    Regards

    Clive.
     
    Guest, Dec 13, 2004
    #9
  10. You're not running a router? You're using two NICs and ICS?
     
    Carey Holzman, Dec 13, 2004
    #10
  11. "The restrictanonymous and restrictanonymoussam registry keys are unchanged
    at 1."

    I just re-read this...

    You need to set RestrictAnonymous on both PCs to 0.

    Leave restrictanonymoussam alone, though.

    Carey
     
    Carey Holzman, Dec 13, 2004
    #11
  12. Sorry, ignore that last message about restrictanonymous.. I read further
    down the thread and saw we went there already.

    I am curious how you have these machines configured. You have a wireless USB
    NIC on the desktop, and you have the cable modem plugged directly into the
    laptop and are using another NIC on the laptop to share that connection.

    Does the laptop have built-in wireless and you are in Ad-Hoc mode with the
    wireless NICs?

    That's just bad jo-jo with regards to wireless security.

    Although the Node Type shouldn't matter, I'd feel better seeing your Node
    Type set to Unknown. To do this, on each PC, run the registry editor, open
    this key:

    HLM\System\CurrentControlSet\Services\Netbt\Parameters

    and delete these values if they're present:

    NodeType
    DhcpNodeType

    Reboot, then try IPCONFIG /ALL again to see if the Node Type has changed to
    UNKNOWN on both PCs. If so, try to access the network again.

    Carey
     
    Carey Holzman, Dec 13, 2004
    #12
  13. Guest

    Guest Guest

    Carey

    The original configuration was laptop with built-in wireless, desktop with
    Linksys wireless USB adapter and Linksys wireless broadband router (acting as
    an access control point only). The wireless network was set up with a unique
    SSID (not "Linksys"!) and WEP key, so my understanding was that security was
    okay. Initially, I ran this for file and printer sharing only until I was
    due to get broadband.

    However, when broadband arrived a couple of months ago, it came with a USB
    modem, so I couldn't plug the Linksys wireless broadband router into it. As
    a temporary measure, I connected the broadband modem to the laptop, so the
    Linksys router continued to act as an access point only. The bridge on the
    laptop was configured for wireless and local area connection so that I could
    connect directly to the Linksys box to configure/reconfigure when necessary.

    This set up worked until the laptop hard disk crashed.

    I've made the changes to both machines -- NodeType was not present on either
    but DhcpNodeType has been set to zero and the machines rebooted. Ipconfig
    now shows "Node Type: Unknown" on both machines.

    I still have the problem.

    Regards,

    Clive.

    PS In the spirit of trying to keep things simple, I had intended changing
    the USB broadband modem/Linksys router combination for an integrated wireless
    router/modem in the New Year (broadband modems with Ethernet ports seem
    almost as expensive and integrated units in the UK). I'd value your thoughts.
     
    Guest, Dec 13, 2004
    #13
  14. If I understand correctly, the laptop has XP PRO and is inaccessible from
    the desktop which has XP HOME.

    Windows XP Pro: two policies can be found in Control Panel, Performance and
    Maintenance, Administrative Tools, Local Security Policy (or click Start,
    Run, and enter: gpedit.msc), expand Computer configuration, Windows
    settings, Security settings, Local policies, Assign user rights, then search
    for the two policies named:
    a.. Access this computer from the network
    b.. Deny access to this computer from the network
    Double-click on the second one. It usually contains a SUPPORT user. Some
    third party software adds Guest or some other user or group here.

    If Guest is included, guest access (all users who do not have an account
    with the same username and password on the target computer) from other
    computers is not possible and yields the above-mentioned error message.
    Remove Guest and all other groups or users who should be able to access this
    computer over the network. The SUPPORT user entry may remain in place.

    In the policy, "Access this computer from the network" make sure that the
    group Everyone is included. If not, add it as a new, last line under the
    other entries.

    (above copied from: http://www.michna.com/kb/wxnet.htm)

    Let me know if this helps.

    Carey
     
    Carey Holzman, Dec 13, 2004
    #14
  15. Guest

    Guest Guest

    Carey

    Some success!

    The "Deny access.." policy only had a SUPPORT user in it BUT the "Access
    this computer..." policy was blank. I added a group "Everyone" and can now
    see the laptop from the desktop. Thanks for getting me this far.

    However, the desktop cannot see the broadband connection. I've rerun the
    network wizard on the desktop just in case and reselected "This computer
    connects to the Internet through another computer". I've rebooted both
    machines. The laptop is connected to broadband but the desktop shows a
    standard Internet Connection icon which is "Disconnected". Previously, I
    could see the broadband icon on the desktop.

    FYI -- the broadband advanced properties on the laptop have been set for
    internet connection sharing (all three boxes checked). Nothing is checked in
    the "settings" option. I didn't set anything via this option before (so I
    can't say whether anything was checked previously or not).

    Thanks

    Clive.
     
    Guest, Dec 13, 2004
    #15
  16. Guest

    Steve Guest

    Not sure if this will help but I would delete the network bridge



    I would Disable DHCP in the router



    If you are going to us ICS then Windows ICS will give out the IP address



    If you are going to use a network bridge then you would have to but in the
    Default Gateway in witch I think? Is the Ip address of the USB modem and DNS
    Severs from USB modem you as well the Network card in the desktop would have
    to be set up manual with ip address as well Default Gateway and DNS Severs I
    am not sure if Default Gateway Ip address Is that USB modem or the ip off
    the network bridge



    Steve
     
    Steve, Dec 13, 2004
    #16
  17. What is the IP Address of the router?

    Carey
     
    Carey Holzman, Dec 13, 2004
    #17
  18. Guest

    Guest Guest

    Steve

    Thanks. Problem now solved. See my next response to Carey for full
    explanation.

    All the best,

    Clive.
     
    Guest, Dec 13, 2004
    #18
  19. Guest

    Guest Guest

    Carey

    WE HAVE A RESULT!!!!

    I cannot thank you enough for your help. I went looking on the site
    www/michna.com/kb/wxnet.htm that you referenced in your last reply and it
    pointed me to the "Truobleshooting ICS on Microsoft Windows XP" document from
    Microsoft. Then both you and Steve asked me questions about the router and
    BINGO!

    Here's the final piece of the solution.....

    Set the IP address of the laptop to 192.168.0.1 (the network wizard set it
    to this but I had changed it to 1.92.168.1.100 to be in the same range as the
    router).
    Set the IP address of the router to 192.168.0.254 (from 192.168.1.1)
    Disable DHCP on the router.
    Reset allowable IP range on McAfee firewall on both PCs.

    Laptop now acts as ICS host computer. Desktop picks up IP address from
    laptop, and not the router.

    I now have no idea how my original set up ever worked. Perhaps I hadn't set
    the laptop as an ICS host, but the desktop still managed to find the internet
    connection somehow...

    Thanks again for your help. I am indebted to you (and my kids can now get
    back to instant messaging their friends!).

    All the best,

    Clive.
     
    Guest, Dec 13, 2004
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.