...file is missing or corrupt: <Windows root>\System32\ntoskrnl.e

Discussion in 'Windows 64bit' started by Guest, Aug 22, 2006.

  1. Guest

    Guest Guest

    I'm getting this error at boot.

    Environment: RAID 0+1, WinXP Pro 64bit, 1G Dual Channel DDR2, 4 160G Maxtor
    SATA, Intel 3.0 HP 64bit processor, Intel 945gtp MB, Samsung 970 Digi LCD
    (this matters).

    Crash resulted from my attempting to get a pci-express ATI all in wonder Vid
    card installed. Card was not compatible with OS. I removed it and went back
    to the on-board Intel Video.
    When I went to install the software to that controls the Samsung LCD and
    launched it, my system immediately shut down.
    On restart...the error.

    2 Questions:
    1. Please suggest how to repair this file and boot.
    2. How do I access my data? I pulled one drive and attempted to access it
    from another RAID 64bit system and I shows 240+Gigs and I cannot access the
    data. It is only a 160G drive?

    I think I'm going to give up on the 64bit. Video cards, printers, Acrobat,
    so many things not compatible. It was an interesting ride but now I'm
    concerned about the data.

    Thank you in advance and happy helping!

    Benjamin
     
    Guest, Aug 22, 2006
    #1
    1. Advertisements

  2. Guest

    Guest Guest

    What beta build is that? It's beta of course so reporting the problem is a
    good move, I've seen that error before but it could be caused by a few
    things...looks to me like your drive partition table might be screwy, if
    you're familiar with procedures to format/partition a hard drive I'd say dive
    in since I found it pretty hard to screw anything up permenantly. If not I'd
    say try re-installing Vista using your Intel Video, and you may get the
    option to format and/or partition the hard drive that way, so change your
    BIOS setting to BOOT FROM CD, insert the Vista installation disc and
    re-install.

    BTW I'm not sure if there is a repair option with Vista (Beta 2 of course)
    yet, but with a XP disc BOOT FROM CD and go through the installation until
    you get a repair option, press R for repair and follow the directions logging
    into the copy of Windows to repair and try using FIXMBR...that might solve
    your problem.
     
    Guest, Aug 23, 2006
    #2
    1. Advertisements

  3. There are several very good repair options available by entering WinRE after
    booting from the dvd. Better and more intuitive than with XP.
     
    Colin Barnhorst, Aug 23, 2006
    #3
  4. Several things here are making no sense - the OS is 'Device Independent' so
    any graphics card just needs a driver to be compatible. It is true that some
    drivers come along with the system, while others don't, if you are short of
    a driver I know of no card that hasn't got a 64bit driver, but it isn't
    always easy to find them.

    Your Samsung LCD, however, may not have a 64bit driver - I don't even know
    if it needs one, but that is a possible issue.

    Anything that needs a driver in XP x64, must have a 64bit driver - in Vista,
    it needs to be signed (WHQL).

    Pulling one HD out of a RAID system and inserting it in another, definitely
    is making no sense, what you may achieve is that you risk zapping that
    drive, and perhaps the rest along with it. If that happened there will
    hardly be anything left for you to restore or repair.

    My guess is that you installed a 32bit driver somewhere and that made the
    computer crash at boot.
    You panic'ed and tampered with the RAID and now all is gone!

    Let's hope I am wrong. ( I often am!)


    Tony. . .
     
    Tony Sperling, Aug 23, 2006
    #4
  5. Guest

    DP Guest


    Warren: It looks to me like you're responding to a Vista problem but the OP
    is using Win XP Pro x64.
     
    DP, Aug 23, 2006
    #5
  6. Guest

    John Barnes Guest

    You won't be able to access your RAID from half a drive, so first reinstall
    the same as it was before.
    With regards to the error, it usually means that your boot files are messed
    up, and not a corrupt file. It is missing because the boot.ini points to
    the wrong place or the boot record is corrupt. After you get the system set
    up so the RAID partition is intact, make sure you have the boot priority set
    so you have the drive with your boot files first in priority (physical drive
    first and partition active) Then see if you can see your data from Recovery
    Console. If so, do a fixboot for the boot partition (partition with your
    os) and a bootcfg /rebuild
    Let us know what you get and any problems along the way if you have any.
     
    John Barnes, Aug 23, 2006
    #6
  7. A single drive from a RAID10 setup would be unreadable on its' own.

    I'd probably try a repair install of XP64.

    You should be able to connect another drive into the machine (perhaps
    EIDE), install XP32, add the RAID driver and have it see the entire RAID10
    array as additional partitions, intact.
     
    Steve Foster [SBS MVP], Aug 23, 2006
    #7
  8. Have you tried booting to Safe Mode and removing the monitor driver and any
    ATI software?

    If you know which version of ntoskrnl.exe you should have (it seems you do
    not) you could use recovery console to restore the correct version.

    Otherwise, a repair install of x64 should recover your installation, unless
    your RAID array has been damaged by removing one of the drives.

    The monitor driver, which would only provide information about the monitor's
    capabilities, is unlikely to be the root cause of your problems. I assume
    you have checked the memory and disks for faults.
     
    Dominic Payer, Aug 23, 2006
    #8
  9. Guest

    Guest Guest

    This is Core20, I originated this question; I’m the soul in fear…

    First off, you guys ROCK to spend time on this helping….

    Second, "DP" is very right: The system is NOT Vista. It is a WinXP PRO
    64bit install with 4 SATA drives RAID 0+1 (intel 945gtp board), 1Gig DDR2.

    Drives 1, 2 and 3 of the 4 RAID drives have never been touched.

    In my ignorance, I thought that this RAID configuration would make all the
    drives redundant. Meaning, if I crashed, the data, the same and all of it,
    would be on each drive. So, I could pull out one and boot a second system
    with that drive attached and quickly noticed that that was not going to work.
    STTTUUUPPPIIDDDD...

    There was a ref in the responses that I might have 'zapped' that drive so
    now I'm apprehensive at putting that one drive back in. Drive 4.

    Therefore, what I have is 3 of the 4 drives. I have drive 1, 2, and 3. 4
    is the one I pulled out. Did I mention...STTUUPPPIDDDD...?

    Anyhow, some direction would be clearly appreciated.

    Last info that might matter: I ran an ASR and saved the backup of that
    floppy to my RAID before the crash. Will this help me at all?

    I have the MS Action Pack which is where I loaded the 64 bit in the first
    place...I have the orig 64bit CD.

    What would you guys recommend I do?

    May I suggest that getting my data off is Priority 1. I can repair Later.

    What I was "just going to do before I thought to log in here and see if
    anyone had any ideas" is unplug drive 3 & 4, intel RAID floppy in A: and MINI
    XP CD in the DVD drive, to see if I could access the data on drives 1 & 2.

    I also have Winternals 5.0 (which is NOT supposed to be MS Pro 64bit OS
    compatible). There is another, Hiren’s Boot CD, yada yada.

    One of my Admin friends said that I had to have the orig drive 1 & 2
    installed into a machine, TOGETHER, SIMULTANEOUSLY, TO GET THE RAID ONLINE
    and THEN … boot with a utility to access the data. Yes or No??

    Do I need these drives installed simultaneously in order to access my data?

    Any thoughts on the Primary Objective of accessing and getting the data off
    this RAID 0+1?

    After Primary Objective 1 is accomplished; I note Article ID 887675 that
    pertains to a WinXP SP-2, not 64bit. Thoughts about this repair method for
    the OS?

    How do I get the data off? Please.

    Wow. Anyone who can follow all this…hats off to you…
     
    Guest, Aug 27, 2006
    #9
  10. Guest

    Guest Guest

    If I try Safe Mode; same error.



     
    Guest, Aug 27, 2006
    #10
  11. Guest

    Guest Guest

    Also be sure to get your drivers directly from the manufacturers otherwise
    you might be getting something that isn't going to treat your system very
    nicely. Have you solved your issue yet?
     
    Guest, Sep 5, 2006
    #11
  12. Guest

    Guest Guest

    Oddly, the unit booted.

    I had the win 64bit Pro CD in the drive and the floppy with the correct
    drivers from the Intel site in the floppy drive.

    When I booked it went all the way to desktop?

    Huuummmm...

    Thank you to everyone for all your time!
     
    Guest, Oct 7, 2006
    #12
  13. Guest

    Guest Guest

    what code would I type in at the prompt in repair console for it to run a
    repair install of 64x?

    In the old win2000Pro, if you boot to the CD, it was simple to run Repair.

    In winXP, there isn't the same interface to just hit Repair. I always get
    the dos prompt and I have never actually seen a code to type that will
    "repair" Windows.
     
    Guest, Oct 7, 2006
    #13
  14. Guest

    John Barnes Guest

    At the first option screen where you have a repair option using Recovery
    Console, you want to select install (the other option). After you accept
    the license agreement you will have the option to install or repair one of
    the current installations. That is where you want to select the repair
    option.
     
    John Barnes, Oct 7, 2006
    #14
  15. Guest

    Guest Guest

     
    Guest, Oct 11, 2006
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.