EtherChannel and Sun/Solaris

Discussion in 'Cisco' started by Steven Faulconer, Dec 15, 2005.

  1. Hello everyone,

    I'm having some issues with EtherChannel between a Cisco 3550 and a Sun
    system with a quad port network card (a GigaSwift card) running
    Trunking 1.3.

    On the switch, I setup the ports as follows:
    ------------------------------------------------------------
    configure terminal
    interface range fa0/11 - 14
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 2 mode auto
    no spanning-tree vlan 1
    end
    ------------------------------------------------------------

    This seems to work, however, on the Sun systems I'm getting an error
    indicating that other systems have my MAC Address. I've gone over my
    Trunking configuration with Sun, and they feel I have an issue on my
    switch. Now, I'm a noob with Cisco IOS, so that's not totally out of
    the realm of the possible.

    I used a Cisco guide on setting up Layer-2 EtherChannel and did not
    have any considerable issues, but since it isn't working quite right, I
    must have done something wrong.

    Any advice would be greatly appreciated.

    Steven

    Note, as I said, I'm a noice with IOS, so if you need additional
    information, please provide the command I should run (I'm learning as I
    go). Thanks.

    Output of 'show etherchannel':
    ------------------------------------------------------------
    Cat3550cape>show etherchannel
    Channel-group listing:
    -----------------------

    Group: 1
    ----------
    Group state = L2
    Ports: 4 Maxports = 8
    Port-channels: 1 Max Port-channels = 1
    Protocol: PAgP

    Group: 2
    ----------
    Group state = L2
    Ports: 4 Maxports = 8
    Port-channels: 1 Max Port-channels = 1
    Protocol: PAgP
    ------------------------------------------------------------
    (Yes, there are 2 channels as there are 2 servers configured the same
    way having the same error)


    Output (truncated) of 'show running-config':
    ------------------------------------------------------------
    ....
    interface Port-channel1
    switchport mode dynamic desirable
    !
    interface Port-channel2
    switchport mode dynamic desirable
    !
    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    channel-group 1 mode auto
    !
    interface FastEthernet0/2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    channel-group 1 mode auto
    !
    interface FastEthernet0/3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    channel-group 1 mode auto
    !
    interface FastEthernet0/4
    switchport trunk encapsulation dot1q
    switchport mode trunk
    duplex full
    channel-group 1 mode auto
    ....
    ------------------------------------------------------------
     
    Steven Faulconer, Dec 15, 2005
    #1
    1. Advertisements

  2. Steven Faulconer

    anybody43 Guest

    I'm having some issues with EtherChannel between a Cisco 3550 and a Sun
    You may be confsing EtherChannel with dot1q
    trunking.

    They are completely different concepts.

    In any case the trunking commands are applied
    to the individual interface and not to the channel.

    1.
    Take out the trunk commands.

    2.
    Read about PaGP, figure out if the sun wants
    to (or indeed can) negotiate EtherChannel.

    You could try setting the switch EtherChannel to ON.

    It's been a while since I did this so I can't help in detail
    right now.

    Also worthwhile might be a debug of PaGP
    if that is available.

    Finally, the issue might just be a few leaked frames.
    Maybe they don't really matter.

    Can you look with tcpdump which I think tells you
    IIRC whether frames have been sent or received on
    an interface?
     
    anybody43, Dec 15, 2005
    #2
    1. Advertisements

  3. It's quite possible I'm confusing something. The docs and newsgroups I
    read indicated that EtherChannel was what I was looking to do, so
    that's the direction I went in. I'll do some additional reading.

    Using the Sun Trunking software, I can see exactly what interfaces are
    getting packets, and it works as expected (other than the errors I'm
    getting).

    Thanks for the response, I'll have to read a bit more.
     
    Steven Faulconer, Dec 15, 2005
    #3
  4. Steven Faulconer

    anybody43 Guest

    Some of the confusion may be arising from
    different terminology being used by various
    manufacturers.

    http://www.sun.com/products/networking/ethernet/suntrunking/
    "Sun Trunking 1.3 software allows you to aggregate up to sixteen
    Sun GigabitEthernet adapter card ports or up to sixteen 10/100
    Sun FastEthernet adapter card ports into a single virtual link or
    trunk."

    Cisco call this an EtherChannel. What cisco call a Trunk
    is completely different. 802.1q is the current trunk technology.

    Originally Cisco used their own proprietary protocol
    to negotiate and manage EtherChannel. PAgP or
    Port Aggregation Protocol. There is now an
    IEEE standard for Link Aggregation (802.3ad) which used
    Link Aggerrgation Control Protocol.

    Cisco seem to me to have deliberately blurred the difference
    in their docs. For example they are both referred to as
    EtherChannel.

    So, you want to use 802.3ad and LACP.
    I would remove the "Trunking commands" just to tidy up.


    configure terminal
    interface range fa0/11 - 14
    no switchport trunk encapsulation dot1q
    switchport mode access
    switchport mode access vlan xxx ! <-- set your vlan if not defalt
    (Vlan1)
    end


    # # # # # #
    http://www.cisco.com/en/US/products...tion_guide_chapter09186a00801cdf51.html#25587

    configure terminal
    interface range fa0/11 - 14
    channel-group x mode on ! <----- Cisco-on = Sun-static
    end

    In general it is not recommended to use "on" since
    this can cause problems in the event of a failure
    of some of the links.


    At the end of the day though, if these mesages are recurring and
    if the links are not going up and down, it does point to
    a loop of some sort in the network.

    If the leakage rate of low it may well not make any difference,
    turn of the mesages.

    If you can open a TAC case. If you can't,
     
    anybody43, Dec 16, 2005
    #4
  5. Steven Faulconer

    anybody43 Guest

    Hi,

    I now believe that the Cisco was not in fact aggregating
    the links at all. The combination of the configured mode
    (auto) and the lack of PAgP would result in the cisco
    not bringing up the channel.

    Configure as described in the last mail.

    Here is one of mine.

    sh etherch

    displays the configured channel state.


    ! sh eth det ! - is similar
    switch2#sh int eth
    ----
    GigabitEthernet8/20:
    Port state = Up Mstr In-Bndl
    Channel group = 1 Mode = On/FEC Gcchange = -
    Port-channel = Po1 GC = - Pseudo port-channel
    = Po1
    Port index = 0 Load = 0x00 Protocol = -

    Age of the port in the current state: 49d:17h:02m:47s

    ----
    GigabitEthernet8/21:
    Port state = Up Mstr In-Bndl
    Channel group = 1 Mode = On/FEC Gcchange = -
    Port-channel = Po1 GC = - Pseudo port-channel
    = Po1
    Port index = 1 Load = 0x00 Protocol = -

    Age of the port in the current state: 49d:17h:02m:47s

    ----
    Port-channel1:
    Age of the Port-channel = 49d:17h:02m:47s
    Logical slot/port = 11/1 Number of ports = 2
    GC = 0x00000000
    Port state = Port-channel Ag-Inuse
    Protocol = -

    Ports in the Port-channel:

    Index Load Port EC state No of bits
    ------+------+------+------------------+-----------
    0 00 Gi8/20 On/FEC 0
    1 00 Gi8/21 On/FEC 0

    Time since last port bundled: 49d:17h:02m:47s Gi8/23
    Time since last port Un-bundled: 49d:17h:02m:47s Gi1/2

    It won't matter _AT ALL_ if one end "thinks" Cisco proprietary
    EtherChannel and the other end "thinks" 802.3ad.
    All they each care about is that they load balance frames
    outbound.

    IIRC Suns by default use the SAME MAC address on all ports.
    You need to make sure that you change this OR
    do load balancing on some source address parameters
    on the cisco.

    Or get a better switch that does load balancing on
    IP addess/ports/whatever.

    Quite a can of worms!!!!!

    The 3550 only seems to do:-
    port-channel load-balance {dst-mac | src-mac}
    This goes on the physical interface.

    If your traffic is between two hosts you may be out of luck.

    In interesting wee problem.
     
    anybody43, Dec 16, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.