Error 421 Unexpected failure, please try later

Discussion in 'Broadband' started by Graham J, Aug 20, 2014.

  1. Graham J

    Graham J Guest

    This message appears immediately I send an email. Has been a problem
    since early this morning (20 August) but not previously.

    Tried several things to no effect:

    1) Send from different email accounts, each with its own SMTP server.
    So problem is not related to a specific mail server.

    2) Send from different PC on LAN. New PC uses Outlook 2013, the older
    one uses Outlook 2003. So not an Outlook problem.

    3) Reboot router. So not a DNS problem

    4) Reboot PC (the newer one). So not DNS or PC problem

    5) Check antivirus. New one runs AVG 2014, old one runs AVG 2012. Both
    fully up to date, neither configured to scan outgoing email. Not not an
    antivirus problem.

    However, send from a different PC at a different location, using same
    SMTP server as one of the earlier tests. ISP is same in both cases
    (Zen) - and this sends OK. So suspect some sort of routing issue within
    Zen?

    Can't do any more testing until lunchtime, so any ideas what I should
    look for?
     
    Graham J, Aug 20, 2014
    #1
    1. Advertisements

  2. Graham J

    Andy Burns Guest

    Does your ISP intercept all port 25 traffic and push it through their
    own SMTP servers rather than the one you intended, the way Freeserve
    used to?
     
    Andy Burns, Aug 20, 2014
    #2
    1. Advertisements

  3. Graham J

    Adrian C Guest

    Try Telnet to the SMTP server.

    e.g. http://www.anta.net/misc/telnet-troubleshooting/smtp.shtml
     
    Adrian C, Aug 20, 2014
    #3
  4. Graham J

    Graham J Guest

    Not that I know of ...

    It's Zen at the problem location and at the alternative site where email
    can be sent, so unless Zen intercept traffic for only some of their
    users ...
     
    Graham J, Aug 20, 2014
    #4
  5. Graham J

    Andy Burns Guest

    When telnetting to the desired SMTP server port 25, does it announce
    itself as something you'd expect?
    Wouldn't expect it of Zen.
    someone else intercepting it?

    </conspiracytheory>
     
    Andy Burns, Aug 20, 2014
    #5
  6. You should have googled the error code

    421: Service not available, closing transmission channel
    Basically this means the relay is down or overloaded.
     
    The Natural Philosopher, Aug 20, 2014
    #6
  7. Graham J

    Graham J Guest

    I did, but did not find that. Mostly I found suggestions relating to
    antivirus programs interfering, or a problem with one particular SMTP
    server. Nothing that would affect all the different SMTP servers that I
    tested.

    Both computers have been shut down since my testing this morning, but at
    lunchtime we restarted the more modern PC - and Outlook 2013 sends mail
    perfectly OK. So the problem has resolved itself, without me doing
    anything different to what I already tried.

    Curiously all the other traffic through the same internet connection
    worked fine (I was testing via a LAN-LAN VPN implemented through the
    routers (here and at the problem site).

    Do you suspect that Zen is actually relaying the SMTP traffic rather
    than simply routing it?
     
    Graham J, Aug 20, 2014
    #7
  8. Graham J

    Phil W Lee Guest

    Zen?
    Absolutely not!
     
    Phil W Lee, Aug 20, 2014
    #8
  9. Graham J

    Graham J Guest

    It's occured to me that all the SMTP servers I tried at the failing site
    were hosted by the same organisation - nsdesign.co.uk - so it's possible
    that there was a routing problem between them and Zen. Curiously the
    failing site and NSDesign are both based near Glasgow.

    The location where I got a good connection to the SMTP servers was in
    Norfolk, so it would appear that the routing from Norfolk via Zen to
    NSDesign worked OK.
     
    Graham J, Aug 20, 2014
    #9
  10. Graham J

    Rodney Pont Guest

    I don't think it would be a routing problem since the 421 would come
    from the SMTP server you were trying to connect to. Errors in the 400
    range are temporary ones with an implicit 'Please try later' while 500
    range errors are permanent telling you to go away :)
     
    Rodney Pont, Aug 20, 2014
    #10
  11. The error is received FROM the relay normally so you were connecting.
    Its just saying 'couldnt accept your message'
     
    The Natural Philosopher, Aug 20, 2014
    #11
  12. Graham J

    Graham J Guest

    Very strange that about 10 tries from the failing site (near Glasgow)
    over about 2 hours all failed, whereas one try in the same period from
    the working site (Norfolk) did work OK.

    I never had time to try a mail server not hosted by NSDesign, but that
    should have confirmed the problem to be with NSDesign.

    Next time the problem occurs I will be better prepared to test on a
    wider range of SMTP servers.
     
    Graham J, Aug 20, 2014
    #12
  13. If its a big mail relay it may actually be more than one machine on
    different IP addresses.

    One of them might have been dead and that was the one in the DNS cache..

    I'll give you a strange one. Early days of NT...customer complained that
    'internet was slow and lumpy'. First onsite test revealed *exactly|* 50%
    packet loss.

    Diagnose the problem...Hint: Only Microsoft in its infinite wisdom
    allows this stupid misconfiguration..
     
    The Natural Philosopher, Aug 20, 2014
    #13
  14. Graham J

    Andy Burns Guest

    Two NICs, with a default gateway set on both of them? Though I thought
    it would stick with one until it failed, then try the next ...
     
    Andy Burns, Aug 20, 2014
    #14
  15. If it were fifteen year ago I'd have employed you.;_)
    Award of chocolate one legged bunny.
     
    The Natural Philosopher, Aug 21, 2014
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.