EPROM and EEPROM bios chips

Discussion in 'Computer Support' started by Phred, Jun 3, 2004.

  1. Phred

    Phred Guest

    I was flashing a new bios onto my P3 motherboard (Via Apollo Pro 133
    chipset) and in the middle of the write operation I stood up and trod on the
    power cord. The power went out and now, of course the board wont POST - just
    get a long beep, then nothing.

    I've tried disconnecting everything but the floppy drive and some ram and
    disabling onboard sound (via jumpers), installing an ISA graphics card with
    the same result.

    We have an old device programmer at work (EPROM Burner) and I have the bios
    files on floppy - but as far as I can tell the burner can't write to the
    type of EEPROM I have. It is a Winbond W29C020C, which is a 32 pin DIP
    package, 5.0V program voltage of 256k in size. Could I burn the data to a
    27256 EPROM instead? Are EPROMs and EEPROMs addressed in the same way (in
    read mode)? If this works it would allow me to boot the computer, physically
    remove the EPROM, install the EEPROM and re-flash the bios.

    BTW - the reason I was re-flashing in the first place was because the board
    would only address the first 128Mb of a 256Mb RAM stick, even though the
    documentation I got with the board said it should recognize the full 256Mb.


    Thanks
     
    Phred, Jun 3, 2004
    #1
    1. Advertisements

  2. Phred

    127.0.0.1 Guest

    if they are both the same physical structure (both 32 pin). then you can use
    the eprom temporarily to get your pc booted, then swap it with the eeprom
    for proper flashing.

    so the answer is, it wouldn't hurt to try...

    i've been in your situation. my solution was hot swapping from a working pc
    of the same eeprom type.

    -a|ex
     
    127.0.0.1, Jun 4, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.