Encapsulation failed on 1721

Discussion in 'Cisco' started by Fottach, May 30, 2006.

  1. Fottach

    Fottach Guest

    First, sorry for the long post but I tried to present all needed
    information at once.

    I have a problem with configuration of Cisco 1721 router.
    I just cannot make him to connect it to remote site on BRI interface
    via Dialer.
    This group seems to be my last resort, because I tried all options I
    could think of.

    Final configuration should include 7 Dialers over BRI and one via AUX,
    but for explanation of a problem I made a two sample configurations -
    one without Dialers, which works, and other with Dialers - that does
    not work.

    First, simple configuration which works:

    <========= This configuration works, but without Dialer
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c1721
    !
    enable secret 5 $1$kNa.$P1DUPowaGURYvbKpT.app/
    !
    username remotesite password 7 000055511114444FFFF
    ip subnet-zero
    !
    isdn switch-type basic-net3
    !
    interface BRI0
    ip address 192.168.201.2 255.255.255.0
    ip directed-broadcast
    encapsulation ppp
    dialer idle-timeout 30
    dialer string 0015551555
    dialer-group 1
    isdn switch-type basic-net3
    ppp authentication chap
    no shut
    !
    interface FastEthernet0
    ip address 192.168.50.100 255.255.255.0
    speed auto
    full-duplex
    no shut
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0
    ip route 192.168.0.0 255.255.255.0 BRI0
    no ip http server
    !
    !
    access-list 1 permit 192.168.50.0 0.0.0.255
    dialer-list 1 protocol ip permit
    !
    line con 0
    speed 19200
    line aux 0
    line vty 0 4
    ===========================================>


    And now configuration that does not work

    <========= This configuration fails
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c1721
    !
    enable secret 5 $1$kNa.$P1DUPowaGURYvbKpT.app/
    !
    username remotesite password 7 000055511114444FFFF
    ip subnet-zero
    !
    isdn switch-type basic-net3
    !
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    ppp authentication chap
    no shut
    !
    interface FastEthernet0
    ip address 192.168.50.100 255.255.255.0
    speed auto
    full-duplex
    no shut
    !
    interface Dialer1
    description Connected to RemoteSite
    ip address 192.168.201.2 255.255.255.0
    encapsulation ppp
    dialer pool 1
    dialer remote-name remotesite
    dialer idle-timeout 30
    dialer string 0015551555
    dialer hold-queue 10
    dialer-group 1
    no cdp enable
    ppp authentication chap
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0
    ip route 192.168.0.0 255.255.255.0 192.168.201.1
    no ip http server
    !
    !
    access-list 101 permit ip any any
    dialer-list 1 protocol ip permit
    !
    line con 0
    speed 19200
    line aux 0
    line vty 0 4 ===========================================>

    When I ping RemoteSite I got following output:

    c1721#deb ip pac
    IP packet debugging is on
    c1721#deb isdn ev
    ISDN events debugging is on
    c1721#deb isdn q921
    ISDN Q921 packets debugging is on
    c1721#deb isdn q931
    ISDN Q931 packets debugging is on
    c1721#
    00:14:57: ISDN BR0: TX -> RRp sapi=0 tei=64 nr=0
    00:14:57: ISDN BR0: RX <- RRf sapi=0 tei=64 nr=0
    c1721#
    c1721#
    c1721#ping 192.168.0.1
    00:15:07: ISDN BR0: TX -> RRp sapi=0 tei=64 nr=0
    00:15:07: ISDN BR0: RX <- RRf sapi=0 tei=64 nr=0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

    00:15:10: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, sending
    00:15:10: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, encapsulation failed.
    00:15:12: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, sending
    00:15:12: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, encapsulation failed.
    00:15:14: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, sending
    00:15:14: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, encapsulation failed.
    00:15:16: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, sending
    00:15:16: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, encapsulation failed
    00:15:17: ISDN BR0: TX -> RRp sapi=0 tei=64 nr=0
    00:15:17: ISDN BR0: RX <- RRf sapi=0 tei=64 nr=0.
    00:15:18: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, sending
    00:15:18: IP: s=192.168.201.2 (local), d=192.168.0.1 (Dialer1), len
    100, encapsulation failed.
    Success rate is 0 percent (0/5)
    c1721#
    00:15:27: ISDN BR0: TX -> RRp sapi=0 tei=64 nr=0
    00:15:27: ISDN BR0: RX <- RRf sapi=0 tei=64 nr=0
    00:15:37: ISDN BR0: TX -> RRp sapi=0 tei=64 nr=0
    00:15:37: ISDN BR0: RX <- RRf sapi=0 tei=64 nr=0



    TIA,

    Boris
     
    Fottach, May 30, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.