Enabling Internet Access for 'Limited Account' users

Discussion in 'Wireless Networking' started by Guest, Sep 5, 2004.

  1. Guest

    Guest Guest


    This question has been posted previously but I have not seen an answer. I am
    having trouble enabling Internet Access to users setup as a 'Limited
    Account'. Here is a brief description of the problem and setup:

    Internet Access: High Speed Internet via Cable Modem
    Access Point: NetGear Wireless Router
    Laptop: XP Pro with SP1 and 802.11b Wireless card
    Problem: Users with a 'Limited Account' profile cannot access the Internet.
    They cannnot even ping the router's IP address.
    Workaround: User with an administrator account capability logs on first.
    Then switches to the limited account userid. Now the limited user account can
    access the Internet without problems.

    How can I fix this problem without having to first login as an
    administrator? Please share your solutions. Thanks.

    Guest, Sep 5, 2004
    1. Advertisements

  2. Guest

    Pavel A. Guest

    This seems to be a driver bug, like the config utility or service of the wireless adapter
    fails to work under limited account.

    Or, if you have advanced security setup (802.1x, Radius server, IAS etc), it
    is not properly set to recognize credentials of your limited accounts.

    Pavel A., Sep 5, 2004
    1. Advertisements

  3. Guest

    Guest Guest

    I am having the same trouble with 3 limited accounts on the computer and two
    administrators, the limited accounts can not login to the internet unless an
    admnistrator logs in first.

    I have a DWL 520+ adapter, I have tried the latest software.

    Is it one of the paremeters contained with the driver?

    Any help appreciated
    Guest, Oct 8, 2004
  4. Guest

    Subbarayudu Guest

    I am still having this problem. I have even tried to install the
    drivers under the limited user by providing them administrator
    privileges during the installation process. Internet access works fine
    as long as the limited user is setup with administrator privileges.
    There is no internet access when I switch the user back to a limited
    user. Any other hints or suggestions will be very helpful. Thanks.

    Subbarayudu, Oct 8, 2004
  5. Guest

    Guest Guest

    I am having the exact same problem...has anyone found a solution yet. It is
    not inconceivable that a system would be setup with internet access for
    limited users. It seems to work fine *if* no WEP or WAP. But, I have
    changed this so many times, I have lost count...All I know for sure is that
    for my limited users to access the Internet, the admin has to be logged
    in...very irritating problem...Any help would be greatly appreciated...Thanks
    to all in advance.
    Guest, Oct 27, 2004
  6. Guest

    T. Robinson Guest

    I don't know if it's related, but none of my non-administrators can get the
    wireless network to work at all--Internet or local network. If I give them
    admin rights, it fixes the problem. My setup is....

    -A Belkin Wireless G Desktop Network Card
    -A DLink AirPlus Xtreme G High-Speed 2.4GHz (802.11g) Wireless 108Mbps1
    -Windows XP with SP2

    I tried rolling back SP2, but it didn't fix it.
    T. Robinson, Oct 28, 2004
  7. Guest

    Subbarayudu Guest

    Subbarayudu, Nov 2, 2004
  8. I am having the same issues, with a computer connected via a LinkSys
    Wireless 802.11b card to our cable modem 802.11b router upstairs.

    I see some people say that if somebody is logged in as an
    Administrator, it will work for the limited accounts. That has not
    been my experience. For me, administrators can access the internet,
    but limited account users cannot. For limited accounts, the tray icon
    for the zero-config-wireless shows that I am connected, and that I
    have an IP address, but I cannot browse to any intra- or internet
    resources (sites), cannot ping any addresses by name or IP, etc.

    Anybody have a solution?

    Troy Whistman, Nov 8, 2004
  9. Guest

    Guest Guest

    Guest, Jan 12, 2005
  10. Guest

    Guest Guest

    I have same issues on my system. I have a Belkin Router and wireless adapter
    card. I called them and they told me that the account must have
    administrator rights in order for it to enable the wireless network.

    Go figure, does not make any sense to me that they would not allow a limited
    account user have access to the wireless network/internet.
    Guest, Jan 12, 2005
  11. Guest


    Jul 8, 2007
    Likes Received:
    The Belkin wireless util won't work w/ limited user accounts. Inexcusable.

    The solution: let Windows do it. I'm running XP SP2 and a Belkin Wireless G USB adapter. I think this works for the PCI cards, too. Here's how to do it:

    1. Insert the Belkin install CD and exit out of the installation program.

    2. Go to the Start menu and run the Belkin uninstall.

    3. Unplug the USB adapter.

    4. Plug in the USB adapter.

    5. XP's install new hardware util should find the driver on the CD. If not, Browse to <letter of CD drive>:\FILES\DRIVERS and hit OK.

    6. Access the properties for your wireless connection, add a preferred network and you're done!
    mikeshtown, Jul 8, 2007
  12. Guest


    Oct 30, 2008
    Likes Received:
    Running AIRPLUS.EXE as windows Service

    If you have DLink DWL-520+ Adapter and you want use it with a limited account you have to run AIRPLUS.EXE as a windows service.

    To do this follow instructions that you will find searching in Google:

    "Create your own user-defined services Windows NT/2000/XP/2003"

    If you run AIRPLUS.EXE as a Windows service you will able to run the program over the Local System account even if you log into Windows with a limited account.

    Now you may use your old adapter!

    Bye bye
    Filippo, Oct 30, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.