Enabling a router to act as a frame-relay switch

Discussion in 'Cisco' started by abrink, Mar 4, 2005.

  1. abrink

    abrink Guest

    I'm trying to do some testing in a lab environment, and someone once
    told me that you can actually make a router act like a frame-relay
    switch, and then setup frame between another router. Is this true? If
    so, how do you do it?

    Thanks,

    Andrew
     
    abrink, Mar 4, 2005
    #1
    1. Advertisements

  2. frame-relay switching

    http://www.cisco.com/warp/public/125/frbacktoback_hybrid.html
     
    Doug McIntyre, Mar 4, 2005
    #2
    1. Advertisements

  3. abrink

    Jason Guest

    I used this on the router acting as the FR switch: (adjust the DLCI's
    and serial ports to your configuration.)service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname frsw
    !
    enable password cisco
    !
    no ip domain-lookup
    frame-relay switching
    clock timezone cst -6
    clock summer-time cdt recurring
    !
    !
    interface Loopback59
    ip address 223.1.59.1 255.255.255.0
    !
    interface Ethernet0/0
    ip address 223.1.56.56 255.255.255.0
    !
    interface Serial0/0
    description to r5
    no ip address
    encapsulation frame-relay
    keepalive 15
    no fair-queue
    clockrate 2000000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 504 interface Serial1/1 405
    !
    interface Serial0/1
    description to r2
    no ip address
    encapsulation frame-relay
    keepalive 15
    clockrate 2000000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 204 interface Serial1/1 402
    !
    interface Ethernet1/0
    ip address 192.1.16.6 255.255.255.0
    !
    interface Serial1/0
    description to r3
    no ip address
    encapsulation frame-relay
    clockrate 2000000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 304 interface Serial1/1 403
    !
    interface Serial1/1
    description to r4
    no ip address
    encapsulation frame-relay
    clockrate 2000000
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 402 interface Serial0/1 204
    frame-relay route 403 interface Serial1/0 304
    frame-relay route 405 interface Serial0/0 504
    !
    !
    !
    ip classless
    access-list 1 permit 192.0.0.0 0.255.255.255
    access-list 2 permit 223.1.0.0 0.0.255.255
    access-list 187 permit icmp any any
    alias exec tr traceroute
    alias exec ship sh ip rou
    alias exec crs copy run start
    alias exec deb187 debug ip pack det 187
    alias exec sb sh ip int brief
    alias exec clip clear ip rou *
    alias exec shr sho run
    alias exec sip sho ip pro
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    password cisco
    login
    history size 100
    line aux 0
    exec-timeout 0 0
    password cisco
    login
    modem Host
    history size 100
    transport input all
    line vty 0 4
    exec-timeout 0 0
    password cisco
    login
    history size 100
    !

    and on the router(s) talking to the FR switch:

    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service udp-small-servers
    service tcp-small-servers
    !
    hostname r5
    !
    enable password cisco
    !
    no ip domain-lookup
    clock timezone cst -6
    clock summer-time cdt recurring
    !
    interface Loopback0
    ip address 145.1.5.5 255.255.255.0
    !
    interface Ethernet0
    ip address 223.1.56.5 255.255.255.0
    !
    interface Serial0
    ip address 145.1.45.5 255.255.255.0
    encapsulation frame-relay
    frame-relay interface-dlci 504
    frame-relay lmi-type ansi
    !
    !
    ip classless
    !
    alias exec tr traceroute
    alias exec crs copy run start
    alias exec ship sho ip route
    alias exec clip clear ip rou *
    alias exec shr sho run
    alias exec sip sho ip pro
    alias exec deb187 debug ip pack det 187
    alias exec sb sh ip int brief
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    history size 100
    line 1 16
    transport input all
    line aux 0
    exec-timeout 0 0
    modem Host
    history size 100
    transport input all
    line vty 0 4
    exec-timeout 0 0
    password cisco
    login
    history size 100
    !
     
    Jason, Mar 4, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.