dual boot - NIC fails on XP-32 after loading XP64

Discussion in 'Windows 64bit' started by Frolin Marek, Oct 8, 2008.

  1. Frolin Marek

    Frolin Marek Guest

    Have tried several times to setup a dual boot PC with XP Pro (32bit) and XP
    Pro 64.

    New hard drive, setup 50gig partition 'C' and installed XP Pro 32. No
    issues, loaded, then loaded video and NIC card drivers, upgraded to SP2 and
    even IE7, all working fine.

    Then install XP 64 by setting up second partition drive 'D', 30gig. XP64
    installs fine and auto configures. When done, can access the net and no
    issues.

    And restart and select XP Pro 32 or XP 64, and login, all works ok there.

    But AFTER the 64 is loaded, the XP Pro 32 can not connect to the Internet.
    And testing leads me to thing the NIC drivers are now bad for 32 bit.


    Original installs, I installed XP Pro 32, and drivers for. With working
    system, NIC and IE included, would load XP 64 and load drivers. With working
    system, NIC and IE under 64, would restart to XP 32 and find I could... open
    IE and get to one site then seems the connection would die and never come
    back.

    So I wiped drive, setup 'C' part again and loaded XP Pro 32. Loaded drivers
    and all was well, bounced around Internet, even got SP2 and IE7 and loaded,
    NIC held ground.

    Then loaded XP 64 on new clean 'D' part, configured auto and did not load
    drivers, let 64 do its own setup. All was well, NIC worked fine, got SP2 and
    all ok.

    Restarted and went back to XP Pro 32, tried IE and would open first time
    page, then die...


    If I try to uninstall the NIC drivers and reload, under XP Pro 32, it acts
    like there is no device now. So thus can't uninstall and reload drivers.

    This is an ASUS A8E motherboard, been using fine for couple years with XP
    Pro 32. New hard drive, wanted to try dual booting again, and after 5-7
    clean builds as described above, gave up. Now months later, new HD and
    wanted to try again and having same issue.


    Any suggestions / options / tips / the answer???


    thanks,
    Frolin
     
    Frolin Marek, Oct 8, 2008
    #1
    1. Advertisements

  2. It sounds like the NIC driver installation program is hard coded to C: drive
    and it's overwriting files that are there. I'd suggest downloading updated
    32-bit drivers, and install them from within 32-bit XP.
     
    Charlie Russel - MVP, Oct 8, 2008
    #2
    1. Advertisements

  3. Frolin Marek

    Carlos Guest

    Charlie,
    That is an nForce 4 chipset based motherboard and he might be suffering from
    the unadverted installation of the NVidia firewall.
    NVidia drivers are not hard coded to C: drive but the last part of the
    installation package installs the NVidia network management tool (or
    something like that) which might be causing this issue.
    Carlos
     
    Carlos, Oct 8, 2008
    #3
  4. Oooooh. Good catch, Carlos. You're probably right.
     
    Charlie Russel - MVP, Oct 8, 2008
    #4
  5. Frolin Marek

    Frolin Marek Guest


    Charlie,

    Thanks, that fixed it!

    In past tried to reload the same drivers without success. Loading the newer
    64-bit versions and the newer 32-bit versions (while in the valid 32/64 OS),
    fixed and even improved hard drive response.

    thanks!
    Frolin
     
    Frolin Marek, Oct 13, 2008
    #5
  6. Good! Glad it fixed it, and thanks for reporting back.
     
    Charlie Russel - MVP, Oct 13, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.